Skip navigation

WiFi Issues With MacBook Air

488204 Views 932 Replies Latest reply: Apr 8, 2014 11:34 PM by javedshah RSS Branched to a new discussion.
1 2 3 ... 63 Previous Next
gcrump Level 1 Level 1 (10 points)
Currently Being Moderated
Nov 28, 2010 6:10 AM
I am about two weeks in to my new Macbook Air and love it except for the wifi. I have had five or six other Mac laptops in the past five years including the original air. I can confirm that there are some wifi issues with the Macbook Air. Based on the messages posted here and my experience here is where I am. I think if it is a "N" network it seems to work fine. I have never had an issue with my Airport Extreme at my house or my Dad's Linksys at his house which is also an N. This also I think resolves the "is it an ISP" issue, since they are distinctly different ISP's and these both work perfectly.

My problems are on non-N's it seems. I travel a lot so I hit a lot of guest networks which are almost always "g". These networks I can generally find and attach to them but not get a consistent internet connection. With these networks I have found that turning the airport on/off and refreshing the IP address does not work. Again I can connect to the browser, in most cases get what appears to be a valid IP but not gain any internet access. I have found that a power down and reboot AFTER attaching to the network (but not getting the internet connection) will then give me a steady and consistent connection.

I need to do some more testing and I guess traveling to pin down some of these things but I wanted to share what I have found thus far, but I definitely think there is a problem with the wifi on the new MacBook Air's.

Thanks,
Macbook Pro and iMac 27" and iPad and iPhone and MacBook Air 2010, Mac OS X (10.6.5)
  • Denis Giguere Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 28, 2010 3:07 PM (in response to gcrump)
    FYI, my new 13 in MBA works fine at home with an "older" model of Airpot extreme Base Station (the flying saucer) with the "g" draft specs. I programmed it to recognize the MBA through its mac number.

    However, I am unable to connect in a public spot I usually frequent, even though other people with MBs and MBP can (they might not be on 10.6 yet, I did not check).

    There, AirPort scans the location and identifies some wifi connections available to the public. I choose one of the connections and enter the wifi password. I do, then, get an IP address, but no access to the Internet. A message says that the MBA has an IP address 198.168.etc, but the that internet service is not available.

    I will however try to shut down and reboot after getting an IP address, as you suggested, at my next visit.

    Also, on a recent visit to my brother's place, who has no wifi, I usually plug in my computer directly into his cable-modem. For my MBA, I purchased the RJ-45 - USB adaptor. I had the same type of result: I received an IP address, but was unable to have an internet access.

    I am sorry I can't be of any help, except to confirm this type of problem. I do have a rendez-vous for a one-to-one at an Apple store and hope to get a workaround.

    Best regards, will keep you informed.
    MacBook Air 13" and iMac 2,93GHz Intel Core 2 Duo, Mac OS X (10.6.5), Airport Extreme Base Station (2003)
  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Nov 28, 2010 3:41 PM (in response to Denis Giguere)
    Denis,
    The fact that you get a 198.168.x.x ip address means your wireless is working well.
    Next time you see this occur, go to System Prefs->Network and look up the router IP address and then launch Terminal and type
    ping <router ip address>

    eg: ping 192.168.1.1

    If you get replies, your wireless is fine and you should talk to the network provider if they have some authentication scheme etc.
    Mac OS X (10.6.5), 11"/13" MBA, 13"/15" 2010 MBP, All iOS devices
  • Jersey Andrew Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2010 6:37 PM (in response to wifiguru)
    I currently own a Dell XPS M1330 laptop which I have used exclusively for the past three years. My antivirus protection and extended warranty are running out soon and I am considering coming back to Apple after 10 years away from the fold.

    Very interested in the new Macbook Air 13 inch model but concerned about the reports of WiFi connectivity problems (especially in public networks). I use a Verizon broadband card at home and would continue to do so with a Mac but enjoy free WiFi at Starbucks and Barnes and Noble. Any feedback would be appreciated.

    Andrew
    Macbook Air 13 inch (late 2010), Mac OS X (10.6.5)
  • Denis Giguere Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 29, 2010 7:17 PM (in response to gcrump)
    This is an update concerning wifi connection with the MBA 13" (late 2010) at a public location.

    gcrump: power down and reboot after getting an IP address has nor worked for me at that public location.

    wifiguru: indeed, pinging the IP address displayed in the network window does give me information that the wifi connection is working at that public location.

    Follow-up with the IT guy at that public location: I was told that that the bandwith with their ISP is currently saturated, and to try to connect at some other time. I have no means of evaluating if this is true or not.

    Running the Network diagnosis on my MBA does indeed show that the "ISP" button is red while the Airport, and Airport settings are green, at that public location.

    Tried ANOTHER public location (just walked in another restaurant). I was handed a piece of paper with a password along with the restaurant's menu. I selected their wifi server, punched in the password, and got an immediate and quick connection. They use a Linksys router.

    Will try some other public locations tomorrow, and keep you informed.

    Best regards
    iMac 2.93 GHz Intel Core 2 Duo, Mac OS X (10.5.8)
  • Denis Giguere Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 30, 2010 6:12 PM (in response to Denis Giguere)
    I went to the mall today with my MBA 13".

    - got an immediate and clean wifi connection at the Apple Store;

    - got an immediate and clean wifi connection at two different coffee shops;

    So, the problem that bugged me seems to have been related not to wifi connectivity of the MBA, but rather indeed to ISP problems at a particular public spot. So its a good idea to run network diagnosis.
    And thanks also to wifiguru for the "ping" tip.

    Best regards.
    iMac 2.93 GHz Intel Core 2 Duo, Mac OS X (10.5.8)
  • hajk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2010 8:25 AM (in response to Denis Giguere)
    Took my new 13-inch MBA on a trip last week and had no problems connecting with various WLANs in hotels and at WiFi hot spots. In one hotel, though, I had to remove all DNS servers in System Preferences - Network - Advanced... for the Airport interface before I could actually connect to the internet.
    Mac Mini 4,1; 13-inch MacBook Air 3,2, Mac OS X (10.6.5), 24-inch LED Cinema Display
  • tommclaughlan Calculating status...
    Currently Being Moderated
    Dec 2, 2010 2:46 AM (in response to gcrump)
    Hi - I'm getting the same problems and it's infuriating Until a fortnight ago I used an MBP 17" and had none even though I was using the same wifi connections at exactly the same locations.

    I'm in a Starbucks now and, like yesterday and the day before, I'm getting 1.83 Mb/s (http://www.speedtest.net/result/1053993948.png). I've had one good day (on the home network) when it was at 9.83 Mb/s but within an hour or so it dropped again to under 2Mb/s (http://www.speedtest.net/result/1053201752.png).

    I took the machine in to an Apple Store and the Genius had no idea what was wrong and, of course, it was connecting to their wifi beautifully...... Back home and back to public wifi connections and I'm at snail's pace again.

    The key thing for me, as I mentioned above, is that I do not have the same problems with my MBP. The one different component in my set up now is the MBA.

    Any ideas what to do next?
    MBA 13", Mac OS X (10.6.5), iPad 64Gb wifi, iPhone 3GS 32Gb OS 3.1.3, iPod Touch
  • rikytik Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2010 4:11 AM (in response to tommclaughlan)
    My Mac Air 13" and o/s 4 iPhone 3Sg would not connect to my sisters wi-fi router, but an ASUS portable repeater I had with me would and then I could connect these two devices to the internet. Directly to the router the units acquired IP's and showed as connected in the router setup, but they could not connect to the internet The IP's were usually something like 169.205.x.x No amount of configuring would change this.

    Coincidentally, my sister in Montana who has a new iMac 27" had a similar problem with her router. Her older iMac 21" connects ok. Apple service came out and changed out the wifi card, and it worked for awhile then stopped working.

    Here is what Apple concluded: ++The results are that in this year's Apple computers they have upgraded the wireless (Airport) card in the machines to match the world wide protocols for wireless protection. The ActionTec, which is now at least 3years old (maybe more) is out of date and will not work on the new Apples with the most recent OS X versions. The 2 year old iMac connects wirelessly with it because it has the old card inside.++

    She has a new modem router on order.
    Mac Mini, Mac OS X (10.6.5)
  • guyha Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 13, 2010 1:22 PM (in response to gcrump)
    I am having similar problems with my new MBA. Sitting in a coffee shop a friend sitting beside me with a new MBP logged right in and had good access. I could not get in though the menu bar showed a strong signal. Today, same location, fewer people, I got right in, the speed is good. Does it have anything to do with the number of people logged in and the power of the computer ? I have the basic 11 inch model.
    IBook G4, Mac OS X (10.4.11)
  • Jersey Andrew Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 14, 2010 11:13 AM (in response to gcrump)
    Have had my new 13 inch Macbook air now for 5 days and think it is lightning fast and a sensational piece of machinery. I was concerned about the WiFi issues but have not experienced any problems working on public WIFi networks (Starbucks, Kinkos, Borders). Borders network is somewhat weaker than the other two but I experienced that slowness with my previous Dell as well. Furthermore, my Verizon 3G mobile broadband card is giving me WiFi-like speeds in an apartment building where I have had a notoriously weak signal.

    Andrew
    Macbook Air 13 inch (late 2010), Mac OS X (10.6.5)
  • ianjohn27 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 16, 2010 7:51 AM (in response to gcrump)
    I've had my new MBA for a little over a month now, and I love it. However, I can confirm that there are issues with the WIFI. On the same WIFI network I loaded speedtest.net on my new MBA and on my old 2006 MBPro. I got 9MB/s on the old machine, and only 1.8MB/s on the MBA. Tried multiple times and always the same result. Now, at home I'm having all kind of intermittent connection issues with an Airport Extreme while my wife's ThinkPad has no issues at all. All firmware up to date, all systems rebooted multiple times. And yet I bet tomorrow I won't even think of this issue once. I've tried everything I can think of. It's really frustrating, the MBA is great in every other way. It's like I'm using dial-up!
    Macbook Air 13" 2010, Mac OS X (10.6.5)
  • freezig Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 16, 2010 6:32 PM (in response to ianjohn27)
    Just a helpful tip(s) for some of you. Don't rely on Public Wifi networks to troubleshoot wireless networking issues.

    Also, check out these articles:

    WEP is weak. If you show connected to a WEP network with a 169.XX IP address then: http://support.apple.com/kb/HT1344?viewlocale=en_US

    If you have some slower than expected speeds and it's not related to distance, wireless interference, or being on a public network then:
    http://support.apple.com/kb/TS3361
    MacBook, Mac OS X (10.6.5)
  • ipearx Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 19, 2010 11:49 PM (in response to gcrump)
    I've been having trouble with my work network. Basically it is a dual band network, with N and G, both listed under the same network SSID.

    With 10.6.4 it would behave as follows on both my Macbook Pro 17" 2.4GHz and MacBook Air 2010 13":
    • Connection would be randomly either the N or G network
    • If connected via G, it won't get an IP address immediately, and the internet wont work. It does eventually get an IP address, but no net still.
    • If connected via N, it works fine and stays connected.
    • If connected via G, I turn airport on and off until it connects with N.

    With 10.6.5 for the 17" it would behave the same as above EXCEPT it would:
    • Randomly drop from N to G after a few minutes, and thus the net would cut out.

    I haven't dared upgrade the Air to 10.6.5, as I suspect the same problem will happen. With 10.6.4 it stays conencted using N.

    iPads and iPhones that connect to G don't have any problems. Another 15" recent MBP laptop in the office also has the same problem, I suggest he doesn't upgrade to 10.6.5.

    Now this could be a problem with our office network (I can't change settings on the base station to test) but it sounds like others on the intrnet are having the same issue. There is no workaround that I know of other than, don't upgrade to 10.6.5.
    To discover if you're using N or G, hold option and click on the airport indicator in the menu bar.

    I added more details on the main discussion about 10.6.5 wifi issues here:
    http://discussions.apple.com/message.jspa?messageID=12598357

    Message was edited by: ipearx
    17" PowerBook G4 1.33 AND Macbook Air 13" 2010, Mac OS X (10.6.5)
1 2 3 ... 63 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (34)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.