1 2 3 4 Previous Next 943 Replies Latest reply: Jul 8, 2014 10:08 AM by CB500X Go to original post Branched to a new discussion.
  • 15. Re: WiFi Issues With MacBook Air
    nickbailey Level 1 Level 1 (10 points)
    @wifiguru Please don't give this stock reply as it's just not true in every case. It is particularly not true in this case where clearly the wireless network is working fine for everyone else but not for particular MBA's.


    I experience the same issue - trouble trying to make a successful connection to the internet through a insecure wifi hotspot, but once I do it is completely solid.

    Same thing every day:
    1 - Establish a connection and wifi all day
    2 - Come back the next day and it's unable to connect to the internet - clearly I can see the network, and connect to the router, but it does not establish a connection to the internet (other laptops are working fine, including my other MBP).
    3 - I randomly turn both the router (which happens to be in my office, though I don't own it) and my MBA on and off repeatedly until a connection is magically established.
    4 - Work hassle free on wifi for the rest of the day again.


    SUCCESS:
    I've just followed the advice here:
    1 - leave the MBA connected to network but not internet (wifi logo with "!")
    2 - then Shut Down MBA
    3 - then Boot MBA and connection is established with internet connection.

    So Mr Apple, tell me, how exactly is this a problem with the ISP?


    IMPORTANT OBSERVATION:
    When I have my MBA in it's connected but unconnected state, if I then turn off the wifi router my MBA still sees the wireless network, and still sees it with full strength. This does not go away even after a good few minutes of the wireless router being completely powered off!

    Strange? Just a little. I suspect that the problem IS with the MBA in that it is not correctly communicating with the wireless networks and is certainly not snowing me the truth.
  • 16. Re: WiFi Issues With MacBook Air
    StevieInDerby Level 1 Level 1 (0 points)
    Just to add my own experiences to Nick's post, in the hope that it might help the fog clear for those of us who are currently struggling with this :

    I have an Airport Extreme (c2008) running 802.11g/n which is the wireless access point for my mid-2008 MBP, iPhone 4, and iPad, all of which have been running perfectly well straight from the box. At no point have I ever had any networking issues and the setup of every device has been really easy to do...

    ...until last week when I bought a late 2010 13" MBA (2.13Ghz), which is really struggling to make or maintain any sort of connection with the internet. The symptoms are exactly the same experienced by others in the thread(s) on this forum - connection fine one minute, no connection the next, successful connection to the Airport Extreme and Network, but no connection to the ISP and Server. With Wi-Fi off, ethernet takes a little time to sort itself out but then works like a dream.

    I've checked settings across all devices and they appear perfect - the common settings you would expect to be the same are the same; each unique device has its own unique IP address; all are using WPA2 security; there are no issues with subnet masking and each device is even recognised and accepted by my ISP router (an ethernet based BT Home Hub 1.5). Refreshing the DHCP lease for the Wi-Fi connections has no impact.

    I've run the hardware test on my MBA and - as you'd expect - its 100% functional. I've even checked the RSSI levels for every device and they're spot on - each device is receiving the same signal strength.

    So, every other device on my network is fine. Given that 99% of the settings are the same across all of these devices (unique IP addresses and MAC address being the obvious exception), and that my MBA is the only device which has a problem, I'm of the same opinion as Nick - it absolutely must be the MBA which is the heart of the problem.

    Sorry I can't offer a solution, but I hope that my contribution might help in some small way - in the meantime if I manage to learn any more I'll naturally post my findings here.
  • 17. Re: WiFi Issues With MacBook Air
    John Scott1 Level 2 Level 2 (300 points)
    I have always thought that for some reason Mac's have more Wifi issues. I just bought a MacBook Air and find with my Netgear WNR3500 V1 the mixed mode works fine for days then all of a sudden I lose the connection. Sometimes even requiring deleting the connection and reconnecting. I have tried it in G only mode and see very little difference. One thing I have learned is that different manufactures of WiFi chips don't always work well together. Even though we have plenty of standards that should not let it happen. I have at least 3 or 4 other routers close by and I would not doubt some conflicts with other signals. I see a bandwidth drop more in evenings when more people are probably using their routers.
  • 18. Re: WiFi Issues With MacBook Air
    korowa Level 1 Level 1 (0 points)
    Just to report that my son also has a similar WIFI issue with his new MacBook Air. At the time, there were no issues with the other devices connected to the home network. Maybe the aerial?
  • 19. Re: WiFi Issues With MacBook Air
    Carly Pederson Level 3 Level 3 (955 points)
    Just to add to the discussion... here's what I'm experiencing.

    I have an older Airport Extreme (b/g) providing wifi to my iMac (no problems), iPod Touch, Android phone, and new MacBook Air 11".

    Here are the issues I'm experiencing with the MBA: I can connect to my network and the internet fine, and then all of a sudden there's no internet connection. I'm still connected to the network (Airport status still shows full signal, can connect to the iMac), but no internet access. The only solution I've found to regain internet is to turn Airport off and then back on, on the MBA. Then internet will work fine, and randomly go out again. I can go from 30 minutes to 3 hours, but at some point or another, I always lose internet on the MBA.

    Just to clarify, there are no connection or internet access issues on the other devices, which are connected via the very same Airport wifi. This leads me to the conclusion that the problem lies with the MBA.
  • 20. Re: WiFi Issues With MacBook Air
    nickbailey Level 1 Level 1 (10 points)
    There seems to be three symptoms:

    1) Those who can't connect at all to some networks
    2) Those who's computer says no, but after a restart can connect fine.
    3) Those who can connect fine to a network and then randomly drop the connection for no reason.

    Does anyone think that Apple give the slightest consideration that there might be a problem with THEIR software rather than just saying 'go and fiddle with the router'?

    10.6.6 and I'm still having problems 1 and 2 on various networks, I've not experienced symptom 3 yet.
  • 21. Re: WiFi Issues With MacBook Air
    braddk Level 1 Level 1 (0 points)
    My issue is a bit different

    When im in close to my time capsule it finds my MBA and connects when Im more than 5 meters away it finds my home network but it askes for my password and when I put the password in it saids wrong password!

    Anyone else have this issue?
  • 22. Re: WiFi Issues With MacBook Air
    bluesky00 Level 1 Level 1 (0 points)
    I'm having good luck so far using a D-Link wireless USB adapter with Ralink drivers.

    Full details here:
    http://discussions.apple.com/thread.jspa?threadID=2716146
  • 23. Re: WiFi Issues With MacBook Air
    nickbailey Level 1 Level 1 (10 points)
    We've really got to get away from thinking it's a problem with the router - this is a total red herring, and will keep Apple complacent by letting them think it's not their problem.

    That being said I agree that some routers are better than others (my home configured network kit is clearly awesome and I've never had a blip). But the fact that on a whim our MBA's sometimes connect and then sometimes just give up the connection is a clear indication it's a OS/Airport Driver issue that needs fixing.

    I love Apple in most respects, but they are a complete fail at admitting their own cockups.
  • 24. Re: WiFi Issues With MacBook Air
    nickbailey Level 1 Level 1 (10 points)
    @freezig I'm afraid your post is entirely unhelpful.

    The problem people are largely having is in connecting to networks that they do not own or manage, so how are you expecting them to set the WEP password, reset the router or do anything other than attempt forlornly to connect to the same network that the people sitting right next to them (not on a MBA) are using without a problem?

    If it was a network issue then NOBODY would be able to connect. It is a MBA software/driver issue.
  • 25. Re: WiFi Issues With MacBook Air
    nickbailey Level 1 Level 1 (10 points)
    How might it be the aerial?

    The MBA doesn't have an aerial (not external at least), and if it's a problem with your router aerial then how are the other devices connecting?
  • 26. Re: WiFi Issues With MacBook Air
    nickbailey Level 1 Level 1 (10 points)
    Today totally no success

    I've tried all the resetting and restarting orders I can think of and I'm still sitting here with 100% signal strength connection to the wireless network (router in same room) but 'No Internet Connection' and w!f! icon.
  • 27. Re: WiFi Issues With MacBook Air
    StevieInDerby Level 1 Level 1 (0 points)
    More on this....

    Earlier this week I picked up an old news item (2+ years ago) about Apple identifying compatibility issues between the 2008 MBA and older Airport base stations. At the time Apple recommended changing older base stations to use the 5GHz channels or to upgrade the base station to a newer model, but then the knowledge base article was pulled.

    (Just to recap my earlier post on this page....I have an Airport Extreme (c2008) running 802.11g/n which is the wireless access point for my mid-2008 MBP, iPhone 4, and iPad, all of which have been running perfectly well straight from the box. All software is up to date).

    In desperation I used the airport utility to change the Wireless>Radio Mode setting from "802.11n (802.11b/g compatible)" to "802.11n Only (5Ghz)". Since then I've had absolutely no connection problems with my MBA (though of course my iPhone 4 can't see the network). I've powered up, powered down, slept, restarted, and even tried getting the MBP, MBA and iPad to stream content simultaneously - in every case the MBA is absolutely solid. So...no problems at home now, but not the end of the story by any means.

    I took my MBA out on the road for the first time this week and had some predicatbly frustrating experiences at the two client sites I visited. At both sites, only a few seconds after boot, the MBA found 12-15 suitable Wi-Fi hotspots from the local area. All had great signal strength, but as luck would have it the ones I needed to connect to both failed.

    Separate companies, separate networks, separate ISPs...yet despite having used those networks with my MBP on an almost weekly basis last year, when I tried my MBA I got the same irritating 'can't connect' / 'timeout' / 'incorrect password' errors that other people in the forum have experienced. When I tried a connection at Starbucks on the journey home it worked fine. (And of course, my iPhone 4 worked fine with all three connections).

    At all three sites I option-clicked the wi-fi icon on the MBA to check the detailed network info (physical type, encryption type, RSSI value etc) : no surprise that the two networks which I couldn't connect to were 802.11a/g spec, and the Starbucks was 802.11/n. (Incidentally, when I got home my personal network still worked fine).

    It's the MBA, no doubt about it.
  • 28. Re: WiFi Issues With MacBook Air
    nickbailey Level 1 Level 1 (10 points)
    Excellent research StevieInDerby, that really narrows the net around the MBA's problem.

    Now how do we get Apple to take note of this? Is it worth going to an Apple Store to enquire? (Clearly they'll just show me how beautifully my MBA connects to their store's wifi - grrr)
  • 29. Re: WiFi Issues With MacBook Air
    Captain Quantum Level 1 Level 1 (10 points)
    To add to your list - I have been experiencing a different symptom.

    I have a Time Capsule, my 13" MBA, and two MBPs (my wife's and daughter's). We all connect at 5 GHz (avoiding the rf clutter in our area). All software on all computers (and TC) are the latest.

    Upon waking my MBA I have had several sporadic instances where the Time Capsule is no longer visible on my MBA (including trying to access it via "Airport Utility"). The other MBPs experience a WiFi outage and lose access to the Time Capsule. Turning WiFi Off and then On on my MBA has no effect. Rebooting the MBA immediately brings back connections for everyone.

    Thus, there is no doubt that at least one of the bugs is associated with the MBA's WiFi implementation!
1 2 3 4 Previous Next