Previous 1 38 39 40 41 42 Next 946 Replies Latest reply: Dec 23, 2014 3:12 AM by BlueDares Go to original post Branched to a new discussion.
  • halmac Level 1 Level 1 (5 points)

    I've had pretty much the same problem (connecting/disconnecting and connection timeouts) with my MBA 2011 since of Monday when I upgraded to Mountain Lion.

    What I finally did was that I changed the channel for the WiFi on my router and after that things have been working without any problem.

  • BeastOfTheMidEast Level 1 Level 1 (0 points)

    I just accepted to be miserable. It's definitely a weak antenna. If anything comes out of that letter please update us.

  • omegis Level 1 Level 1 (15 points)

    KextUtility and a copy of v3.2 Snow Leopard kext has always fixed the wifi issue for my MBA

  • Vipul47 Level 1 Level 1 (0 points)

    I have MBA 13" 2010 model, i was using it then i closed the lid and after sometime i opened it and wifi says no hardware installed. Next day bluetooth icon also shows greyed out with a line on it and says not hardware available.I tried resetted the SMC, PRAM/NVRAM but no luck, tried it in the safe mode, no go.Reseated the wifi card, still no go.Deleted the system configuration Plist, no success.Please somebody help

  • Happyplatypus Level 1 Level 1 (0 points)

    I have similar issues but my billion router only work with 2.4 ghz, so how can I change the channel? Thanks

  • mt granny Level 1 Level 1 (0 points)

    If you read through this thread you will discover many different answers that may or may not work. I called my local Mac repair guy and found that for $400 he ships it to Houston, TX where it is tested and everthing but the battery is replaced if needed and warrantied for 90 days. Mine turned out needing a logic board. Came back and still no wifi so it was reshipped (all free this time) and airport was installed/connected.

    No problems since. I don't plan to buy a replacement but wanted to extend what I have a few more years until I see enough product and customer service improvement.

    I hope you find a solution that works for you.

  • yazidatan Level 1 Level 1 (0 points)

    There's a new Lion update 10.7.5 that is supposed to "Improve Wi-Fi reliability for iMac (Late 2009 and newer)".  If anyone's tried this, please let us know the outcome.

     

    My MBA 11in is for now stable, so I'm not updating until I'm pretty sure that it's gonna work.

  • flemlux Level 1 Level 1 (0 points)

    I'm also having the same problem and have found a somewhat "temporary" fix that seems to work on my MBA until it's properly resolved. I have tried to narrow down the problem as much as possible.

    Firstly my machine is a MacBook Air 13 Inch Mid 2012 Core i7 8gb RAM 256MB SSD.

     

    PROBLEM

     

    I get no Internet connection on ANY network (my home "Airport Extreme" network, iPhone personal hotspot including wifi, bluetooth and USB). My old trusty white MacBook successfully connects to all of these.

     

    When I try to connect to any one of these networks it displays an exclamation mark over the Airport icon in the top menu bar and when you click on the icon it displays "no internet connection". Opening network preferences shows "self assigned ip address" displayed.

     

    ACTIONS TAKEN TO RECTIFY

     

    These are the actions i've taken to rectify to date using iPhone wifi personal hotspot and testing connection each time opening Google homepage in Safari and sending a test email to myself using Mail. "Fail" means the network seemed to connect but it self assigns an IP address and has no internet connection.

     

    - Renew DHCP Lease, attempt reconnection - Fail

    - Set MTU manually to 1400, attempt reconnection - Fail

    - Untick "Remember networks this computer has joined", remove all preferred networks, attempt reconnection -Fail

    - Select "edit locations" and add location, adding Wi Fi (in this instance) service, attempt reconnection - Fail

    - Deleted three preference files called "preferences.plist", "networkinterfaces.plist" and "com.apple.airport.preferences.plist", empty trash, restart, attempt reconnection - Fail

    - Attempt all of the above with firewall turned off, attempt reconnection - Fail

    - Turn firewall back on, shows successful conection on airport icon (chain/link icon displayed), email failed to send test emai, Safari timed out loading Google, Renew DHCP Lease, attempt reconnection, SUCCESSFUL CONNECTION

     

    I thought it may have just been a fluke so restarted the computer and once again "no internet access" "self assigned ip address". Turn firewall off, attempt reconnection - Fail, turn firewall back on, renew DHCP lease, SUCCESSFUL CONNECTION.

     

    Does anybody have any idea why the firewall seems to block the assignment of DHCP? "Block all incoming connections" is not ticked in the firewall settings and if the firewall was disabled, shouldn't it connect?

     

    It doesnt explain why it's doing it but its a temp fix for my particular MBA. Why apple....Why

  • rar624 Level 1 Level 1 (0 points)

    I have a 2012 MBA and the wi-fi is vastly inferior to my 2006 ThinkPad -- I can have the two computers next to each other and the ancient one works fine while the MBA keeps losing connectivity.

     

    I've called Apple and brought it to a store and they haven't been able to identify a problem. I think your theory that they have a weak antenna / radio could be accurate. The question is what it takes to fix it (if a fix is at all possible). Unfortunately, it's hard to show that there's a definite problem, and they don't seem to acknowledge that there is a problem at all.

  • Jorgalem Level 1 Level 1 (0 points)

    It's amazing how Apple does not care about us, nobody answer the post. Does some one really care about this? If they continue like this they are going to sink!

  • shabads Level 1 Level 1 (0 points)

    I've got a 2012 MBA which catches every wifi in my building but mine...how am i supposed to rectify this.Sometimes it connects and sometimes it just fails to even acknowlege that i have a wifi while my Sony Viao's catches it easily.Help!

  • The Robby Level 1 Level 1 (0 points)

    Don't worry about Apple sinking. It won't happen so far there are multitude of idiots out there that will go camping outside stores two weeks before the next iCrap debuts. Seems Apple spends more in promoting its products than actually making it work as good as it looks. Apple should be recalling these MBAs by now instead of just keeping quiet. So next time you buy, just pray you are lucky to get the MBA with working wifi - just like me.

  • blazetypes Level 1 Level 1 (0 points)

    I am experiencing the same issue here. This is ridiculious and I am glad i'm not the only one with this problem. My problem seems to be the change in routers. My old router (cox) works fine with the my 2012 MBA, but when I changed providers and went with at&t uverse, i ran in to this problem when i tried connecting to the new network.

     

    My 2012 MBP, ipad, sharp tv and phone connects perfectly with the router, not sure why the air can't do the same! This better get fixed because it's pointless to have paid $2400 for this laptop and not be able to connect to the internet at home!

  • mt granny Level 1 Level 1 (0 points)

    My MBA was not happy with my upgraded Verizon router using a WEP key- neither were the 3 iTouches in our family. I went to Verizon's site and figured out how to access my router in Sarafari so I could change it back to a WPA2 key. No more dropped connections.

    Although this might not be your answer it may be worth a try.

  • HalfGenius Level 1 Level 1 (0 points)

    Found a working solution. Turned off the security settings - no WEP or WPA/2. Haven't dropped the connection since.

Previous 1 38 39 40 41 42 Next