Previous 1 48 49 50 51 52 Next 947 Replies Latest reply: Aug 26, 2015 5:05 PM by gweis99999 Go to original post Branched to a new discussion.
  • Yeh78 Level 1 (0 points)

    I got that wifi issue (MacBook air 2012) just today during a meeting (...). I just tested the MTU option set to 1453 (instead automatic mode) and it seems to work (for at least the last 15mns).

    We really need an apple fix on it asap.

  • SouthLake1 Level 1 (0 points)

    sokratov wrote:


    I also have problems with 5GHz on Mid 2011 MacBook Air (10.8.2, with all the Software Update-suggested firmware changes). MBA connects to the network with transmit rate 300, but very soon the transmit rate drops down to 14 or something (does not disconnect though). Not always I can open a web page with such speed. No such problem with 2.4GHz from the same router (different SSID) - stable transmit rate around 130-140 all the time.

    Manual setting of the MTU on the wifi card was mantioned in here. How can I edit those settings? Windows computers work fine. The router is ASUS RT-N56 (sorry, could not affort TimeCapsule). And having seen various posts fro other discussions in here this is more likely either problem with AirPort Extreme or with Mountain Lion...


    i think this is worth repeating here.

    i believe this is an N (5GHz) issue that is either related to the latest ML update or latest AirPort update that our macs underwent.


    Switching your router to transmit / host G (2.4GHz) wifi only should resolve this issue as it would appear your experiencing the exact same thing i did as far as behavior. 

  • sokratov Level 1 (0 points)

    Yes, this is how I use WiFi - 2.4Ghz network from the 2 transmitted by the dual-band router. Which AirPort update is under suspicion? I am not using AirPort (if this is something different from the firmware of the AirPort Extreme card of the MBA), though have the utility installed due to not too successful attempts to play music through AirPort Express. Should I uninstall it? Can someone confirm that 1453 for MTU in router really help? I can do it. Just do not want to change too much at the router side. Others are happy with the existent set-up/selected options, only my MBA is not.

  • mdiorio Level 1 (0 points)

    The MTU change didn't help in the long run. If you want to try it, you do it on the laptop, not your router. Don't mg it on the router would cause fragmentation of packets to your isp and slow your connection, which could interfere with voip traffic as well.

  • sokratov Level 1 (0 points)


    But where can I change it on MBA? Another "alt" trick or a line for Terminal would be very appreciated

  • Mathiesen1 Level 1 (0 points)

    See the answer in my post on page 49.

  • Dutchson Level 1 (0 points)

    I have been struggling with this issue as well. I have tried all the things listed, and none of them have worked for me either.

    But I think I have found a solution that may help some others...


    It would seem that the problem should be a wireless connection issue. But for me it wasn't - it ended up being an outdated program that was "hijacking" my connection (for lack of better terms). I had noticed that there was an icon in my tray for a program called LogMeIn. It has connection to the Internet, so I decided to uninstall it. Once I did that, all my problems disappeared immediately.


    I don't know exactly what happened, or why these programs were closing my Internet connection, but uninstalling this type of program has worked for me in the past and it worked for me this time as well.

  • CuriousMarc Level 1 (0 points)

    I could not join a public WiFi (Macbook Air 13" 2011) - connection timeout error after it actually works for a second or two. My iPad could join the same network, no issue. Since in a case like this I have no access to the router, is there a way to force the Mac adapter to use 2.4GHz only?

  • sokratov Level 1 (0 points)

    I do not see such program in my computer. But can believe that something from system is not compartible only with 2.4GHz. May be some utility can show what is actually involved into such communication?

  • Jorgalem Level 1 (0 points)

    I think that the real problem is how the web page works. I have seen that in some pages like it occurs that internet conecction freezes, if you close that page and change to there is no problem. Some times it occurs on and in


    Maybe is my imagionation, but i really think that the probles is the web page display format rather than the wifi card. Another thing that make it difficult to connect is when you are using a b/g router only. It need to bee a/b/g/n to work properly, better if it is only N router. Give a try too. Since i used an airport express my wifi problems went off except when i visit the pages i mention early in this post.

  • sokratov Level 1 (0 points)

    Strange, but the 5GHz connection works now, with µTorrent running. I would not consider it very stable (the transmit rate is dropping down and up again), but mainly stays at 300. And no discunnection for almost hour (I am downloading 20 Gb, 14 is already in here). The only other change in set-up - the file is downloaded to external thundebolt drive. Do not recall any system update since last unsuccessful try with 5GHz WiFi.

    In my view this means some software problem - like dropping connection with router when no active connection is recognized by the system.

    Someone else can check if it would work with heavy traffic?

  • Mathiesen1 Level 1 (0 points)

    On page 49 I promised to return when I had found a solution. I have found one that works for me.


    First  I would like to sincerely thank the 10+ geniusses at the Millenia in Orlando and at the Florida Mall, also in Orlando, for their patience with me and for taking this matter seriously and being very persistent in trying to help find a solution.


    Everything that could be done softwarewise was tried with no luck. A complete clean reinstall was made and yet the problem persisted. Then the logic board and wifi card were changed resulting in new hardware issues. Then the MBA was changed to a brand new one but still the problem didn't go away. Then I partioned the SSD in two equal sizes and purchased and installed a copy of Windows 7 Pro on one of the partions with the help from Bootcamp. In Windows 7 on the MBA I have no issues at all, so now when I have to use a wifi connection that OSX doesn't like I just switch to Windows 7 and keep working. I have been in the process of shifting to platform independent software for some time now so this is not a problem for me. Because of the SSD the switch happens very fast.


    My conclusion is that this could be a software/firmware issue and that I am sure that Apple is working hard to find a solution that will be included in a future update.


    I'm very glad that I have Applecare. I bought a new one for the new MBA and 1-800-apl-care were very helpful with issuing me a prorated refund for the old one.


    Best of luck to you all.

  • SleeveMonkey Level 1 (0 points)



    This fixed the extremely slow wifi speed on my brand new MBA. There were multiple other wifi hubs using channel 11. I switched to a channel that didn't show in the airlock list (2) and my wifi speed went up from 1,2Mb to >50Mb.


    Stange thing is that my 2010 MBPro (with exact same settings) wasn't effected at all and has speeds of >50Mb for both my old channel and my new.


    Thanks again,


  • UpsetMad Level 1 (0 points)

    I'm on my second brand new MacBook Air for reason of this discussion thread, connected with AppleCare man named Chris who solved it.


    You may not have the same issue but I was getting locked and blocked from Internet and symptoms sounded a lot like all these. Do this:


    In Sys Pref / Network, read Status (if you think you're connected but the computer is acting as if you're not) for the IP address. If it shows this number -- 169.254, that's bad. It hasn't recognized the correct IP. So either unplug your router/modem for a minute, or go to Advance, then to TCP/IP, and click on 'Renew DHCP Lease'. 


    After many wasted hours, he helped me in five minutes. Also is sending me particulars re the area of support that addresses this. I like the second solution, of course, for those times you're out and have no control over modem/router.

  • UpsetMad Level 1 (0 points)

    I have to amend the above post! Remember, this is an off-the-shelf MBA. The AppleCare fix I lauded in previous comment did NOT hold; without much on-line work, the computer slowed down and locked again, with the search bar partially filled in. So I pulled up my research from this discussion forum and tried two more things you guys suggested. One -- don't remember who recommended this -- is working like the luckiest of charms. That was to go to Location via Sys Pref / Network, and change it to 'internet' from 'automatic'.  Wow. So this is what speed is like on-line. I'm going to keep at it until I snore over the keyboard and will only come back on if it, too, fails. I was all set to take this baby back to the store and try either nothing or a MBP, but maybe won't have to.


    It is not supportable, however, that customers have to poke around (i've spent 14 hours on this now) and find Apple's bandaid solutions for them.

Previous 1 48 49 50 51 52 Next