6 Replies Latest reply: Dec 31, 2010 11:59 AM by Matthew L. Smith
Wunderboy Level 1 Level 1 (15 points)
My 1st Gen MBP circa 2007, had no issues sleeping automatically. Brand new MBP 17" hates to. Same software installed and same OS.

I have searched and searched but cannot find a solution. I have deleted preference files, repair permissions, unplugged all peripherals and I cannot get it to auto sleep. I can manually get it to sleep no problem. Apple even replaced the logic board.

I decided to look into my logs and I notice that when the auto sleep event should take place, there is no indication in the log messages that the MBP even tried to go to sleep. I would assume that there would be some kind of message indicating MBP tried to go to sleep, but no. The only msg that is consistently there around the time I would think it should sleep is..

11/28/10 10:19:15 AM System Preferences[371] .scriptSuite warning for result type of command 'timedLoad' in suite 'SystemPreferences': the type NSNumber ('long') doesn't match the result Apple event code ('doub').

I have tried to find out what that means with no luck. I was hoping that I would discover something preventing my MBP going to sleep but no. The weirdest thing is that this new MBP is used exactly like my old MBP, with same software and utilities installed. It always liked going to auto sleep.

Of course, this isn't a very bad problem and I just have to remember to manually sleep my machine, but it is a perplexing problem. Obviously, the hardware change has something to do with my new machine not liking to auto sleep over my old machine.

Any input would be appreciated.

2010 MBP 17" i5 4gigs, Mac OS X (10.6.5)