9 Replies Latest reply: Dec 27, 2010 12:44 PM by Stephen Kelner1
bobio Level 2 Level 2 (310 points)
I have been using my HP LaserJet 1200n with my G5. The ethernet cable from the printer is plugged into my Airport Extreme Base Station. On the G5 I have checked the box "Share this Printer", and its location is given as "Local Zone". I have added a new Mac Pro, and want to use the LaserJet with it. I will be getting rid of the G5. The problem I am having is that I can not get the Mac Pro to "find" the LaserJet on its own. IF I have the G5 turned on, then and only then will the Mac Pro print via ethernet to the LaserJet. In this configuration it lists the Laserjet "@ G5". With the G5 turned off the Mac Pro Systems Prefs list the LaserJet as "idle", but when I attempt to print the Mac Pro searches for the LaserJet with no results. How do I fix this? Thanks!

Mac Pro Quad Core + iMac Intel 2.16/2 +Macbook 2.2/2, Mac OS X (10.6.5), iPod Touch, 2G
  • Bruce De Benedictis Level 4 Level 4 (1,690 points)
    You should be able to add this printer as a JetDirect printer. I do not know whether it supports Bonjour, but if it does not, your best bet is to configure the printer with a fixed address within the network subnet. That is, if the router address is xxx.yyy.zzz.0, then configure the printer with an address like xxx.yyy.zzz.30, where the letters are the same numbers in both addresses. Then add the printer using the JetDirect protocol and that address.
  • bobio Level 2 Level 2 (310 points)
    Thanks, but due to my lack of experience, I do not understand. How would I configure the printer with a fixed address? I do remember seeing somewhere that this LaserJet, although ethernet enabled with a box on the back, lacks many features of newer printers.
  • bobio Level 2 Level 2 (310 points)
    I've got it! I've had the thing so long I forgot that it also has a USB port on the printer, which now works fine. The problem with the ethernet is that it is an old AppleTalk printer and that is not supported in 10.6.
  • J Darrel Stickler Level 1 Level 1 (10 points)
    If I could pile into this thread. I have the exact same situation with my new iMac 10.6.5, my G5 and a Laserjet 2100M with an ethernet port. I have sent the G5 to the recycler. I also had the @G5 message when the G5 was connected. Now it's gone, so I deleted that printer from the iMac.

    My iMac hooks to a Linksys router as does the printer. I've read the Apple posts about entering IP manually, but I only know the routers IP address, not the printer itself.

    How do I configure the printer with a fixed address within the network subnet. I rummaged around in the Linksys and can't figure out how to ask it to ping its ports or tell me how to id a port.
  • greg sahli Level 7 Level 7 (24,795 points)
    ping is an endpoint to endpoint query protocol - the router only passes the messages through...

    You should be able to find the printer's current IP address with this help:
    http://h30434.www3.hp.com/t5/Printer-networking-and-wireless/LaserJet-1200-IP-Ad dress/td-p/14764
  • J Darrel Stickler Level 1 Level 1 (10 points)
    yes. after I posted, I found an HP post about holding down the two buttons and getting a printout where the printer self identifies its IP address. It's done no good. I can add the printer manually via the IP tab) and Print Utility just says it can't connect to the printer when I try to print. I haven't been able to do the thousand monkeys typing thing by plugging the printer directly into the iMac ethernet port. Nothing I've tried works. I wish I could instruct the router to tell me what IP addresses are assigned. I suppose x.x.x.100 and 101 (iMac wireless and the printer wired)? It seems criminal to throw out a perfect ok laserjet printer.
  • Bruce De Benedictis Level 4 Level 4 (1,690 points)
    If you add the printer, you need to choose HP JetDirect to add the IP address, not the default IP address method. The HP address uses a different port. If you do that, and the first three numbers of the printer address are the same as the router address, it should work.
  • J Darrel Stickler Level 1 Level 1 (10 points)
    Good news and bad news.

    Good news: I got it to work
    Bad news: It worked after about 4-1/2 hours of reading Apple and HP posts and printer manuals, and I really don't know that I did anything different I didn't do at 20 min.

    To document for anyone that might search...

    With a Laserjet 2100M or 2100TN connected through a Linksys router, I think what was key is to unplug and restart every network device several times, including the router itself. That's the only thing I can think of that might have made it work this time since I was doing the random monkey thing.

    Pushing both buttons simultaneously on the printer gets it to divulge its IP address, but I realized I can look at my router in the browser and see where it starts assigning IP addresses (...100 in my case) and if worse came to worse, just configure a bunch of printers with ...100, ...101, etc up to the number of devices on the network since you don't know what got assigned what address (it's unrelated to which of the four ports a device is plugged into because of the wireless devices).

    So you can go to the printer menu, I right click on the existing printers and clear all the printers, then hit + and then go to IP menu and pick the jetsocket choice, type in the IP address. The very last (successful) time, it knew what the printer was and picked the drivers (instead of generic postscript or PCL like it had 50 times before).

    Again, I think it's the rebooting and unplugging or turning things off to force them to do a little comms handshaking. Depression to elation, all over a printer. We're just pawns in the grip of multinational hegemony. <joke>

    Message was edited by: J Darrel Stickler
  • Stephen Kelner1 Level 1 Level 1 (5 points)
    I had a similar problem with our iMac network. After an hour and a half of fiddling and checking, here's what I did:
    1. Get the "Configuration" page from the 1200n, which I did by pushing the tiny button on the printer's wireless router.
    2. Check the IP address. Strangely, mine had shifted from xx.xx.xx.6 to xx.xx.xx.7, which may have been the problem.
    3. Open System Preferences/Print & Fax and press "+" to add a printer.
    4. Select "HP Jetdirect - Socket"
    5. Enter the IP address in "Address"
    6. Wait for it to find a driver - it should be "HP LaserJet 1200".
    7. Select the "Add" button. You're good to go - or at least we were!