Previous 1 2 Next 17 Replies Latest reply: Oct 23, 2011 3:25 PM by lisa-jayne3
JamesRene Level 1 (0 points)
I am having problems with my iPhone 4 not being able to send MMS, on contract with O2. It is only less than 2 months old.
The guys at O2 have no idea why this is happening as all my settings are correct, even the Apple tech guys are at a loss... could this be a bug in the update? Or something to do with the O2 carrier settings?
Any help would be much appreciated

J.

iMac 3.06GHz, MacBook Pro 2.66GHz, Mac OS X (10.6.4), iPhone 4 16GB, iPhone 3G 8GB, Powerbook G4, 1.67 GHz, iPod 8GB Classic
  • ke11111y Level 1 (105 points)
    Hi, my Dad had a similar problem on his and it turned out he had the mms switch turned off. You've probably already checked this but I thought it was worth a mention. Settings/messages/mms messaging.
  • Stinkycheeseman Level 1 (15 points)
    My wife and I are having the same challenge, as are others who have posted in the O2 support forum. Still no solution though. Hope it's sorted ASAP as I use MMS a lot.
  • JamesRene Level 1 (0 points)
    Hi.
    Cheers for that, you know what... my friend actually said the same thing to me, when i checked... it was switched off, but when i tried again with it switched on, it still didn't work, very sad. Oh well Thanks anyway
  • JamesRene Level 1 (0 points)
    At least i am not the only person with this problem. Hopefully it will get solved sometime soon!
    Cheers for that anyways
  • sarush Level 1 (0 points)
    I updated my iPhone 3GS to 4.2 last night. This morning, I couldn't select MMS from the photo library or go into my texts and select the camera icon. After doing a few quick searches all I found were posts like these.

    Oddly enough, I don't have an MMS option in my messaging settings...it seems preposterous Apple would turn off MMS or make such a weird error in an OS update...and then I thought, duh, restart your phone. I always forget to do that when updating my iPhone.

    So, just restart the phone. All the normal MMS options showed up. Hope it works and you all aren't experiencing some other issue.

    Message was edited by: sarush. Screwed up the MMS acronym.
  • Jon Coley Level 2 (200 points)
    I'm having the same trouble with my iPhone 4 on o2 as well. Although, it only seems to be a problem with pictures taken on the phone. When I've tried to MMS an image copied from Safari, it sends no problem so I can only think it's something to do with the MB size of the image taken by the iPhone but I was led to believe that the iOS 4 update allowed MMS messages of up to 2mb to be sent.

    Another thought is, should I have a good 3G connection in order to send a largish MMS? Where I live, there is no 3G reception.

    Jon.
  • wegras Level 6 (15,070 points)
    There does appear to be a problem with the latest O2 carrier settings
    O2 recommend until sorted
    Settings>General>Network>Mobile Data Network>MMS
    reset ......MMS max Message size to 307200

    This has worked for most people reporting issue on the O2 User Forum

    although as usual initial issues raised had the Usual O2 response ....Oh its Apples problem
    they have now it appears worked out it is their carrier settings causing a timeout on sending
    a MMS up to the size allowed by the original setting
  • Stinkycheeseman Level 1 (15 points)
    Great! That worked for me!
  • Jon Coley Level 2 (200 points)
    Doesn't work for me unfortunately, when I hit reset the Max Message size stays at 2097152. However, my theory of it needing a 3G connection seems to hold water. I tried to send a photo from my phone this morning and had a good 3G connection from work and it sent without a hitch but I have to disconnect any wifi connection for this to work.
  • wegras Level 6 (15,070 points)
    You are not saving it
    Look here the issue is the size set by O2 carrier settings .
    http://forum.o2.co.uk/viewtopic.php?f=3&t=56353

    Once you actually change size it should work
  • killhippie Level 3 (765 points)
    I had that issue but it seems to have gone now, mms also had been disabled at O2's end after the update somehow. Anyway its working now, maybe O2 got things sorted.
  • philg1824 Level 1 (5 points)
    Many thanks!! Worked for me. Phil
  • wegras Level 6 (15,070 points)
    Cheers
  • can't send mms without 3g area Level 1 (0 points)
    I recently purchased a i phone 4 out off the 02 shop and i had problems sending message at 1st and then i just kept mucking about with it then when there was a 3g signal on my fone the mms messages were sending ok, but i've not known u must have a 3g signal before u can send a message to a network?

    so you must have a 3g signal in the area ur in to send a mms!
Previous 1 2 Next