Skip navigation

How to reset forgotten Restrictions password with iPhone restore?

1027853 Views 374 Replies Latest reply: Apr 5, 2014 5:00 AM by Lawrence Finch RSS Branched to a new discussion.
  • Slimjoey14t Calculating status...

    A quick respring, not restore. FU auto correct. Lol

  • amaksoud Calculating status...

    I have to admit that you, Lexandsson have saved my life.

     

    A few weeks ago I put a restriction on my daughter's iPad 2 to prevent her from doing in-app purchases and eventually I forgot it .

     

    The iPad is jailbroken and running iOS 5.1.1 and since the post that Marcin2011 did is not applicable for iOS 5.x, I was really trying to figure out a way of getting it removed without having to restore the iPad and install tens of games again on it.

     

    I followed the steps you posted on your link with a minor change, which is that I didn't do the following steps

     

    1. open iFile on your device
    2. open file /User/Library/Preferences/com.apple.sprinboard.plist
    3. switch off SBParentalControlsEnabled

     

    I simply bypassed them then followed all the other steps to the letter and viola, the passcode was gone.

     

    So, as yo mentioned that you are not sure if the iPhone/iPad needs to be jailbroken or not, I guess it will work with non-jailbroken iDevices as well.

     

     

    Thanks once again, you will be a hero for lots in here, including me

  • propermee Calculating status...

    Good afternoon Boz,

     

    I read your post where you thanked someone for listing the steps you take to reset you restrictions passcode.  Looking through the posts, I am unable to find where the steps are listed.  I did see where you re-listed some steps that began with -Backup, however I don't seem to be able to located where to find that option on my I4.  Do you have a moment to go through this with me? 

     

    Thank you in advance,

     

    Propermee

  • badal38257 Calculating status...

    This worked perfectly for my 3gs.  Thank you so much.

  • zannie Calculating status...

    So after 4 failed attempts I made it almost all the way through your steps and got to the part where I was going to enter in the

    5.THEN BELOW COUNTRY CODE AND US AND BELOW DICT TYPE IN:

    <key>SBParentalControlsPIN</key>

    <string>1234</string>

    THE 1234 IS THE NEW RESTRICTIONS PASSCODE

     

    and I was thinking I'll never figure this out.  So for the heck of it, I thought well I will just try that 1234 code before doing all this...... and volia it worked.  i don't remember ever setting it and none of my stuff was even set to be restricted, it just bugged me the restrictions was on haha.  so anyway, thanks hopefully i don't ever have to actually do this

  • rharve Calculating status...

    After the usual struggle it finally worked. simple and effective. Just copied

    <key>SBParentalControlsPIN</key>

    <string>1234</string>

    with ibackupbot on my pc to the file backup file Library > Preferences > com.apple.springboard.plist.

     

    I pasted it at end and it was automatically moved to the right place in the list view.

     

    Restored with the edited backup, went to restrictions and entered 1234 and it worked.

     

    Thanks all!

  • LisaNorene Calculating status...

    I think this MAY resolve my problem of a mystery restrictions passcode. I too, only remember wanting to "turn off" my App Store notifications. I have a book I store ALL my passwords in, but nothing recorded for iPhone App Store. I've already made 9 attemps with all the 4-digit codes I normally use with no success. I'm told on the 10 failure I will have no other choice but to restore NEW. My biggest fear is losing ALL of my Contacts! I am also locked out of iCloud &amp; Twitter, so still not sure if this will work, but I'll give it a try.

  • x_master Calculating status...

    now sorry to say but this thing didnt work out with me... i dont know y but when i try to restore the new edited backup on iphone 4 the same says that the backup is corrupt or not this device.. so help me resolving it...   BigBopper66 if u can plzz tell me what m i doing wrong in it???    

  • tmulle Calculating status...

    I can confirm this worked on OS 5.1.1. I just did this because I too forgot the password for Restrictions.

    Funny thing is that I tried to "Rest back to Factory" and it wouldn't let me because I needed the "Restrictions" passcode!! So, I was stuck...

     

    Thankfully, I found this solution about adding in the missing section in the preferences file.

     

    Thanks to all who found this out..

  • audiorack Calculating status...

    I have an iphone 4 on ios 5.1.1  and had the same  problem with a corrupt backup. So I decided to take a simpler approach.

    So here are a few simple steps:

     

    1. Backup the iPhone on itunes

    2. Using iBackupBot, open the backup folder and access file named Library/Preferences/com.apple.springboard.plist

     

    All that you need to do is to turn off restrictions. Look for SBParentalControlsEnabled Change the <true/> to <false/> in the following lines:

     

     

    <key>SBParentalControlsEnabled</key>

              <false/>

     

    After making the change --> SAVE in ibackupBot and  restore from iTunes.

  • LisaNorene Level 1 Level 1 (0 points)

    Well folks, after MUCH worrying over losing my contacts, I have reset my iPhone. First I backed up to my MacBook laptop ("computer") with iTunes. Then, after confirming (finding) my contacts were in my Address Book, I backed that up to an external drive, just in case. While still connected to iTunes, I reset all to factory settings. When prompted, I sync'd with my backed up contacts, calendar, iPhoto pictures and iTunes music. Viola! I think I've got everything. I manually set up my email accounts and only have to delete a few duplicate contacts. Thank goodness this worked. I didn't know how to find those files others mentioned in this thread. This worked for me. First thing I did was set up my iCloud to assure future backups. I was previously locked out of iClouds, Apps and my email account settings. Now NO MORE PASSCODE RESTRICTIONS!!! Yay!

  • Aepfelchen Calculating status...

    Yeah!!!!!!! It worked on my 1st generation ipad (not jailbroken) with iOS5.1.1 without any problems! I just added the changes you mentioned (set the failed attempts to 0 and added a PIN code), connected the ipad to itunes and restored the ipad from backup. It was super easy! A big thank you to all who helped finding a solution for this!!!!!

  • momblessed3x Calculating status...

    This worked for me!!! I was about to give up until I came upon your post.  I had already looked in my back up files and searched all around SBParentsControlPin and there was no number to be seen. I took your advice and went back to look for numbers that would be followed by a T and there it was!!! THANK YOU SO MUCH May_Day!!!!!

  • TheDonnieB Calculating status...

    Thanks to Everyone for this solution!

  • Dottore de Funk Calculating status...

    Worked for me too! Thanks so much to everyone.

1 ... 7 8 9 10 11 ... 25 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (18)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.