Previous 1 8 9 10 11 12 Next 408 Replies Latest reply: May 3, 2016 5:44 AM by britanniefrombeaverton Go to original post Branched to a new discussion.
  • Rat09 Level 1 Level 1

    Mrcoffey this procedure work on not jb iPhone 4?how and can I download this ibackupbot?waiting on your reply,thanks for the info.

  • Rat09 Level 1 Level 1

    Mrcoffey this procedure work on not jb iPhone 4?how and where can I download this ibackupbot?waiting on your reply,thanks for the info.

  • tallPablo Level 1 Level 1

    Many thanks BigBopper66! Worked perfectly on my iPod running iOS 5.1.1. That was a stroke of genius thinking to just add the PIN entry back in!


    Everybody else. All the answers to recovering your Restiction PIN, including detailed step-by-step instructions and download links, are already covered in this thread. Just use the 'Previous' button below!

  • MorayMcC Level 1 Level 1

    If ibackupbot doesn't work for you and/or you don't want to jailbreak, then you can do this manually with a great deal of effort.


    Here is an outline step-by-step  - for VERY ADVANCED USERS ONLY - it would take me too long to describe everything for users who aren't familiar with hex-editing files.




    You will need

    1) a hex editor - I used the one from

    2) an online SHA generator - I used

    3) a plist editor - I used this one -

    4) a successful unencrypted backup to disk (not icloud) of your device


    Outline step-by-step

    1) iTunes should be closed

    2) Find the directory with your latest backup

    3) find the file 662bc19b13aecef58a7e855d0316e4cf61e2642b - this is the backup of Library/Preferences/

    4) copy it to another location safely and make a note of its exact file size in bytes (hexadecimal form)

    5) upload it to the SHA file generator and make a note of the SHA-1 hash of its contents (hex form)

    6) rename it in the original location to a .plist extension

    7) edit this plist to include the PIN as described by others, and/or to change the number of times


    8) rename it to remove the .plist extension

    9) make a note of its exact size in bytes (hex form)

    10) upload it to the SHA file generator and make a note of the SHA-1 hash of its contents (hex form)


    Now we need to tell Apple's file database about the changes we have made.

    11) make a backup copy in another location of manifest.mbdb

    12) open in the main backup location manifest.mbdb in the hex editor.

    13) Search for the string

    14) Soon after this entry you will see hex for the SHA-1 your wrote down in 5) above. Replace it with the SHA-1 from 10) above.

    15) Soon after that you will see a series of zeros followed by the file size in bytes you wrote down at 4 above. Replace this with the size you wrote down at 9) above.

    16) save the mbdb file


    Now you can restore from this backup using iTunes as normal.


    Worked for me! But you have to be very careful and methodical.

  • snigglefritzbc Level 1 Level 1

    I downloaded backupbot, changed the parental control line to false, reset the counter to 0, saved my changes then restored from backupbot, no change to my iphone (which I recently updated to IOS6) did I do something wrong?  the changes still show in the backup file, they just didn't restore to the phone...

  • tallPablo Level 1 Level 1

    snigglefritzbc - It appears to be much harder to do this in IOS6 because they now hash the file in question. MorayMcC outlined the steps you need to take to make the changes to the file stick.

  • BringBackSteve Level 1 Level 1

    Pretty sure you can use 'shasum' in Terminal rather than uploading to the online tool.

    (Assuming you use Mac OS X...)


    man shasum



    $ shasum ~/Desktop/foo.png

    9cbe1e3e2a0967bc3dba628f0c0437b4452c950a  /Users/myuser/Desktop/foo.png


    Using your URL  (note same result as hex)


    hex: 9cbe1e3e2a0967bc3dba628f0c0437b4452c950a

    HEX: 9CBE1E3E2A0967BC3DBA628F0C0437B4452C950A

    h:e:x: 9c:be:1e:3e:2a:09:67:bc:3d:ba:62:8f:0c:04:37:b4:45:2c:95:0a

    base64: nL4ePioJZ7w9umKPDAQ3tEUslQo=

  • byronwithlove Level 1 Level 1

    okay i just found the answer, when you go to restrictions and it says enter password ,it actually means enter one to set it up, so at first it says enter password, so enter what you want it to be, then it says RE ENTER password, do it again, this sets up the password from now on, and your in!

  • BringBackSteve Level 1 Level 1

    Normally yes that is what should happen...

    after the IOS 6 install however, some people myself included got screwed - because the password <didn't work>


    And if you weren't having that issue, but just forgot the password entirely as the original poster, then obviously one can't re-enter it correctly twice in a row (because you don't know it!)

  • snigglefritzbc Level 1 Level 1

    Well, problem solved... my on/off button went on the fritz and Apple replaced the phone .  When I reloaded my backed up file, with the changed switch as you recommended above, the password was gone.  Then I had to temporarily set up a password to change the 'deleting apps' switch to 'on' (it was stuck in the off position and couldn't be changed) and then un set the password.  Yay!  I think a regular old 'restore' would have done the same thing.

  • jklinephd Level 1 Level 1

    I got what BigBopper66said to work with an iPad 2, iOS 6.01.  Here is what I did.  I downloaded iBackupBot.  Opened up the latest backup for my iPad.  Found the library/prefereces/ file.  Extracted it (and only it) to the desktop.  Checkmark the file, then select the Extract Icon, then select the checkbox that says only that file and the other checkbox that says something about Info about the file.  Two files will appear pn your desktop - one ending in plist and the other ending in .info. 


    I had previously downloaded Xcode which has a PLIST editor.  I opened the PLIST file in XCOde.  I added a New Key. I named it "SBParentalControlsPIN" and set the value to 1234.  Hit Save. 


    I then hit the import button in iBackupBot.  Quit Backup Bot. 


    Plugged my iPad into iTunes and Selected Restore from backup and then backed it up to the backup I just modified. 


    Took 15 minutes.  It then rebooted, and failed.  Crap.  I finally held down the power button and then when the apple came on screen, held the Home Button down while it was plugged in to iTunes.  I held the home button until It started to reboot (the horizontal progress bar appeared).  It booted.


    I went into Settings Selected Restrictions and entered 1234.  It worked.  I then disabled Restrictions.  Yahoo!!!!!


    Seems fine.  No Guarantees.  Proceed with Caution.  Might want to Backup Twice and keep one in reserve. 

  • anderv91 Level 1 Level 1

    saved my life haha thnks for the help.

  • Domitilla6 Level 1 Level 1

    Hi @Marcin2011, I have the same problem as listed by everyone here: I can't seem to find the 4 digits to unlock the restrictions.

    I was looking at your answer, which by many has been rated as the best one, which I believe it to be to.

    However, I am a very bad computer user, and get lost when you say:


    2. Extract the Zip file you downloaded (from where sorry? how do I extract it?), move the App to your Applications folder (where, in iTunes?), then run the App (hem, once again, where exactly?)

    3. Click on Read Backups, in the window that pops up (from where?) click on the backup file of the device you need the lost pin for, then click Choose

    4. You will have a list of all the Apps on the phone (where?). Scroll to the bottom of the list and click on iOS Files, then click on Extract. Choose a folder where you want the files to be extracted to.


    If you could answer any of these questions, it would help me out so much.

    Thank you and every community member



  • taichimaster Level 1 Level 1

    Many thanks MorayMcC.  Your outline and solution works great!

  • Cfrozal Level 1 Level 1

    Okay- I must be a complete idiot.  Whenever I try and click on library/prefrences/ 



    I get an this message that pops up when I try to double click on it or right click on it.


    "Can't view a password protected backup.  Please disable password protect in iTunes:

    1. Run iTunes and connect device to computer.

    2. Select your device name in left pane of iTunes.

    3. Uncheck "encrypt Iphone backup" in right pane.


    Then exit iTunes and restart this program.



    ??? I did that.. it's not checked.. if I knew my password I wouldn't need this.. please help.. i've been killing myself trying to figure this out.

    I have an iphone 4 with the newest ios?


    Thanks in advance.... I've had an iphone for the last 5 years.  Backed up my iphone4 yesterday because hubby bought me the iphone5.  Came home to transfer all the info just to have my stupid laptop give me the blue screen of death :*(    Backed up my iphone 4 on my hubbys computer and now it has asked for a password which my laptop had never asked for before.  I restored the phone(4) and I can see all my info is still saved on this computer but I can't for the love of me get past the password!!!

Previous 1 8 9 10 11 12 Next