Previous 1 2 3 4 Next 408 Replies Latest reply: May 3, 2016 5:44 AM by britanniefrombeaverton Go to original post Branched to a new discussion.
  • jjkboswell Level 1 Level 1
    Um, I think you've gone slightly off track here. My PC's parental controls for internet access (the rather excellent BlueCoat K9) are nothing to do with accessing iTunes. And as far as I'm aware, there isn't a straight forward way to limit access to iTunes so that my family can play music, watch podcasts browse the store and prevent access to iPhone backups.

    And the whole point of this is, I just turned off the in-app purchases! I don't need to convince my children not to reset my iPhone, they wouldn't do that and besides it takes too **** long! (nearly done now)

    So I appreciate what you're saying about security, but this is just parental control on the iPhone we're talking about, nothing else. And hence a simple "enter your iTunes password here to recover your Restrictions passcode" would be entirely sufficient.

  • jjkboswell Level 1 Level 1
    Thanks again to the guys who posted the restore details. I got around my problem by:
    - backup
    - take copy of backup (just in case!)
    - restore (wipe iPhone)
    - create new iPhone
    - sync apps to iPhone
    - open app and do in-app purchase that I needed
    - restore (wipe iPhone again)
    - restore from backup

    Massive inconvenience to me as the owner, but a worthwhile tradeoff if a kid wanted to bypass parental controls on an iPhone.

    Now to write all my pin codes down so I can't forget them (face palm)

  • Lawrence Finch Level 8 Level 8
    Mac OS X
    There's an app for that. Actually, quite a few of them: 1password, splashid, ewallet, etc. Weel worth having; with any of these you only have to remember one password.
  • jjkboswell Level 1 Level 1
    Sorry, was being sarcastic.

    That's right, I have all my pins in Keeper Mobile v4. However, this particular one I didn't seem to put in it, perhaps I reused one of my many other pins? But as I said, trying 1 pin combination every 60 minutes is a bit of a pain. I've taken security seriously, I just made one mistake to forget the least important pin I had, the parental conrol lock.

    And the final insult to this Apple security system? When you restore from a backup, the main iPhone passcode is removed and the phone is unlocked, however the parental Restriction code is not removed.



    Message was edited by: jjkboswell
  • Andrea Rimicci Level 1 Level 1
    jjkboswell wrote:
    ... I need an in-app purchase for CoPilot navigation app.

    ... clear the restrictions password? ...

    Large apps, as navigation ones, can only be downloaded by local network or by iTunes sync.

    If you lost the password and don't want lose everything on phone, I will suggest you to purchase the app by the store in iTunes, then sync it back to the iPhone.
  • jjkboswell Level 1 Level 1
    The CoPilot navigation app is very very big, and I downloaded it straight to my phone with a wifi connection, although you can do it the way you describe.

    But the problem I had was I wanted an "in-app" purchase within CoPilot, which means the app does the purchase within the app. And with in-app purchases disabled within the parental Restrictions setting, unless I have the pass code I cannot do an in-app purchase.

    But the process of restoring a new iPhone, doing the inapp purchase then restoring my backup works, albeit taking hours.

  • Andrea Rimicci Level 1 Level 1
    jjkboswell wrote:
    ..I wanted an "in-app" purchase...

    My bad!
    Try to guess your pass, hope you hadn't used real random numbers, but some pattern that has meaning to you and no one else.
  • Marcin2011 Level 1 Level 1
    jjkboswell, unfortunately I saw this topic a couple months after you had the question but this might help other people in the future. Also since you ended up restoring from the original backup I'm guessing you still don't have the Parental Controls pin code after all. Here is how you can get it back:

    1. Download iPhone Backup Extractor (This is for OSX, if you are using Windows there are other Backup Extractor programs although my iPhone syncs with a Mac so you will have to tweak these directions to work with the Windows program, here is one of the Windows programs I found:
    2. Extract the Zip file you downloaded, move the App to your Applications folder, then run the App
    3. Click on Read Backups, in the window that pops up click on the backup file of the device you need the lost pin for, then click Choose
    4. You will have a list of all the Apps on the phone. Scroll to the bottom of the list and click on iOS Files, then click on Extract. Choose a folder where you want the files to be extracted to.
    5. After it finishes extracting go to the folder where you extracted the files and follow this directory path: iOS Files --> Library --> Preferences
    6. In that folder find the file "" and open it. (Read note below if on Windows)
    7. In Property List Editor look for the key titled "SBParentalControlsPin"
    8. Look to the right of that entry and you will see the 4 digit PIN. You can now remove/modify parental controls

    (NOTE: If you are on Windows and do not have a program that will read PLIST files then open the file with Notepad instead. It will mostly look like garbled junk and words running together but towards the end of the file look for 4 successive digits, if there is more than one place with 4 successive digits then try them all, one of them will be your pin).
  • sulli75 Level 1 Level 1
    Thank you! My 15 year old was (understandably) upset when I "forgot" the password and we thought we'd have to restore and lose everything just to change/turn off the parental controls. Your post saved me from his wrath.

    First, I'm usually pretty leery of downloading programs in posts on message boards, but I went with it, and used the (free) one at So, for anyone else reading this, it's a safe program as far as I can tell. I saved it, extracted the zip file and ran the one that said App (I didn't have to move anything to an app folder or anything). I had to click on "expert" and then scrolled to "Library" and "Preferences". I located the "" file. It took a minute or two to realize I had to put a checkmark just before the file name in order to get the "extract" button (down at the bottom) to become available. I exctracted that file, opened it with notepad and then scrolled around until I found the four digits.

    Now, the real kicker is .... the four digits that were shown were the four digits I'd originally tried on my first attempt. When that didn't work the first time around I tried other codes until I gave up. Anyway, I went back and tried that code again and it worked, so crisis averted.

    Thank you so much for your post!

    And I agree with the other poster... it seems silly to me that the parent who sets up the code can't reset it if it's forgotten without losing EVERYTHING. Seems like there could be a secure way of easily resetting it... perhaps having it sent to the email address of the person who put the code on in the first place... after answering security questions? There's gotta be a better way!
  • iamsmurph Level 1 Level 1
    Thank you Thank you Thank YOU

    This method worked flawlessly. Running iPhone 3GS with 4.3 and Toshiba Laptop. The 4 digits were located in the last bit of information and worked great. I struggled for 3 hours looking for a solution.

    Thank you again
  • spiffothemouse Level 1 Level 1
    I tried this on iOS4.3 (iP4) and that line doesn't appear in the PList editor. Is this a new change in iOS 4.3? Any suggestions appreciated.
  • Holldoll78 Level 1 Level 1

    Thank you so much!!  This worked on my iPod touch that my 3 year old had gotten a hold of and set up a restrictions passcode.


    I too think it is pretty silly to be able to do a restore and lose the actual device passcode but not the restrictions passcode.

  • icefall5 Level 1 Level 1

    "Now, the real kicker is .... the four digits that were shown were the four digits I'd originally tried on my first attempt. When that didn't work the first time around I tried other codes until I gave up. Anyway, I went back and tried that code again and it worked, so crisis averted."


    That's my problem. I know exactly what my code is, but it's apparently incorrect and won't unlock my restrictions after I restored to factory settings and then restored from a backup.

  • danielefromquarrata Level 1 Level 1

    Thank you!!! Finally!!

    Same situation of icefall5.. the code I tried the first time was the right one!

    And the phone gave it as wrong passcode.

    I'm sure of it becouse I start writing the passcode I was trying (to not repeat the same code several times) and I went crazy... :-(

    Anyway now everything is ok! Good!!

  • brucefrommckinney Level 1 Level 1

    Yay!!  After several "sexting" issues with our teenage son, I needed to remove Safari from his phone.  Resetting it didn't reset the parental permission password, and my husband and I didn't have a clue, since the phone has been passed around between us.  This worked like a charm, except I had to download "Text Wrangler" to read the .plist files.  Thanks so much!!

Previous 1 2 3 4 Next