Previous 1 16 17 18 19 20 Next 407 Replies Latest reply: Apr 23, 2016 3:27 PM by Stultitia Go to original post Branched to a new discussion.
  • bazzoonboy Level 1 Level 1

    wcj72: I'm having the same trouble as TwoFaceTony...


    My file looks almost exactly like his:

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">

    <plist version="1.0">



              <string>texttone:Calendar Alert</string>


              <string>texttone:Sharing Post</string>


              <string>texttone:New Mail</string>


              <string>texttone:Reminder Alert</string>




              <string>texttone:Sent Mail</string>


              <string>texttone:Sent Tweet</string>









    It's only alert tone settings. I'm read through this entire thread so far, but I find no alternate Springboard plist file. I'm on iOS 6.1.3.


    Anyone know where you can make modifications in this new, barren Springboard file?

  • wcj72 Level 1 Level 1

    You have to make sure you're looking at the correct springboard file.  If the springboard file has a date older than your backup date, it is not the correct file.  Mine was located in


    "System Files/HomeDomain/Library/Preferences"

  • bazzoonboy Level 1 Level 1

    Ah, I had used a different app to extract the backup at first. Using iBackupBot, everything's good.


    Heads up to anyone who gets an error on line 73: Make sure that if you just pasted in the new SBParentalControlsPIN text, it's broken up with a return and a tab, and contains no spaces.

  • cfagent0 Level 1 Level 1

    I did everything suggested by Tom, and everything was fine up until the end of the restore, in which it said error 20, and the restore just stopped. If anyone had any suggestions on how to fix this I would greatly appreciate it.



  • JeanHT Level 1 Level 1



    Thank you for your detailed instructions! I was able to use them on an iPhone 5 running iOS 6.1.3.



  • macbok80 Level 1 Level 1


    I solved it too. I have iOS 6.1.3


    1). Took a backup.

    2). Closed the iTunes

    3). Imported the backup via ibackupbot

    4). Opened the file: Library/Preferences/ via ibackupbot

    5). Added







    6). Closed ibackupbot

    7). Opened iTunes and restored the backup.

    8). Went to Restrictions, gave 1234 to disable restrictions.

    9). Went to Reset Settings and gave iPhone password and bingo, all settings reset.



    Note: Earlier I tried to restore it via ibackupbot, but this time I restored it via iTunes and it worked! phew!

  • Ninjababii Level 1 Level 1

    i dont remember my password for the back up!! how can i get it back??

  • Lawrence Finch Level 8 Level 8
    Mac OS X

    Keep guessing. There is no way to restore an encrypted backup without the password. It's a password that you created at the time the backup was first encrypted.

  • walldogkl Level 1 Level 1

    I'm only posting this because it took me forever to get this done and the way to do it is so convoluted and frustrating.  I have a iPhone 4s running iOS 6.1.3 and I just did this after several weeks of research.


    Tomhr260's instructions are pretty much spot on.  I've recopied them here, but changed it a bit to make more sense (at least in my mind).


    1) Backup iPhone/iPod/iPad to iTunes.  Sync your iPhone/iPod/iPad and make sure the backup is help locally.


    2) Close iTunes but leave your device plugged in to your computer


    3) Download iBackupBot


    4) Open iBackupBot


    5) Select your backup from the left column.  For me, it was the last one with today's date on it.


    6) Navigate to "Library/Preferences/" (there may be two files named this; try them both) and double-click to open.

         This was the hardest part.  There are actually two files that are  You want the one here:

              System Files/HomeDomain/Library/Preferences/

         Double click the file to open it.  The whole "This is a TRIAL Version" will appear.  You do NOT need to buy the program.  Just hit cancel and the file will open.


    7) If the backup is from iOS 4.X or lower then you should be able to find "<key>SBParentalControlsPIN</key>" somewhere in this file and your passcode will be below this line.

    If your backup is iOS 5 or higher, then continue on.  I assume everyone is running iOS 6 or higher so continue.



    8) Look for and change the string for "SBParentalControlsFailedAttempts" to 0.


    Here is where things get a little complicated.  For some reason, I was not able to make any changes that got saved to the .plist file.  I did it numerous times and nothing happened.  In summary, what I did was export the .plist file, and use another program to make the changes, then reimported it using iBackupBot and then restored it to the iphone.  Instructions continue below:



    8a) So you have the open.  Go to the icons on top and click Export.  Pick a destination (I used the Desktop).



    8b) Download PlistEditPro to edit the .plist document (  After you download and install the PlistEditPro, you can right-click the file and Open With PlistEditPro.


    8c) If you don't see the commands, or if it says "The property list is in binary format and has no textual representation. To see a textual representation, choose a different property list format using the Change Format submenu located in the Operations menu." then go to the Operations Menu, click Format and select XML.  That should show the commands.



    8d) Look for (about 2/3 down) and change the string for "SBParentalControlsFailedAttempts" to 1.  I did this rather than 0 in case there wasn't supposed to be anything if there were 0 failed attempts and I didn't want to screw it up.


    9) Directly below the FailedAttempts, you will see:







    After THAT, add this text:





    Make sure it matches the rest of the file.  You will need to remove leading spaces for each command line and it should be tabbed over.


    10) Click save.  If you get an error, then you probably have extra spaces or tabs in there.  Go back and make it consistent.  Click save.


    11) Close out of that file


    11a) Go back to iBackupBot.  Click Import on the top and select the just edited file.


    12) Click restore backup/file to iPhone/iPod Touch (the icon of an iPhone and a blue arrow) located under the menu bar in iBackupBot


    13) After restore is done (should be like 10 seconds) and phone restarts the password should be 1234.


    14) Change it to something you will remember this time. 


    Hope this helps someone else.  I know it's super frustrating and I don't know why the password reset can't be done to via an email or phone call or whatever, but here it is and it works.


    <Link Edited By Host>

  • Mobytoss Level 1 Level 1

    I've got the same setup (iPhone 4S, iOS 6.1.3) and it seems to not work. I dunno if Apple released a small patch for 6.1.3 to stop this happening but setting a pin here does nothing for me. I can reset the number of passcode attempts no problem so the actual backup restore is working fine. I've triplechecked the XML for spelling errors, typos, formatting problems etc but nothing is off. Anyone else having this problem resetting their code now?

  • dlp911 Level 1 Level 1

    I needed to reset the restrictions passcode on my 2nd gen iPad running iOS 6.1.3 and after many attempts at other users instructions I followed Walldogkl's instructions above with one addition:


    When you do the the restore in 12 a dialog box pops up that asks if you would like to reboot following the restore.  If this is selected the fix worked.  If not it would not work.  Thank you Walldogkl for your helpful post.



  • adeleaca Level 1 Level 1

    THANK YOU SO MUCH FOR THIS!!!!! I was trying this since 1230 AM (its now 315 am) and i could NOT get it until I read your post! I have an iPhone 4 6.1.3 and this worked like a charm. everytime i tried without exporting to plist edit it would erase my entire backup and i would get so scared! i am so thankful for your help.


    one thing i will say to save some time is this will NOT work with an encrypted backup! follow walldogkl's steps word for word and you will be satisfied....thank you again!

  • valhalla99 Level 1 Level 1

    This is a life-saver!  Instructions for iOS6 using the plist editor did the trick since ibackupbot wouldn't save.  I'm a newbie but was still able to reset.  Thanks to all!

  • MacHound Level 2 Level 2



    Your instruction are amazing.  I haven't been able to do in-app purchases for over a year after the kids turned on Parental Controls.  (It's a funny interpretation of who, exactly, is being controlled here.)  I guess Apple doesn't like making money at the AppStore.


    On my fourth generation iPod Touch there was no SBParentalControlsFailedAttempts key so I had to create one from scratch.  iBackupBot works fine for me to enter the text manually.  Here is the exact text in bold (the non-bold key above and below are for reference points within



















    Thank you, thank you, thank you!  Now to apply it to my iPad2, which has also been locked to in-app purchases for over a year.

  • walldogkl Level 1 Level 1

    Glad this has worked for people.  Hopefully others as well that have not posted.  And to be clear, I just ammended Tomhr260's original instructions with my own notes from when I did it myself.  So props to him too.

Previous 1 16 17 18 19 20 Next