Previous 1 17 18 19 20 21 Next 394 Replies Latest reply: Feb 23, 2015 1:47 PM by calmwater82 Go to original post Branched to a new discussion.
  • MacHound Level 2 Level 2 (265 points)

    Oops, I wrote too soon.  What appeared to work didn't work.  I'm not sure how I could have been confused about it but the Restrictions setting definitely remains ON.  The number of failed password attempts goes back to 1 when I restore from the iPod Touch backup, but the password "1234" doesn't work.  Looking at the com.apple.springboard.plist file again, it's totally different than before... almost no similarity whatsoever.

     

    No luck on my iPad2 either despite many attempts.

     

    I'm going to do a factory restore on the iPod Touch, since I don't have much time invested in its contents.  I am reluctant to do a factory restore to my iPad2.  Perhaps I can do in-app purchases on the iPod Touch, then transfer the updated apps to the iPad.

     

    So close and yet so far!  This is incredibly frustrating.  Apple needs to solve it.

  • BeenHereBefore Level 1 Level 1 (0 points)

    The newest version of iBackupbot will change and write back (there was a problem with writing back pre version 4.1.1).. Also you can restore just com.apple.springboard.plist file by selecting it then right click it and choose restore selected item(s) to device.  The device will then go into restore mode and reboot

  • MacHound Level 2 Level 2 (265 points)

    BeenHereBefore, restore selected item(s) to device is a great iBackupbot feature.  I'll gladly pay the shareware fee for this app if I ever get it to solve my iPad Restrictions.  So far I have a few hours of trying and no success.  I tried recoding the com.apple.springboard.plist file numerous times, making minor changes in the line spacing, reordering the instructions, etc., but nothing works.  Most times I get error code -20 when I attempt to restore the device.

     

    I feel encouraged that some people using iOS 6.1.3 are reporting success.  I just wish I were one of those people.  My iPad is relegated to "toy" status until this problem is solved.  I don't feel inclined to buy any more iOS devices or apps knowing how cavalier Apple is about customers being locked out by naughty children.  I wonder if this is why some people are moving to Android?

     

    BeenHereBefore, if you're the author of iBackupbot, did you ever consider making a stand-alone app that reverts iOS Parental Controls and basically does nothing else?  Many of us don't need all the other complexity of iBackupBot.

  • BeenHereBefore Level 1 Level 1 (0 points)

    Machound, No I am not the author.  As I explained I tried to write the changes back to the backup file with version 4.1.0 of iBackupbot with no success. I emailed WOWsoft support and once they established (one email exchange) that I had performed the correct steps the had a look, found the bug, fixed the product and released the update (4.1.1) all within a couple of hours.

     

    to be clear I only restored the individual file com.apple.springboard.plist.


    I paid for the product but I can't see that would make it perform differently.  However you could try emailing WOWSoft support describing your error. I think if they provide a solution then you could pay for their meal, cheaper than replacing an iPad.

     

    Why Apple can provide these tools I cannot imagine.  iTunes gets worse and worse.  We all need a backup and maintenance utility not a music manager with backup and maintenance as a forgotten relative tagging along behind.

  • russellelly Level 1 Level 1 (0 points)

    I had post here that's been removed, showing a workaround for this passcode. I won't link, but search for my username, passcode and YouTube and you'll find a different approach that works. MacHound and others, maybe it will help.

  • MacHound Level 2 Level 2 (265 points)

    Russell, your solution is brilliant.  I don't have time to run it tonight but will give it a try tomorrow.  Thanks for posting what may be the only way out of our morass.

  • MacHound Level 2 Level 2 (265 points)

    Russell,

     

    Your solution worked when everything else failed.  Absolutely marvelous!  It cost me $5 for Type2Phone and a couple hours of my time, but now I have control of my iPad back!!!  Hooray!

     

    I won't post the link here, for reasons cited above, but anyone who is interested can find it by searching for Russel's name at MacRumors Forums, posted on 4/4/2013.

     

    I can't thank you enough, Russell.  Bravo!

     

    (I wonder how much money I might have spent at the App Store all those months when I was locked out of my iPad's in-app purchases?  Silly Apple!  I feel sorry for the small developers who get hurt in the cross-fire.  I'll stop now before I get banned.)

  • russellelly Level 1 Level 1 (0 points)

    You're welcome, really glad it worked for you. Maybe you'd be kind enough to post on the YouTube comments, especially if you could share what device and iOS version you used :)

  • topmedic Level 1 Level 1 (0 points)

    Many thanks. Worked flawlessly. ibackupbot even saved the xml file for me so I didn't have to edit outside of it. My older daughter set up the Restrictions password originally for her younger sister then forgot it altogether. I have an iPhone 4 v6.1.3. Thanks again.

  • kane1755 Level 1 Level 1 (0 points)

    walldogkl and tomhr260 you are the best. it has taken me so long to figure all this out. thanks everyone on here for clearing this up.

  • funkyfuzzmonkey Level 1 Level 1 (0 points)

    Russell!!! You are a certifiable genius!!!!! I've had the passcode issue for months, and nothing worked to recover it. UNTIL NOW! If you're looking for a solution people, follow Russell's advice to the letter. Outstanding work old cheese!!!!!

  • cbron Level 1 Level 1 (0 points)

    Thanks walldogkl, your instructions were very helpful!

     

    I did make some slight adjustments after it failed to work the first time.

     

    after step 9:

         I clicked the Sync outline button in PlistEdit Pro and then saved it.

     

    After the save I just left Plist open and followed the rest of your instructions. I dont know if that makes any difference but it worked for me after not working the first time.

  • kami1239 Level 1 Level 1 (0 points)

    i have the same problem

    i have iphone 4s,6.1.3

    how to solve restriction passcode?

  • Lawrence Finch Level 7 Level 7 (28,785 points)

    You could start by reading the solutions posted already in the thread you just posted to without reading it.

  • TXTitan05 Level 1 Level 1 (0 points)

    Thanks for this.  Was able to reset my restriction code without a restore.

Previous 1 17 18 19 20 21 Next