5 Replies Latest reply: Feb 2, 2011 11:51 AM by imadori
Level 6 Level 6 (11,035 points)
I have a new computer (Windows 7) and I moved Itunes over from my old box. All works reasonably well (using IPod and Ipad) except that every time I open ITunes on the computer, I get a dialog box informing that ITunes is not the current default player. I've now selected Itunes about 50 times as the "default" -- to no avail. Can someone advise how to set it and get past this issue? Thanks in advance.

PC; 2.8ghz; 8g mem., 64 bit, Windows 7
  • 1. Re: Setting Itunes as default player
    WPLJ42 Level 1 Level 1 (15 points)
    Just like Internet browsers, media players fight to be the default. Perhaps you have a player like Winamp or Real Player taking back the default. You should be able to fix the settings in Control Panel. I have Control Panel set to view by large icons. If you are set to Category, then click on Programs, then you should find the option to set your default programs. Open that and look for iTunes on the sidebar. You should be able to fix your situation there. Also look at any other media player and un-check the file types that you want iTunes to control. Even if you haven't installed anything new, Windows Media Player might be set as the default for your iTunes files, and won't let go. If you have Winamp Agent in place, it will take back the default status, each time it opens. I think Real Player will too.

    Jim
  • 2. Re: Setting Itunes as default player
    Level 6 Level 6 (11,035 points)
    Jim,
  • 3. Re: Setting Itunes as default player
    Level 6 Level 6 (11,035 points)
    Jim,thanks for the info. I suspect Win. Media Player is the culprit. If so, it clearly does not wish to relinquish control. Oddly, everything behaves in an acceptable manner (mp3 play automatically through ITunes etc.) It's just the stupid dialog box asking about defaults. I'll keep playing with it. Again, thanks.
  • 4. Re: Setting Itunes as default player
    WPLJ42 Level 1 Level 1 (15 points)
    PhillyFella, If everything is working well, you can go into the Advanced tab in iTune's Preferences un-check "Warn me if iTunes is not the default player for audio files." That works for me, as I don't want my computer telling me what to do.

    Jim
  • 5. Re: Setting Itunes as default player
    imadori Level 1 Level 1 (0 points)
    Thanks for the information! This has been driving me crazy for months!