11 Replies Latest reply: Aug 23, 2013 5:04 AM by David Blocher
macav8tr Level 1 Level 1
I am unable to login to Citibank using Safari 5.0.3. I worked with Citibank techs trying a bunch of stuff with no success. Works fine with Firefox browser. Every time i try to log in it justs loops me back to the sign in page. It doesn't matter what you enter either. I tried doing a forgot usernam/forgot password reset and it just loops you also. Any ideas?

imac 20inch 2.66ghz intel core 2 duo, Mac OS X (10.5.8), 2gb DDR Ram
  • Carolyn Samit Level 10 Level 10

    From your Safari menu bar click Safari / Preferences then select the Security tab. Click: *Show Cookies*

    Delete all Citibank related cookies.

    Quit Safari (Command + Q) Relaunch Safari. See if that helps.

  • macav8tr Level 1 Level 1
    We went through all of that with the Citibank Tech guys. We also reset safari and cleared all caches. It still just endless loops to the sign in page.
  • Carolyn Samit Level 10 Level 10
    Try restarting your Mac.

    If you have Citibank bookmarked in the Safari Bookmarks bar. Drag it straight up and off. Quit Safari (Command + Q) relaunch Safari.

    Navigate to the Citibank site.

    techs trying a bunch of stuff with no success.

    We have no of knowing what "a bunch of stuff" implies. When posting for help tell us exactly what's been tried so we know. Thanks!

    Login to another user account on your Mac. Launch Safari and see if you can access Citibank there.

    Open Keychain Access (Applications/Utilities) Select Passwords on the left. Delete the Citibank keychain.

    See if that makes a difference.

  • macav8tr Level 1 Level 1
    Did that after all the above. no change. The Citibank people said a bunch of people were having similar issues.
  • Carolyn Samit Level 10 Level 10

    Go to Safari / Preferences, select the Autofill tab. Click the Edit button next to: *Other forms*

    Delete all Citibank url's.

    Quit Safari, relaunch Safari.

  • Colin Ayer Level 1 Level 1
    I tried everything in this post, nothing worked. Then I went to Safari > Preferences > Extensions and flipped the switch to OFF. This solved the problem for me.
  • Peter Deli Level 1 Level 1
    Mac OS X

    Hello Colin and others,


    I know it won't change anything, but I have the same problem at my University.


    Wifi available to everybody who has credentials (so no WPA2 and stuff: it would be simply unmanageable). When turning on the computer, turning on Wifi, launching Safari (I have version 5.1.5) and reaching a website, a login page should appear. Before, it used to, but since the latest version of Safari not even the login page appears, it just looks for the page forever.


    Previously, I had discovered a "loophole":

    • Turn off Wifi (and all network connections and BT);
    • Quit all applications;
    • Restart the computer;
    • Login;
    • Launch Safari (do not attempt to reach a site);
    • Turn on the Wifi (wait a bit for all the handshake to take place);
    • Try to connect with Safari;


    At that last stage, it used to work, but not anymore. So I had to revert to Firefox. I have no problem using Firefox, what bothers me, however, is that there's a bunch of Safari login depedent applications that either won't work, or even hang up (beachball forever), like:

    • Mail
    • iCal
    • AddressBook


    Mail being the one to hang up on me. By the way, Chrome does not work either.


    I went to the IT help desk of the University and saw the Mac specialist who reverted to Firefox. He told me he also tried a "bunch of things" like putting manually the certificate with no avail. It seems that with the incresing security concerns of Apple, they increased the tightening. However, we need to work. And what about the "Firefox hole"?


    Well, we're not out of the woods, yet.


    But if anyone has more elaborate ideas than restarting the computer, emptying the caches and turning off extensions, I'm willing to try


    In the meantime, as I have Time Machine, I will try to get an earlier version of Safari and see if that works (wonder why I haven't thought of that one before )






  • Ashka Level 4 Level 4

    If it's any help at all, I have to have JavaScript enabled to use Safari with my Bank.

    Safari Preferences > Security.   Java can stay off.

  • I amDavid Level 1 Level 1

    Hi Peter,

    I have the same trouble using Safari 5.1.5 in WiFi network.

    My company is a wireless service provider.Recently our call center received some complains about Mac+Safari(5.1.5) can't login wifi network.But the login process can be worked before Safari upgrade to the latest version.Our technical guys told me the root cause that our wifi landing page have several redirect actions so Safari truncate user login ID information automatically.I think that it's a bug in version 5.1.5.Who can help me report the issue to Apple thechnical team.



  • Peter Deli Level 1 Level 1
    Mac OS X

    Hello I amDavid and others.


    Just to give you a quick feedback: I retreived all the versions I had from Time Machine backups (went back as far as version 5.0.3, so not that far), but with just version 5.1.3 I was able to log back in with the help of my "little trick" (check my previous post). So I'm happy to tell you that it works. So I have all the programs working (Mail, iCal, AddressBook, etc.) without a hitch.



    As for your question, I amDavid, on how to report any problem/bug to Apple, follow this link: http://www.apple.com/feedback/safari.html


    Take care everyone,




  • David Blocher Level 1 Level 1

    I was able to login after deleting the accountonline.com cookie from the cache (Safari preferences-->Privacy--> Cookies and other website data.  I noticed that once I logged in, the url changed to accountonline.com.  This is what worked for me in my configuration