8 Replies Latest reply: Dec 3, 2010 12:05 AM by Xaniel
Xaniel Level 1 Level 1 (0 points)
I have been having some trouble using WDS between an Airport Extreme and Express, with the Extreme acting as the internet router in the network.
Both devices have been updated with the lastest firmware.
I am using Airport Utility 5.5.1

*Airport Extreme Configuration*
*Wireless Tab*
Wireless Mode: Participate in a WDS network
Allow Network to be extended: Checked
Radio Mode: Auto
Security: WPA/WPA2 Personal
Channel Selection: Manual (Same as my Express)

*WDS Tab*
WDS Mode: WDS Main
Allow Wireless Clients: Checked
WDS Remotes: (MAC of my Airport Express)

*Airport Express Configuration*
*Wireless Tab*
Wireless Mode: Participate in a WDS network
Channel: (Same as my Extreme)
Network Name: (my network name)
Wireless Security: WPA/WPA2 Personal
Allow this network to be extended: unchecked
Radio Mode: 802.11n (802.11 b/g compatible)

*WDS Tab*
WDS Mode: WDS Remote
Allow Wireless Clients: checked
WDS Main: MAC of my Airport Extreme

I think that covers the pertinent stuff. If there's anything else that might be useful, please just say so.

So, the Extreme is green-lit, working fine. Wireless clients can connect to it just fine. On the Wireless Clients page the MAC of my Express is showing up, with a type of WDS listed. It does not, however, show up under the DHCP clients section.

The Express is yellow-lit. Sometimes after a setting change it goes green for a minute or so, then back to yellow, reporting a WDS Error ("the AirPort Wireless device is set up as part of a WDS network, but no other AirPort wireless devices were found").

The Airport Express is ending up with an ip address of 169.254.49.198 (an automatic private). It seems it's not getting an ip from the Extreme's DHCP.

Do I have some sort of authentication issue here? Honestly I'm totally baffled.

Any help with this would be greatly appreciated.

Would the routers' logs be of any help?

Thanks

Message was edited by: Xaniel

Mac OS X (10.6.4)
  • Bob Timmons Level 10 Level 10 (87,720 points)
    Xaniel, welcome to the discussions!

    WDS is very tricky. If both your AirPort Extreme and AirPort Express are newer "n" devices, you can use Apple's "extend a wireless network feature". It's much easier to configure and it will provide far better performance than a WDS arrangement.

    If you have an older "round" AirPort Extreme, then you would need to use the WDS setup. Can you clarify on the devices that you have?

    Since the older Extreme is broadcasting an 802.11b/g wireless signal, you would want to configure the AirPort Express the same...802.11b/g. That may be why you are getting the WDS error.
  • Xaniel Level 1 Level 1 (0 points)
    Sorry for the ambiguity, I should have been more clear about this.

    Both the extreme and the express are brand-new models.

    Wait, just did a bit more reading. Am I correct in assuming now that the "Extend a network" option will function as a wireless repeater, with no ethernet connection to the main router required?

    I had previously assumed I needed to do WDS for this.
  • Bob Timmons Level 10 Level 10 (87,720 points)
    Wait, just did a bit more reading. Am I correct in assuming now that the "Extend a network" option will function as a wireless repeater, with no ethernet connection to the main router required


    Yes. This will provide much better wireless performance...and...its much easier to configure.

    On your AirPort Extreme, open AirPort Utility - click Manual Setup
    Click the Wireless tab below the row of icons
    Wireless Mode = Create a wireless network
    Make sure there is a check mark next to "Allow this network to be extended"
    Update to save settings

    On the AirPort Express, open AirPort Utility - click Manual Setup
    Click the Wireless tab
    Wireless Mode = Extend a wireless network (hold down the option key when you click on the selection box if you do not see this setting)
    Wireless Network Name = Click on the selection box and name of your AirPort Extreme network should appear
    Check mark next to Allow wireless clients
    Wireless Security = Exact same setting as the AirPort Extreme network
    Wireless Password = Same password as the AirPort Extreme network
    Confirm Password
    Update to save changes

    A good starting location for the Express is a point that is about 1/2 to 2/3 the distance from your AirPort Extreme to the area that needs more coverage.

    The ethernet port on the Express is also enabled, so you can connect an ethernet device if needed. Post back to let us know how things are working.
  • Xaniel Level 1 Level 1 (0 points)
    Thanks, I've got the express extending my network now, works great in both the 2.4 and 5 GHz bands.
    One last thing though. This sort of setup only lets me have a hub and spoke type configuration. That is, I can use an Express to regenerate the signal from my Extreme, but I can't keep on chaining routers that way. They all have to be able to talk to the main router.

    Can I run a cable to a more remote location (not in range of the main router) and use an Express to extend my network there?

    Message was edited by: Xaniel
  • Bob Timmons Level 10 Level 10 (87,720 points)
    I've got the express extending my network now, works great in both the 2.4 and 5 GHz bands.


    The Express is a single band device, so depending on its location, it is extending either the 2.4 GHz band or the 5 GHz band, but not both. It's more likely extending the 2.4 GHz band.

    You can check to see by opening AirPort Utility, clicking on the Express and jotting down the AirPort ID of the Express. Then move your Mac close to the Expess and hold down the option key while you click on the fan shaped AirPort icon. Look for the BSSID. That should match the AirPort ID of the Express. You can also see the channel, and band you are using here at the Express location as well.

    Can I run a cable to a more remote location (not in range of the main router) and use an Express to extend my network there?


    Yes. This is the best way to provide more wireless coverage on any type of network because it preserves the network bandwidth more effectively than a "wireless only" type of setup.

    You'll configure the "remote" Express differently in this type of setup if you want to do this. Post back if you need details.
  • Xaniel Level 1 Level 1 (0 points)
    {quote}The Express is a single band device, so depending on its location, it is extending either the 2.4 GHz band or the 5 GHz band, but not both. It's more likely extending the 2.4 GHz band. {quote}

    Indeed, after reading my post again I realized I worded this poorly. I meant to say that I have successfully used the Express to extend in either band, not at the same time of course.

    {quote}You'll configure the "remote" Express differently in this type of setup if you want to do this. Post back if you need details.{quote}

    I actually found another post of yours on this topic, no sense rehashing it here. If I understand correctly, I just set the router up in bridge mode, and set it to create a wireless network with the same SSID and security settings as the main router. I read somewhere that auto channel selection should sort things out, otherwise I should ensure that the APs are using different channels. That about cover it?

    I only bring up manual channel selection because I have installed routers for people in areas where I have upwards of 50 networks in range. Those locations make the 5 GHz band look really attractive.
  • Bob Timmons Level 10 Level 10 (87,720 points)
    I actually found another post of yours on this topic, no sense rehashing it here. If I understand correctly, I just set the router up in bridge mode, and set it to create a wireless network with the same SSID and security settings as the main router. I read somewhere that auto channel selection should sort things out, otherwise I should ensure that the APs are using different channels. That about cover it?


    That's got it covered.
  • Xaniel Level 1 Level 1 (0 points)
    Thanks for all the help then, it's greatly appreciated. I'm marking this thread solved.