3 Replies Latest reply: Mar 14, 2012 4:47 PM by Steven Shmerler
John Bowers1 Level 1 Level 1 (10 points)
I rented a video from iTunes and i never got a chance to view it all the way through. The video is taking up space on my iPad but I can't figure out how to delete it. It doesn't show up on my iTunes movie section so I can't delete it from my iMac. I have tried swipeing but it doesn't do anything. Any help would be appreciated.

IPad, Mac OS X (10.4.2)
  • lllaass Level 10 Level 10 (162,690 points)
    Swiping is supposed to work. Have you tried swiping in different directions?
  • anilsudhakaran Level 4 Level 4 (1,425 points)
    Tap and hold the movie thumbnail on your iPad and you should get an "x" to appear on the left corner of the thumbnail. Tapping the "x" should delete the movie
  • Steven Shmerler Level 1 Level 1 (70 points)

    i have the same problem on my ipad1, but I can't find the movie on my ipad to delete it. When I plug into my computer and select Rental on the left under devices, I see the movie in the right larger column, but don't see a way to delete in any of the itunes menus or even control clicking the movie title in iTunes.

     

    WHen I try to update to iOS5.1, i get the message that I need to transfer this rental first to my iTunes library. ANd then it says" are you sure you want to continue?"

     

    Maybe I should say Continue since the rental expired long time ago any way.

     

    I don't see the movie in my Video app, or doing a search doesn't find the movie either. So it's like it isn't really on my ipad in a way.

     

    PS: doing a transfer doesn't transfer it by the way.