Previous 1 2 Next 19 Replies Latest reply: Dec 16, 2010 9:18 PM by alli3katt
marcbyron Level 1 Level 1 (25 points)
Since the iOS 4.2.1 update I am having issues with iTunes 10.1 recognizing the iPhone.

I already re-installed iTunes once, because it seemed to be the only thing that worked.

Worked fine, but now a couple of days later I am plugging in my iPhone and iTunes doesn't recognize it. iPhoto pops up (wants to transfer photos) but not iTunes.

Anyone having the same problem? I don't want to re-install iTunes everyday

MacBook Pro Core Duo 2.16, Mac OS X (10.6.5)
  • dark_knight5 Level 1 Level 1 (0 points)
    Try restoring your iPhone because it could be an issue with the iPhone.
  • wisniewski Level 1 Level 1 (0 points)
    I have a similar problem
    just bought an iphone 4 (OS 4.2.1) It was properly detected until i updated iTunes to 10.1.
    It worked one or two days then the next day iTunes could not detect the iphone. Iphone was still detected by iPhoto.
    I did a full reinstallation of iTunes as suggested and the first time i reconnected my iPhone it was detected by my "new" iTunes. However the next day iTunes failed to detect it again;;;
    What is very strange is that my iPhone is detected with no similar issue on my son's computer which is also a MacBookPro with a recently installed iTunes 10.1.
    I am really confused and would also appreciate some help there...

    Thanks

    Francois
  • Lawrence Finch Level 7 Level 7 (30,180 points)
    Well, you've already isolated the problem to your computer, as it works on your son's. Are you using a USB port directly on the computer, and not a hub or keyboard port? Have you tried switching cables?
  • marcbyron Level 1 Level 1 (25 points)
    I have have the iPhone plugged in directly (no hub), tried a different USB port and also a different cable.
    Same issue. Reinstalling iTunes seems to be the only way to get the phone to sync (once)
  • Lawrence Finch Level 7 Level 7 (30,180 points)
    If you have Windows (your profile says Mac, but just to be sure):

    Open the Task Manager (CTRLSHIFTESC), click the Processes tab, then the Image Name column heading to sort. Look for AppleMobileDeviceService.exe. If it is not running this is your problem. Then you have to find out WHY it isn't running. Open Control Panel/Administrative Tools/Services. Find the service, right click it and choose Start. Also set it to Automatic if it isn't already. try to sync. Throughout the process look for error messages or a warning from your antivirus.

    If AMDS is running then your problem lies elsewhere; most likely either an out-of-date USB driver or some part of the iTunes process tree is being blocked by your antivirus/antispyware/firewall.

    Message was edited by: Lawrence Finch
  • marcbyron Level 1 Level 1 (25 points)
    I am on a Mac
  • Lawrence Finch Level 7 Level 7 (30,180 points)
    Hi; I see that you said that earlier; it's why I shouldn't respond before my coffee. I am stumped right now, because this problem usually only occurs with Windows. You can still check that AMDS is running as it is a daemon that is required and runs on the Mac also. If you restart your computer does it recognize the phone at least once also?
  • mr_joost Level 1 Level 1 (0 points)
    Hey Marc,

    Sorry, I unfortunately don`t have the answer but the same problem over here.
    I still haven`t figured out yet how to resolve it.
    Itunes only recognizes my Iphone just after I re-install Itunes 10.1.
    There appears an usb-icon instead of a battery icon and Iphone appears in Iphoto so the problem is Itunes.

    When i shut down my computer (Imac- Mac OS X 10.6.3), itunes doesn`t recognize the Iphone anymore (after I turned on the computer again ofcourse) .

    Please let me know if you have resolved the problem, I`ll do the same.
  • 3lions Level 1 Level 1 (0 points)
    Im having a similar problem, since I updated to 10.1 itunes dosnt recognize my iphone or my wifes. Ive uninstalled and reinstalled itunes 4times so far but still wont recognize our iphones. I spent 2 hours on phone to Apple yesterday but they couldnt sort it out, they said they were going to investigate and phone back today but still waiting
  • wisniewski Level 1 Level 1 (0 points)
    I finally managed to fix this issue.
    I was following one of the suggestions to create a new user with admin rights and open iTunes under this new user. In fact this did not help but only triggered my attention with the MAC software update message.
    There were 3 or 4 software to be updated but i noticed that one was related to iTunes (I forgot its exact description), very small update (6kb).
    I only selected this one and run it. Then I had to restart the Mac and everything is OK since then. iTunes sees my iPhone 4 every time i plug it and with all users.
    I am not sure when this itunes update came up...I had downloaded several times the latest version in the last few days so I could have expected any update to be included there ! apparently not.
    I also recently bought and installed iLife11 and Snow Leopard from CD's . This can explain why I had to update several aps.
    I know this is not very clear but i wanted to share the end of my troubles with you.

    good luck

    Francois
  • marcbyron Level 1 Level 1 (25 points)
    Ok, so I created a new user and when I plug in my iPhone, iTunes starts and recognizes the phone.
    However, I don't want to login as a different user, because I wouldn't be able to use older backups from the iPhone, etc. I would have to move my music and other settings for other programs as well, which would be annoying.

    There must be a way - other than reinstalling iTunes everytime - to get the phone to sync with iTunes under my original user.

    Restarting (using original user) doesn't help by the way. iTunes doesn't move a bit when plugging in the iPhone.

    What should I try next?
  • wisniewski Level 1 Level 1 (0 points)
    Marc,

    In my case, after the small iTunes update under my new user I restarted the MAC under my initial user name and everything was OK. I still think that this update had something to do with the solution.

    Rgds

    Francois
  • Lawrence Finch Level 7 Level 7 (30,180 points)
    Did you run System Update, as the previous poster suggested?
  • marcbyron Level 1 Level 1 (25 points)
    It was working before I hit system update. When I hit system update it wanted to update to Safari 5.03 and install a new Java engine.

    Btw. I got it to work yesterday within my original system. I restarted my iPhone (pressed lock and home button at the same time), then plugged it in and iTunes recognized it, so I could sync and backup.

    Then I shut down my computer, tried to plugin the phone again this morning - nothing.

    Restarted my iPhone again - nothing.

    I am back at square one
Previous 1 2 Next