1 Reply Latest reply: Dec 3, 2010 8:52 PM by pgn674
pgn674 Level 1 Level 1 (0 points)
I had a problem, then figured it out. I wanted to post my solution to another thread where someone had the same problem on his iPhone but no answer was ever given, but that thread was locked. So I am posting this here in hopes that it helps other people, as it seems like it would be a common problem.

My Apple account's ID was set to an old email address that I was getting rid of. I did some looking, and it seemed to me that your contact address and your Apple ID are one and the same. So I changed my Apple ID to my new email address. Then, on my iPod Touch, I was unable to update my Apps any longer. The box asking for my password displayed my old email address, and my password did not work (I had not changed it). I tried syncing my iPod Touch, and it did not help.

I eventually went into the iTunes Store on my computer, and I noticed that the Apple ID in the top right corner in the black bar was set to my old email address. So I clicked that, and was asked to log in, with my old email address pre-filled in. I changed to my new address, and tried logging in. It then said my email address was invalid, and brought up a short form with a bunch of filled in info, like my birth day. The form also had my new email address pre-filled in. So I just hit save on the bottom, and then clicked the still old Apple ID in the top right again. Same log in request. But this time, it seemed to work, and the ID in the top right changed to my new email address.

I tried an App update on my iPod Touch again, and it failed again. I then synced, and then the App update worked; it showed my new email address when it asked for my password.

I think what happened was that I changed my Apple ID in my web browser, but neither iTunes on my computer nor my iPod Touch heard about this. So I told iTunes to get with the times, and iTunes regaled my iPod Touch with the story, and so now everyone is on the same page.

I hope this helps someone. Or me in the future if I do this again and Google for the answer only to find my own post. It's happened before.

Home Built, Windows 7, iTunes 10.1.0.54; iPod Touch 2,1; iOS 4.1