9 Replies Latest reply: Dec 5, 2010 2:08 PM by sig
Gretchen Daniel1 Level 1 Level 1 (15 points)
Hi - I'm having problems with my couple-years-old MacBookAir lately. Specifically long periods where it freezes, the beach ball spins, and even a few crashes. It's not application-specific; it happens in Firefox, Mail, iPhoto... It does seem to have started when I started using iPhoto '11 (have had problems with that, too), but that could be coincidental. It's only started in the past few weeks. So far I've tried:

repairing permissions with both Onyx and Disc Utility
repairing hard drive with both Onyx and Disc Utility
performing some maintenance operations with Onyx (clearing caches)
reinstalling Snow Leopard

Nothing seems to be helping. If anyone has any suggestions I'd be most grateful. I've searched the forums but this is such a generalized problem that it's hard to know where to even begin to look.

latest crash report:
Interval Since Last Panic Report: 70219 sec
Panics Since Last Report: 1
Anonymous UUID: D2447E7A-48EB-4F99-B0F9-36B4669CEB98

Sat Dec 4 09:28:44 2010
panic(cpu 0 caller 0x2a6ac2): Kernel trap at 0x30c63cf4, type 14=page fault, registers:
CR0: 0x8001003b, CR2: 0x2a8b0000, CR3: 0x00100000, CR4: 0x000006e0
EAX: 0x4b94c000, EBX: 0x20000001, ECX: 0x2021b000, EDX: 0x1fe8e000
CR2: 0x4b94c074, EBP: 0x25932b28, ESI: 0x1fff4000, EDI: 0x2021b000
EFL: 0x00010287, EIP: 0x30c63cf4, CS: 0x00000008, DS: 0x00000010
Error code: 0x00000002

Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
0x25932948 : 0x21acfa (0x5ce650 0x2593297c 0x223156 0x0)
0x25932998 : 0x2a6ac2 (0x590a50 0x30c63cf4 0xe 0x590c1a)
0x25932a78 : 0x29c968 (0x25932a90 0x4b6a780 0x25932b28 0x30c63cf4)
0x25932a88 : 0x30c63cf4 (0xe 0x48 0x10 0x10)
0x25932b28 : 0x30c1ec67 (0x1fff4000 0x20000001 0x25932b98 0x3066d6bc)
0x25932b78 : 0x30c20d3f (0x1fff4000 0x5c02622 0x800 0x0)
0x25932bf8 : 0x561a44 (0x1fff4000 0xa8d6b6c 0x25932e3c 0x28)
0x25932c38 : 0x562b44 (0x30ca08c8 0x1fff4000 0xa8d6b6c 0x28)
0x25932c88 : 0x5633be (0x1fff4000 0xb 0x25932cd0 0x0)
0x25932da8 : 0x28421d (0x1fff4000 0xb 0xa8d6b68 0x0)
0x25933e58 : 0x21d09c (0xa8d6b40 0x437d5a0 0x1fac28 0xa53f)
0x25933e98 : 0x210234 (0xa8d6b00 0x0 0xaed42d0 0xaed96c0)
0x25933ef8 : 0x216497 (0xa8d6b00 0x0 0x0 0x0)
0x25933f78 : 0x2922ba (0x50b8188 0x0 0x0 0x0)
0x25933fc8 : 0x29d44d (0x50b8184 0x0 0x10 0x4ab1f44)
Kernel Extensions in backtrace (with dependencies):
com.apple.GeForce(6.0.0)@0x30c12000->0x30cb8fff
dependency: com.apple.NVDAResman(6.0.0)@0x30eb4000
dependency: com.apple.iokit.IONDRVSupport(2.0)@0x30625000
dependency: com.apple.iokit.IOPCIFamily(2.6)@0x2a2cd000
dependency: com.apple.iokit.IOGraphicsFamily(2.0)@0x30667000

BSD process name corresponding to current thread: Preview

Mac OS version:
10A432

Kernel version:
Darwin Kernel Version 10.0.0: Fri Jul 31 22:47:34 PDT 2009; root:xnu-1456.1.25~1/RELEASE_I386
System model name: MacBookAir2,1 (Mac-F42D88C8)

System uptime in nanoseconds: 30379975758986
unloaded kexts:
com.apple.iokit.IOUSBMassStorageClass 2.5.0 (addr 0x25b23000, size 0x45056) - last unloaded 13426456060719
loaded kexts:
com.apple.filesystems.webdav 1.6 - last loaded 20336593928071
com.apple.filesystems.afpfs 9.5
com.apple.nke.asp_tcp 5.0
com.apple.driver.AppleHWSensor 1.9.2d0
com.apple.driver.ApplePlatformEnabler 2.0.0d2
com.apple.driver.AGPM 100.8.15
com.apple.driver.AppleIntelPenrynProfile 17
com.apple.DontSteal_Mac_OSX 7.0.0
com.apple.driver.AppleHDA 1.7.4a1
com.apple.driver.AppleUpstreamUserClient 3.0.5
com.apple.driver.AudioIPCDriver 1.1.0
com.apple.driver.ACPISMCPlatformPlugin 3.4.0a20
com.apple.driver.AppleLPC 1.4.6
com.apple.driver.AppleBacklight 170.0.2
com.apple.driver.AirPortBrcm43xx 410.91.20
com.apple.kext.AppleSMCLMU 1.4.5d1
com.apple.driver.AppleIRController 161
com.apple.GeForce 6.0.0
com.apple.driver.SMCMotionSensor 3.0.0d4
com.apple.driver.NVSMU 1.1.7
com.apple.filesystems.autofs 2.1.0
com.apple.driver.AppleUSBTCButtons 1.8.0b4
com.apple.driver.AppleUSBTCKeyboard 1.8.0b4
com.apple.iokit.IOAHCIBlockStorage 1.5.0
com.apple.BootCache 31
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
com.apple.driver.AppleAHCIPort 2.0.0
com.apple.driver.AppleUSBOHCI 3.7.5
com.apple.driver.AppleUSBHub 3.7.8
com.apple.driver.AppleUSBEHCI 3.7.5
com.apple.driver.AppleEFINVRAM 1.3.0
com.apple.driver.AppleRTC 1.3
com.apple.driver.AppleHPET 1.4
com.apple.driver.AppleSmartBatteryManager 160.0.0
com.apple.driver.AppleACPIButtons 1.3
com.apple.driver.AppleSMBIOS 1.4
com.apple.driver.AppleACPIEC 1.3
com.apple.driver.AppleAPIC 1.4
com.apple.security.sandbox 0
com.apple.security.quarantine 0
com.apple.nke.applicationfirewall 2.0.11
com.apple.driver.AppleIntelCPUPowerManagementClient 90.0.0
com.apple.driver.AppleIntelCPUPowerManagement 90.0.0
com.apple.driver.AppleProfileReadCounterAction 17
com.apple.driver.AppleProfileTimestampAction 10
com.apple.driver.AppleProfileThreadInfoAction 14
com.apple.driver.AppleProfileRegisterStateAction 10
com.apple.driver.AppleProfileKEventAction 10
com.apple.driver.AppleProfileCallstackAction 20
com.apple.iokit.IOSurface 73.0
com.apple.iokit.IOBluetoothSerialManager 2.2f18
com.apple.iokit.IOSerialFamily 10.0.2
com.apple.driver.DspFuncLib 1.7.4a1
com.apple.iokit.IOAudioFamily 1.7.0fc16
com.apple.kext.OSvKernDSPLib 1.3
com.apple.driver.AppleHDAController 1.7.4a1
com.apple.iokit.IOHDAFamily 1.7.4a1
com.apple.driver.IOPlatformPluginFamily 3.4.0a20
com.apple.nvidia.nv50hal 6.0.0
com.apple.iokit.IO80211Family 300.20
com.apple.iokit.IONetworkingFamily 1.8
com.apple.iokit.AppleProfileFamily 40
com.apple.NVDAResman 6.0.0
com.apple.iokit.IONDRVSupport 2.0
com.apple.iokit.IOGraphicsFamily 2.0
com.apple.driver.AppleSMC 3.0.1d2
com.apple.iokit.IOSCSIArchitectureModelFamily 2.5.0
com.apple.driver.AppleUSBMultitouch 200.20
com.apple.driver.BroadcomUSBBluetoothHCIController 2.2f18
com.apple.driver.AppleUSBBluetoothHCIController 2.2f18
com.apple.iokit.IOBluetoothFamily 2.2f18
com.apple.iokit.IOUSBHIDDriver 3.7.5
com.apple.driver.AppleUSBMergeNub 3.7.5
com.apple.driver.AppleUSBComposite 3.7.5
com.apple.driver.XsanFilter 402.1
com.apple.iokit.IOAHCIFamily 2.0.0
com.apple.iokit.IOUSBUserClient 3.7.5
com.apple.iokit.IOUSBFamily 3.7.8
com.apple.driver.AppleEFIRuntime 1.3.0
com.apple.iokit.IOHIDFamily 1.6.0
com.apple.iokit.IOSMBusFamily 1.1
com.apple.security.TMSafetyNet 6
com.apple.kext.AppleMatch 1.0.0d1
com.apple.driver.DiskImages 281
com.apple.iokit.IOStorageFamily 1.6
com.apple.driver.AppleACPIPlatform 1.3
com.apple.iokit.IOPCIFamily 2.6
com.apple.iokit.IOACPIFamily 1.3.0

MacBook Air, iMac, Mac OS X (10.6.5)
  • sig Level 8 Level 8 (35,780 points)
    When you run Repair Disk from Disk Utility what does it report? Have you tried running the Hardware Test? Have you tried reformatting the hard drive and reinstalling the OS?
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    Hi -

    Repair Disk from both Disk Utility and Onyx reports that the hard drive is fine. What/where is the Hardware Test? SMART status is OK according to Onyx and Disk Utility.

    I've reinstalled Snow Leopard, but it did the default archive & install. I was trying to avoid the nuclear option, reformatting the drive, until I exhausted all other possibilities.

    By the way, I didn't mention, but this behavior is happening on my admin account and my test account, so it's not particular to one account.
  • sig Level 8 Level 8 (35,780 points)
    With OS installer disk in the optical drive reboot and hold down the 'd' key.
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    Thanks. Ran the more extensive Hardware test - no problems found. Any ideas?
  • sig Level 8 Level 8 (35,780 points)
    Back up and reformat the drive. Then reinstall the OS.
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    Thanks - but wouldn't I run the risk of "reinstalling" the problem if I restore from my most recent backup? Or are you suggesting I not restore, but make copies of all my files, and start from scratch with a fresh OS and an empty hard drive?
  • sig Level 8 Level 8 (35,780 points)
    "Or are you suggesting I not restore, but make copies of all my files, and start from scratch with a fresh OS and an empty hard drive?"

    Give it a shot.
  • Gretchen Daniel1 Level 1 Level 1 (15 points)
    Thanks so much for the guidance, this is a tough problem to nail down. Before I do that, I had an idea about what might be causing this... I've been having font issues. After doing some reading on it it appears that corrupt fonts can cause this sort of overall behavior, i.e. sluggishness, spinning beach ball, crashes... I ran Font Book and have several fonts that are questionable (i.e. not "safe to use"). I'm looking for a font utility which will fix corrupted fonts, because some of these are essential to me (Arial, Hoefler Text). Just looking to cover all bases before I do the obvious.

    The other complicating factor is that I am going to be getting a new 11" Macbook Air and giving this one to a friend. Obviously I'm going to wipe the hard drive clean and reinstall the OS before I do that, but I was hoping to use Migration Assistant to get my stuff on the new MBA. Didn't want to go through all the work of reinstalling 3rd party apps, etc.

    Any suggestions for hunting down font problems would be appreciated. Thanks.
  • sig Level 8 Level 8 (35,780 points)
    " I'm looking for a font utility which will fix corrupted fonts, because some of these are essential to me (Arial, Hoefler Text). Just looking to cover all bases before I do the obvious."

    use Font Book in your Applications folder.