Previous 1 2 Next 23 Replies Latest reply: Aug 30, 2014 12:43 PM by djdemonstr8 Go to original post
  • BDAqua Level 10 (122,202 points)
    Hi Beth, and a warm welcome to the forums!

    Might try these two...

    Mac OS X: About the Reset Printing System feature ...

    http://support.apple.com/kb/HT1341?viewlocale=en_US

    Might try Printer Setup Repair 5.1...

    http://www.fixamac.net/software/index.html
  • echica Level 1 (0 points)

    Great forum. I was experiencing the same issue on my MacBook Pro (10.6).  I could see and use the fax but not the printer.  After installing the suggested 2.90 version (http://support-au.canon.com.au/contents/AU/EN/0200111302.html), the printer showed up (and printed!) without any further issues.

  • BDAqua Level 10 (122,202 points)

    Welcome aboard!

  • noslenpar Level 1 (0 points)

    Thank you PAHU!!

    I just installed the MG5220 and only had scanner, no printer on Lion (OSX 10.7.2). Turning on LPR seems to have worked, the printer shows up now.

  • btmnt528 Level 1 (0 points)

    I was having similar trouble. My Mac wouldnt find the printer and i tried everything, from installing the cd-rom again and rebooting my computer and connecting to my printer to the LAN over and over again, and nothing seemed to work. I would frustrated and wanted to return the printer but i love it so much and continued my quest on how to add it on my Mac. Finally my quest came to end when i read this article. Thanks so much. Now my printer is up and running again and printing everything from photos to documents. Thanks so much!

  • btmnt528 Level 1 (0 points)

    I had trouble with my printer before and i did everything from resettting it to the LAN setup, enabling bonjour, and when i enabe bonjour on the printer, it worked the first time. but now months later, when i try to print, it says, ' communication error'. i deleted the printer and tried adding it again using the system preferences, printer&fax, then pressing the '+' buttom to add the printer but for some reason, the printer doesnt show up. Please help!! i need my printer to print out invitations for my daughters 1st birthday.

  • Carol Hammal Level 1 (25 points)

    I had the exact same problem but on OS X Lion. I had the printer installed on the same computer once before with no problems but this time when I tried to re-install it it wouldn't see it on the network. Doing the LPR advertising worked! It finally saw the printer on the network & I was able to add it. Before, it was only seeing it as a scanner.

     

    Thanks for that tip!

  • andyroy Level 1 (0 points)

    I had the same problem. downloading gthe network tool made the printer show up. thanks guys.

  • djdemonstr8 Level 1 (0 points)

    I have a Canon Pixma MG5220 and had this same problem, scanner would work wirelessly but printer wouldn't show up. I turned ON the LPR setting, and BAM! It worked!

     

    Thanks for the input.

Previous 1 2 Next