Previous 1 2 Next 24 Replies Latest reply: Mar 15, 2016 6:22 AM by JoshHibschman
arsteffen Level 1 Level 1
I just purchased a Canon MG5220 printer with wifi printing capability. I connected the printer to my wireless access point. I then setup my windows 7 computer to print through wifi with no problem. Now, when I tried to setup my Macbook 10.4.11 to print wireless, I cannot find the printer through the Canon printer utility. Any ideas?

Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10
    Hi arsteffen, and a warm welcome to the forums!

    The Driver may not work via Wifi in 10.4.x, but is the IP of the Printer the same as the IP of the Mac in the 1st three positions?
  • arsteffen Level 1 Level 1
    Thanks for the super quick reply! Yes, the ip addresses match on
  • BDAqua Level 10 Level 10
    In Printer setup Utility>More Printers, is there a Canon IJ Network, does it not show up there?
  • arsteffen Level 1 Level 1
    Correct, it does not show up in the Canon IJ Network.
  • BDAqua Level 10 Level 10
    I assume you installed the 10.4.x drivers right?

    One quirk about 10.4 & earlier, if you have Printer Sharing enabled it won't look outside of itself for a Printer, you have to not only disable it, nut reboot also.

    Mac OS X: About the Reset Printing System feature ...

    Might try Printer Setup Repair 5.1...
  • arsteffen Level 1 Level 1
    Ok. So I did the resent printing system and rebooted the computer. I went ahead and installed everything on the disk again to the computer and when I got to the canon ij network printer finder, I did see a printer pop up. However, after I selected the printer that was shown available and hit next and followed to the close of the installation process, there was no printer to be found on the mac.

    So strange!
  • BDAqua Level 10 Level 10
    Hmmm, let me ponder this a bit, hopefully PAHU the Canon & printing expert sees this & pops in, if not bump this thread with a reply of some kind.
  • arsteffen Level 1 Level 1
    Yeah, I even did the printer setup repair and wiped all the drivers away and then reinstalled the printer driver. I got to the step where it showed the printer on the Canon IJ Network tool window, but once I selected it and hit next to finish, there is nothing to be seen on the Mac printer info.

  • PAHU Level 6 Level 6
    If the printer is not appearing in More Printers > Canon IJ Network, then it would suggest that the service is not running or installed. If you look at your menubar, on the right side near the time & date, you should see an unusual icon. To me it always looked like a fancy art-deco chair but it is supposed to represent a scanner with its lid open and it is connected to a wired network. Do you have this icon in the menubar?
  • arsteffen Level 1 Level 1
    I do have that icon there on the mac and I actually scanned a photo and it transferred the scanned image over to the mac via wifi! However, when I try to add the printer to the mac's print & fax system setting, the printer is no where to be found.
  • PAHU Level 6 Level 6
    Try installing version 2.90 of [Canon IJ Network Tool|]. This is what I am using on the 10.4.11 Mac and I can see the MG printer on the wireless network.

    If this doesn't help then you could look at enabling a setting in the printer called LPR service advertising. When enabled, this setting advertises the Line Printer daemon protocol (LPR) service using Bonjour. Since the scanner is working and it uses Bonjour I am expecting that when you enable this LPR service the printer should appear in the Default add printer view (rather than going to More Printers).

    To enable the LPR setting, go to Settings > Device settings > LAN Settings > Other Settings > Bonjour settings > LPR service advertising and set to ON. Then return to the Home view and then do an Add Printer on the Mac again, this time selecting the Default view.
  • arsteffen Level 1 Level 1
    Ok! So, I fiddles around with the scanner icon and enabled it. Then I went back into the Canon IJ Network and the printer finally showed up! I made one successful printer via wifi of "hello world"! Thanks for all the help guys, I really do appreciate it!
  • E.M.C. Level 1 Level 1
    I was having the same problem, but found this discussion and tried installing Canon IJ Network Tool, as advised. It worked! (The new Canon printer then showed up as an option to select in the printer browser of the Printer Setup Utility.) Thank you!
  • bethm69 Level 1 Level 1
    I was overjoyed to see this topic, because I encountered this very problem today. I installed the printer on my new Macbook Pro (OS X 10.6.6) with no problem and immediately printed. Then went to iMac (OS X 10.4.11) and tried to do the install. No printer showed. After setting LPR service advertising to ON, I then saw the printer appear and was able to choose it. However, when attempting to print, the job just hangs forever until I cancel it. Any suggestions???

    Other info: Macbook Pro is completely free-floating. iMac is connected to wireless router by Ethernet.
Previous 1 2 Next