Previous 1 2 3 Next 117 Replies Latest reply: Aug 25, 2012 9:05 AM by Sylvan B.
HoonAndReel Level 1 Level 1 (0 points)
Even though 4.2.1 did help increase my phone speed in some areas, my maps became unusable over the 3G network. I turned off the location service for my maps and that solved the problem. Wishfully hoping that they fix this in the next update.

Anyone else have this problem?
  • Lawrence Finch Level 7 Level 7 (29,490 points)
    While a lot of other problems have been reported recently, yours is the first I have seen for this problem. So it's probably something wrong with your phone. Try restoring with iTunes and set up as a new phone without reloading your backup.
  • RestlessFool Level 2 Level 2 (380 points)
    If it's unusable over the 3G network, how does it work over WiFi (from your home/work/hot-spots)?

    If it's OK then it's a carrier issue.

    As you didn't specify a location in your profile it's impossible to say which carrier you're using and whether others using that carrier have experienced the same issue.
  • spottphoto Level 1 Level 1 (0 points)
    I have been experiencing the same problem with my 3G since updating to 4.2, which is extremely frustrating because I use my maps feature frequently. Any solutions folks?
  • thathuvam Level 1 Level 1 (0 points)
    I have the same problem with the maps. I am on AT&T and it doesn't work on 3G in San Francisco. It works intermittently on wifi, but the location service seems to take a long time to exit which causes any other application to not load. So pretty much when I try to use the maps, my phone becomes unusable. Any resolutions?
  • h0stile17 Level 1 Level 1 (5 points)
    I'm having the same issue with the maps app crashing whether I am on WiFi or on 3G. From all of the research I have done I can't find a resolution but this is not an issue with the phone hardware as stated in the first reply. It's seem to be an issue with available memory based on the logs that my iStat app creates.

    Just file this under the "Sorry iPhone 3G users" section
  • Jill U Level 1 Level 1 (0 points)
    i am having the same issue.....since the update, my maps is not working....have you found a "fix" for this?
  • GeekApproach Level 1 Level 1 (0 points)
    Just thought I'd chime in and say I'm having the exact same problem. I've noticed that even doing a hard reboot with no other running apps in the background causes the same problem. Forcing Maps to quit leaves the "location active" icon arrow in my status bar, even when I switch over to Airplane Mode.

    I'm hoping someone at Apple has a solution to this...and that it doesn't involve me needing new hardware.
  • Lawrence Finch Level 7 Level 7 (29,490 points)
    Maybe, just maybe, there is another application using Location Services. For example, are you using Dataman?
  • montauk Level 1 Level 1 (0 points)
    I have the same problem. My 3G freezes when using maps (usually when I start typing the location that should be searched, one of the first letters pops out and then freezes). This takes a while. Then the location service icon stays there for a moment on the home screen. To exit immediately is impossible I just have to wait. Sometimes this process can be repeated 2 to 3 times, then it works. Tried to reboot, did not change anything.
  • Gordon Craig Level 1 Level 1 (0 points)
    I'm having the same problem on my 3G iphone. The map app opens, but then locks up for ~5 minutes or so. Eventually it starts working, but that's only after 5-10 minutes.
  • A. Koe Level 1 Level 1 (0 points)
    I have been having this exact problem as well. I'll try to use Maps; Slow to load the app, then freezes absolutely once I hit a character to input a search term. Location icon stays visible for about a minute.

    I use the Maps app several times a day. This has the "Oh look, your hardware is starting to become slightly outdated, better upgrade before you can't even use the base functionality;" ring to it. Thanks a lot Apple. Way to look out for your customers.
  • khyrox Level 1 Level 1 (0 points)
    Same problem here. Maps is basically unusable on 3G 4.2.1. It just hangs my iPhone for minutes before I can do anything. All of the apps on my phone that uses map/location functionality seems to be affected based on my experience. The iPhone is extremely sluggish after I exit the app.

    I am surprised that Maps is running as poorly as it is. Considering how many apps use location/map functionality I would hope this issue gets recognized and fixed soon.
  • CShaner Level 1 Level 1 (0 points)
    Nothing new to add really, but just adding to the discussion.

    I've noticed the same thing on a 2-year old iPhone 3g running ios 4.2.1. When launching maps with locations services toggled to 'on' the phone becomes virtually unresponsive - touch screen won't register movements, home and power button responses are delayed. Even after closing out of maps, the phone continues to drag as the gps (arrow) indicator remains active in the status bar. Phone will remain unresponsive until the indicator arrow turns off. The only (temporary) resolution I've found is to either power down the iphone or run a hard reset. Otherwise, I have to turn off location services later for maps and other location/gps- based apps to run correctly.

    As a side note, I noticed a similar lag in facebook when location services was on, but once turned off the app appears to run without incident. As other stated, appears to be an unfortunate by-product of advancing software on "outdated" hardware, but hope to see this addressed so we can continue to use native apps and functions of the iPhone. Otherwise, doesn't speak well to long-term iphone compatibility and relevancy.
  • RollinAbes Level 1 Level 1 (0 points)
    I got the EXACT same problem with the phone freezing up when using GPS when I updated my iPhone 3G to 4.2.1

    Here's how you fix it:

    - Go to settings, general, auto-lock, change it from 1 Minute to NEVER
    - Go to settings, general, reset, reset network settings (THIS WILL REBOOT YOUR IPHONE)
    - Go outside, in a clear place with NO tree's, buildings, or anything blocking your view of the sky
    - Open "MAPS", click NO on all that wi-fi crap, then click the little gps icon, and let it sync up with the satellites (this could take a few minutes)
Previous 1 2 3 Next