4 Replies Latest reply: Dec 6, 2010 3:43 AM by Copper_Eos
Copper_Eos Level 1 Level 1 (0 points)
Hello, I have to networks where I live and each time I restart my computer I have to log back into my network. I can't figure out how to save my password so I don't have to log in every time. Can anyone help me with this?

Macbook, Mac OS X (10.6.4)
  • Jolly Giant Level 7 Level 7 (25,440 points)
    do you have an Apple base station ? if so, launch *airport utility* and enter +manual setup+ for the device. go to the airport pane, then to the wireless tab.

    ignore the other arrows etc. in the following screenshot but check if there is a tick in the little box next to +remember ... in my keychain+

    Jolly's TC

    JGG

  • Copper_Eos Level 1 Level 1 (0 points)
    Unfortunately I don't have an airport base station so I still need help
  • Matt Clifton Level 7 Level 7 (29,490 points)
    Your wireless network passwords should automatically be saved no matter what kind of router you have. Try repairing your keychain - in the Applications/Utilities folder, launch Keychain Access, and click on the "Login" password on the top left of the window. Go to the Keychain Access menu, click FIrst Aid, and type your Mac login password, then click Repair and Start.

    Also, try searching in the keychain (the search box is on the top right of the Keychain Access window) for your wireless network passwords - (they'll all be listed as Airport Network passwords)

    Make sure also, in System Preferences - Networks, under Airport - Advanced, that you tick "Remember networks this computer has joined"

    Hope that helps

    Matt
  • Copper_Eos Level 1 Level 1 (0 points)
    For some reason when I connect to a network it doesn't have the "Save Password" checkbox that older versions of OS X had. I was able to fix it in a similar method as you described Matt. I went into Keychains and deleted the one network that was saved. I already had "Remember Networks" checked in my network settings. So I just re-joined the networks then went back into Keychains and made sure the check box by the password was checked. This seemed to fix the problem and now I don't have to rejoin the networks every time I login or startup the computer.