14 Replies Latest reply: May 8, 2011 8:02 PM by simken
satchelpig Level 1 Level 1 (115 points)
I have seen threads that indicate problems with WiFi speed after iOS 4.2.1 was released, but my problem isn't with speed exactly.

In brief, my iPad will essentially go to sleep on its WiFi connection regularly, despite showing a 100% WiFi signal at all times. I can correct the problem temporarily by turning the WiFi off and then on again, but this is quickly becoming a nuisance.

Speedwise, the speed is terrific when it's locked in and working. So I don't have the slowness issues some others are reporting. It's just more of an all-or-nothing deal.

Per some threads I read elsewhere, I tried resetting my network on the iPad, but the problem persists.

Are there any known solutions out there? Do we have any indication that Apple is aware of the problem?

iPad 3G 64GB, iOS 4, Netgear WNDR 3700 Router (N)
  • satchelpig Level 1 Level 1 (115 points)
    That page is just suggesting restarting the iPad. I've done that. When I do it, I have the same issue -- WiFi works great for a while, and then stops working entirely, despite showing full signal strength.
  • Ralph Landry1 Level 8 Level 8 (37,780 points)
    It sounds like you have researched the issues discussed and are up to speed on the solutions offered.

    The occasional dropping seems to be a problem a few users are experiencing. So far I have not seen anyone with a definitive solution.

    Just the usual:

    Restart the iPad
    Restart the router
    Change router channel
    Update router firmware and drivers
    Reset iPad network and reinstall information
    Be sure you are using WPA or better security
    Turn Safari AutoFill OFF

    There is not a lot more to offer at this point.
  • UG64 Level 2 Level 2 (150 points)
    I completely understand, my launch day iPad has this very problem from the start and was fixed with iOS 3.2.1, but with the iOS 4.2.1 update the problem is back. The best work-around for me beyond turning wifi off and then on again is to have the access point set to only one 802.11 protocol, B, G, or N.

    My iPad will maintain a solid connection for hours while connected to a WAP that is setup to run just one 802.11 protocol not mixed. I've tested this on three different routers, two (b/g) and one (b/g/n), and the results are reproducible. I've contacted Apple Care about this and they are being made aware of a growing problem among iPad users, so a solution should be three months down the road like the last time they fixed the problem. If that isn't something you can work with, it might be best to return the iPad, because it's clearly a minor hardware fault with a minority of iPads as many of the users in these forums will tell you that there isn't any problem with their iPad. Me, I'm willing to give Apple a chance to fix the bug.

    You should still call Apple Care about your problem or at least submit a bug report to apple.com/feedback, they do not read these forums, the forums are user driven.
  • Jpw6 Level 1 Level 1 (0 points)
    To add to the growing evidence that this is likely a iOS 4 bug on the iPad, I have an iMac, Windows 7, three iPhone 4's and a year old and a new iPad using the same router. Only our iPads, since upgrading to iOS 4, are having the problem where the connection gets dropped and we're prompted to reconnect. Little doubt in my mind that this is an iPad iOS 4 bug. Hopefully Apple fixes it quickly. I'll have to try setting my router to b, g, or N as a work around to see if that eliminates the annoyance until they provide a fix.
  • Bounty Bob Level 1 Level 1 (0 points)
    I have this exact same issue. Really annoying as I develop apps and use the wifi extensively within that development. Every half hour or so, the wifi just goes off, even though full signal is displayed. Going to settings and turning wifi off and on again resolves it for a short while.

    Will speak to my network admin about router settings, but that might not be an option for me.

    edit this is since the upgrade to 0S 4.2.1

    Message was edited by: Bounty Bob
  • Gswayne Level 1 Level 1 (0 points)
    Same issue here but I have not upgraded to 4.2.1. It will drop the connection in the middle of a download. When I go to settings I see that it says WiFi not connected yet it shows full strength on the icon at the top left of the iPad. Also interesting to note that this happens more frequently at work than at home. I don't have router details at work but the home router is a Lynxsys. Will check for a firmware update at home and talk to my IT person about the router at work.
  • jmillernj Level 1 Level 1 (0 points)
    My IPAD WiFi works flawlessly on my home network using a Verizon FIOS wireless modem/router. While away from home, I use a SMC 80.11n router with a Comcast Arris modem and have constant problems with the WiFi connection "locking up". Like other people have reported, it is necessary to turn the WiFi off and then back on to resume browsing. After the reset, the connection works for a while and then locks again, usually after following a new link. I also have two MacBooks on the same wireless LAN and they do not experience any problem with the network. This seems to be an issue with IOS (4.2.1). Does anyone know if Apple is addressing this issue?
  • Gurneyhck Level 1 Level 1 (0 points)
    I also have this problem, not able to fix it yet
    But i just read this on ipadforums.net:
    +"Someone else on here had a wifi SSID with a space in the name and removing that fixed the problem."+

    I also have a space in my SSID, so maybe this is THE solution.
    But I'm not able to try this out right now, I will try it tomorrow. Maybe someone else can already try it...
    Will post back if I had any luck or not. I also send a bugreport via the feedback-form posted a couple of posts up. Recommend everyone with this problem does this, so our problem soon gets fixed
  • Pftumch Level 1 Level 1 (0 points)
    Same issues here.turning wi fi on/off seems to cure it for a short while,but it,s becoming a pain now
  • adrenna Level 1 Level 1 (0 points)
    I had the same issue when I first got the iPAD. I resolved by using a dual band router. The house gets the 2.4 side and the iPAD gets the 5 ghz side all to it self. The problem went away instantly. I read somewhere that the iPAD likes a constant connection. Also, the cause may be the other wireless components in the home. The speed of the wireless network is only as fast as the slowest device. When the router switches speeds, the iPAD locks up.
  • Gurneyhck Level 1 Level 1 (0 points)
    Changing SSID to a name without a space didn't solved the problem here..
  • Vancouver Taylor Level 1 Level 1 (0 points)

    Same problem here. I have a wifi only 64 gig iPad 2 and have found my wifi to be dropping out all the time. The wifi icon has full bars but I can't get on the internet. My short term solution is to just turn off and on the wifi again so it works. This is getting frustrating. My iphone 3g and 4 doesn't have this problem. My network name has a space in it if that matters and I live in an apartment with 10 other networks in proximity.

  • simken Level 1 Level 1 (0 points)

    I have had exactly the samenproblem ever since I upgraded to the new iOS.  They have a bug and I hope it is fixed very soon.