Skip navigation

Self-assigned IP address with Apple USB Ethernet Adapter

10002 Views 7 Replies Latest reply: Jul 11, 2011 5:01 PM by monikeoreilly RSS
fix2k5 Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 7, 2010 10:37 AM
Hello,

I recently bought MacBook Air 13'' (Late 2010) and Apple USB Ethernet Adapter but wasn't able to get ethernet network working. I have tried two different routers but it always shows "USB Ethernet has a self-assigned IP address and will not be able to connect to the Internet". Device is recognized, cable is connected (status: connected) but IP is not assigned (even thou it is set to automatic DHCP). Tried renewing IP but no luck - the same issue. Needles to say that ethernet works fine with Windows PC.

The same router perfectly assigns IP if connecting via WiFi.

Any help would be appreciated.

Thanks,

Ugis
MacBook Air 13'' (Late 2010), Mac OS X (10.6.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.