Previous 1 2 Next 20 Replies Latest reply: Mar 19, 2014 7:12 PM by Kathryn1804 Go to original post
  • Moi0111 Level 1 Level 1 (0 points)

    I dunno why, but I aslo got the same problem. I'm also from Malaysia. no matter how many times I tried, it kept on telling me to input at most 3 letters in the County box when I chose my actual county code.

     

    What I did was, I chose another county code, in my case...I chose JH. Somehow, it accepts that...I have no idea why. Then I went back and change the code to the actual county code. It worked.

  • J Andrade Level 1 Level 1 (0 points)

    I have the same history of your guys, I also couldn't purchase at the iTunes Store in my iPad because there is an error with my province address. I am in Brazil. After reading all the posts about the same problem, I tried the "solution" everybody had tried and finally I wal allowed to proceed.

    This does appear to be quite a bug. I agree with the people from Malaysia that this needs to be corrected. Remembering: the original post was posted on Dec, 8th, 2010, but the problem goes on.

    What did Apple do, better, what should Apple do?

  • ninguem Level 1 Level 1 (0 points)

    Same here... Contacted iTunes Support, **sent a screen shot of the issue**, explained that was a problem in editing the billing information, etc... The guy told me to install the iTunes(?) and told me how to change my billing information(?)...

    Waiting for Apple to correct the issue. I'm a huge fan and I would like to see that fixed please!!

  • Cam Anderson Level 1 Level 1 (0 points)

    Here I am in 2013 with the same problem for Canada. What the ????

  • Cam Anderson Level 1 Level 1 (0 points)

    OK, I just fixed it. You have to go to Store, on your computer, and change your account there. You cannot validate from where you are purchasing, or you have the province digits limit issue. Go to the store on your PC

  • Kathryn1804 Level 1 Level 1 (0 points)

    2014 and still an issue.  Followed the workaround on page 1 using itunes on my computer and got it updated.  Honestly .. nobody has fixed this in 3 years????

Previous 1 2 Next