14 Replies Latest reply: Jan 26, 2011 10:15 PM by steampunked
natalie-x0x Level 1 Level 1 (0 points)
I have windows 7 and am running 64 bit
itunes USED to work ok before there were a few glitches but it was ok
now since I have downloaded the latest itunes (yes I downloaded the 64 bit version) it has not been working at all. I would open it and it would not pop up. So i went to task manager and it says itunes*32.exe. After about an hour or so itunes would open but it would just be frozen.
I have completely uninstalled it and all components of apple 6 times now.. I have tried to download the lastest itunes once again and an error msg would show up

*The version of this file is not compatible with the version of Windows*
*you're running. Check your computer's system information to see whether*
*you need an x86 (32-bit) or x64 (64-bit) version of the program, and then*
*contact the software publisher.*

I have no idea what this means bcoz i downloaded the 64 bit version!!!

so i tried to download an older version i tried 9.2 which did not install..
and then tried 8.2 which installed but does not work!!!

so when i try to run 8.2 itunes NOTHING happens when i click task manager there it is in processes again as itunes*32.exe

I have never had any other version of windows on this laptop but i have tried to change the compatibility to other versions.. did not work ofcourse..

then tried troubleshoot and it just says itunes is incompatible..
i really dont understand how a month ago itunes was working and now its not

yes i have sweeped my computer for viruses and downloaded all the updates windows has suggested..

I dont know what else to do im no computer whiz

i have seen a fair few people with similar issues

any suggestions???

Acer, Windows 7
  • natalie-x0x Level 1 Level 1 (0 points)
    oh and now i get an error msg saying that 'ituneslibrary.itl' cannot be read bcoz it was created with a newer version of itunes... GAH ***

  • b noir Level 9 Level 9 (72,015 points)
    The version of this file is not compatible with the version of Windows

    you're running. Check your computer's system information to see whether
    you need an x86 (32-bit) or x64 (64-bit) version of the program, and then
    contact the software publisher.

    Try downloading an installer again:

    http://www.apple.com/itunes/download/

    Is the name of the file you're downloading iTunesSetup.exe or iTunes64Setup.exe ? (The latter name is what the 64-bit installer file should be called.)

    If you've been getting an iTunesSetup.exe, then your web browser hasn't been autodetecting your operating system correctly. So to get a 64-bit installer, on the left of the downloads page in the *Windows Software* text (you may need to scroll down to see that) click on the *64-bit installer* link. That'll take you through to a downloads page for the iTunes64Setup.exe.

    Once you've got the latest 64 bit version installed again, we start checking on a few of the more common causes of error-message-free iTunes launch failures.

    Some questions in the interest of narrowing in on possible culprits with an error-message-free iTunes launch failure.

    (1) Does your QuickTime Player launch, or do you get an error message of some kind when you try to launch that?

    (2) If your QuickTime seems to be launching fine, try (by way of experiment) disabling the BonJour Service.

    In your Start Menu, right-click Computer and select "Manage".
    Expand "Services & Applications".
    Open "Services". (Maximise the window to better see what's going on.)
    Right-click the BonJour Service and select "Properties". In the "General" tab, set Start-up type to "Disabled".
    Restart the PC, and try launching iTunes again. Does it launch this time?

    If iTunes launches with the BonJour Service disabled, by any chance do you have a recent version of IOBit's Advanced SystemCare utility currently installed on the PC? If so, try uninstalling and reinstalling Advanced SystemCare. Can you launch iTunes without having to disable the BonJour Service now?
  • natalie-x0x Level 1 Level 1 (0 points)
    thanks for replying.. well I have downloaded the proper 64bit version but i erased itunes and downloaded it again.. this time when opening the file to install it a different error msg showed up..

    *Unsupported 16 bit application.*
    *The program or feature itunes64setup.exe cannot start or run due to incompatibility with 64 bit versions of windows. Please contact the software vendor to ask if a 64bit windows compatible version is available.*

    I have sweeped my laptop for viruses again bcoz this just doesnt make any sense but nothing is coming up..

    I have never had this problem before
  • b noir Level 9 Level 9 (72,015 points)
    Unsupported 16 bit application.


    Good gracious. I believe that's a rare variation of the "not a valid win32 application" message. In that case, the installer is getting damaged during the download.

    Perhaps let's try the following document first:

    [iTunes: Windows reports that "iTunesSetup.exe is not a valid Win32 application"|http://support.apple.com/kb/TS1406]
  • natalie-x0x Level 1 Level 1 (0 points)
    OK well got itunes installed without any errors but the program still doesnt launch..
    disabled bonjour, restarted, tried to launch again..
    error msg

    *itunes.exe has been set to run in compatibility mode for an older version of windows.*
    *for best results, turn off compatibility mode for itunes before you open it.*

    umm i right clicked on itunes and went to properties, compatibility, and unchecked run this program in compatibility mode..

    tried again but itunes wont open

    oh and quicktime works fine

    should i enable bonjour again?

    thanks for your help so far!
  • natalie-x0x Level 1 Level 1 (0 points)
    well now a window popped up saying *itunes setup assisant* but the window is blank and is unresponsive..
  • natalie-x0x Level 1 Level 1 (0 points)
    hmm ok well the error msg showed up again today but this time i was able to see what it said which was that bonjour was disabled and that i need to enable it again after i clicked ok itunes actually opened and i was able to use it..

    i do not have any system care programs things that i know of

    i enabled bonjour, restarted and yeah itunes did not open again..

    how can i find out if i have that systemcare program or is there any other issue that might be causing this..
  • natalie-x0x Level 1 Level 1 (0 points)
    goodness.. with bonjour enabled.. after half an hour itunes opened but is frozen which was the original problem..
    this is annoying..
  • b noir Level 9 Level 9 (72,015 points)
    how can i find out if i have that systemcare program or is there any other issue that might be causing this


    If you've got the SystemCare package, there should be an *Advanced SystemCare 3* entry in your Uninstall a program control panel. (I just tried installing it myself to see how it appeared.) Can you see anything like that?
  • natalie-x0x Level 1 Level 1 (0 points)
    no nothing like that at all...
    I disabled bonjour again and itunes works fine...
    i dont actually need bonjour do I? I dont even know what it is haha

    any other suggestions as to why this may be happening?
  • b noir Level 9 Level 9 (72,015 points)
    It's a conflict between BonJour and something on the PC, which is taking down iTunes as collateral damage. (Whether it's a conflict with an application or a driver or something else isn't so clear at the moment.)

    The main things I can think of that iTunes uses BonJour for are Home Sharing, syncing to AppleTVs, and Remote apps on iPads/Pods/Phones. If you're not using any of that, we could just go with the workaround of disabling the BonJour Service ...
  • natalie-x0x Level 1 Level 1 (0 points)
    hmm I see.. well I will see how things go now if I have any more problems I'll be sure to come back..

    Thank you so much for your help!!
  • b noir Level 9 Level 9 (72,015 points)
    No problem. Glad things are finally working a bit better for you.
  • steampunked Level 1 Level 1 (0 points)
    well it is 1/26/2011 and I have the same problem, computer says incompatible application for itunes!!! It stopped working 12/26/10, nothing is new. I deleted itunes and downloaded new version, still the same problem. it can play music that is in library but the store can't be accessed and the whole site looks gray. HELP!