Previous 1 2 3 Next 115 Replies Latest reply: Oct 24, 2012 8:01 AM by Grenabo
SteveK12 Level 1 Level 1
The first time that I used Facetime on my Mac it worked perfectly fine.. that was right after I installed it.. but ever since, i have not been able to log in. My Apple ID and password are correct but it keeps telling me that the server encountered an error processing registration and to please try again later but it still won't work. What do i do?

MacBook, Mac OS X (10.6.5)
Reply by FilipeTeixeira83 on Jan 1, 2011 9:20 AM Helpful
I had the same problem, and found the solution in other thread:

"This worked for me: (make sure Facetime is closed)
1. In Spotlight type in "Keychain Access"
2. There will be a certificate issued by Apple iPhone Device CA - This certificate was signed by an unknown authority. Delete this certificate (or move it to the desktop, out of the keychain access store)
3. Launch Facetime and login - this time there will be no error..."

from: http://discussions.apple.com/thread.jspa?messageID=12561111

All replies

  • EZ Jim Level 7 Level 7
    SteveK12 wrote:
    The first time that I used Facetime on my Mac it worked perfectly fine.. that was right after I installed it.. but ever since, i have not been able to log in. My Apple ID and password are correct but it keeps telling me that the server encountered an error processing registration and to please try again later but it still won't work. What do i do?


    Welcome to Discussions, SteveK12

    Try shutting down everything. Then restart modem, router (if you use a separate device), and Mac in that order. Allow each devices' self-test to finish before starting the next. Then test FaceTime again with no other apps running.





    Mac Pro Quad Core (Early 2009) 2.93Ghz Mac OS X (10.6.5); MacBook Pro (13 inch, Mid 2009) 2.26GHz (10.6.5)
    LED Cinema Display; G4 PowerBook 1.67GHz (10.4.11); iBookSE 366MHz (10.3.9); External iSight; iPod4touch4.2.1
  • Morgan88 Level 1 Level 1
    Mine did the EXACT same thing. I shut everything down... restarted.... no change. I even deleted the FaceTime app and reinstalled it. I Still can't get it to work.

    Help anyone?
  • EZ Jim Level 7 Level 7
    Morgan88 wrote:
    Mine did the EXACT same thing. I shut everything down... restarted.... no change. I even deleted the FaceTime app and reinstalled it. I Still can't get it to work.

    Help anyone?


    Welcome to Discussions, Morgan88

    You say "EXACT same thing." 

    Do I understand correctly that you:

      (1) tried to activate FaceTime in Ontario although you show "Alabama" as your location, and

      (2) received a message that the server encountered an error processing registration ?

    If so, how long did you wait to try again?

    Did you continue to try for at least 24 hours?

    We may be able to offer specific suggestions based on the details in your response.


    Message was edited by: EZ Jim


    Mac Pro Quad Core (Early 2009) 2.93Ghz Mac OS X (10.6.5); MacBook Pro (13 inch, Mid 2009) 2.26GHz (10.6.5)
    LED Cinema Display; G4 PowerBook 1.67GHz (10.4.11); iBookSE 366MHz (10.3.9); External iSight; iPod4touch4.2.1
  • FilipeTeixeira83 Level 1 Level 1
    I had the same problem, and found the solution in other thread:

    "This worked for me: (make sure Facetime is closed)
    1. In Spotlight type in "Keychain Access"
    2. There will be a certificate issued by Apple iPhone Device CA - This certificate was signed by an unknown authority. Delete this certificate (or move it to the desktop, out of the keychain access store)
    3. Launch Facetime and login - this time there will be no error..."

    from: http://discussions.apple.com/thread.jspa?messageID=12561111
  • Graham Parker Level 1 Level 1
    FANTASTIC

    I have been trying to log in for weeks following lots of discussions and long winded fixes that didn't!!!!

    Yours worked straight away,
    Thankyou
  • Kaitimar Level 1 Level 1
    Worked for me too.

    Thanks!
  • Jack Cooley Level 1 Level 1
    Great solution! Thanks for the help!
  • SteveK12 Level 1 Level 1
    Thanks for the help.. it works great now
  • zphatkid Level 1 Level 1

    Worked like a charm. Thanks!

  • deedii Level 1 Level 1

    FilipeTeixeira83

     

    Nice work... your fix worked perfect. Apple needs a support doc with this fix.

    Thank you.

     

    Diane

  • sadi83 Level 1 Level 1

    Hi, I have the same problem, but i have not any certificate issued by Apple iPhone Device CA in Keychain Access.

    Any idea to fix my error?

     

    Thanks,

    Daniele

  • james fromcanterbury Level 1 Level 1

    im in the same boat as sadi on Lion (10.7) i get no iphone device CA in keychain access and i still cant get around the "the server encountered an error processing registration please try later" error . any help would be great

  • DribbleCastle Level 1 Level 1

    Same issue here with Lion.   Other Lion test Macs have been able to sign in and work fine.

  • tenfifteen Level 1 Level 1

    Having the same issue, which is apparently somewhat rampant (confirm via Google). I've moved all certs out of the keychain. None of the above suggestions work. Would love an official response here from Apple.

Previous 1 2 3 Next