11 Replies Latest reply: Dec 13, 2010 10:12 AM by wjosten
LostSoul 301281 Level 1 Level 1 (0 points)
I bought an iPhone 4 two weeks ago and I still cannot get it to detect my wireless home network.

I use a Time Capsule as my router, which is plugged directly into my modem via ethernet.
My Macbook can find my network/TC fine, and has done since I bought it.

My wireless settings are 802.11n only (5GHz) with wireless security set to WPA2 Personal.

I tried changing my settings and found that the only one that worked at connecting my iPhone was 802.11n(802.11b/g compatible), but it caused serious problems.
The connection between my TC and Macbook was severely reduced, and it could not detect my TC in Airport Utility, so it would not run the Time Machine back-up, and I was unable to get access to the settings to change them back.

I had to do a full reset on my TC(power down, hold reset button in and power on again) about six times before I could get it all working properly again and get access to the settings.

If I try to manually search for my network on my iPhone, it still will not find it.
It will find other peoples networks, but not mine.
And my current settings are the only ones that work perfectly with my Macbook and Time Capsule.

Any help?

2.1GHz Macbook, Mac OS X (10.5.8)