Previous 1 2 Next 25 Replies Latest reply: Aug 9, 2011 12:26 PM by rsrhcp Go to original post
  • codywater Level 1 Level 1 (0 points)
    I am having the same problem: AirPlay works fine with audio from the iPhone, however, the AirPlay button does not appear as an option for any photos. Tried resetting iPhone and Apple TV to no avail. Apple TV showed no software updates available yesterday, but I just checked again and it shows one update. Hopefully that solves the problem.
  • John Knowles Level 2 Level 2 (335 points)
    I hope the updates work for you guys; in my case I've already applied the last ATV firmware update and it did not address the problem.
  • Wolfang Level 1 Level 1 (0 points)
    I've the same problem, all devices are now updated but... I didn't resolve yet. It works correctly on my Ipad, but if I use Iphone4...it seems freezed on the first photo, there is always a long delay....something is of course wrong...it is not usable.. please help me
  • ChuckHo Level 1 Level 1 (0 points)
    I too am having the same problem. I can use the Remote iPhone app, and that works without any problems, so I don't think it's a problem with WiFi. But when I use the Photos app to show pictures on my TV via Apple TV, I can show 1 or 2 photos, sometimes more, then it stops working. The TV picture freezes on one photo, and no matter how many photos I browse through (on the iPhone), the TV picture doesn't change. If I stop AirPlay and restart it, usually that does not help. Occasionally it works for a bit after that.
  • bob83148 Level 1 Level 1 (0 points)
    I had the same problem and found that if I put the iphone in airplane mode - the slideshow feature worked great.
  • sandler77 Level 1 Level 1 (70 points)
    If you enable a Photos slideshow on the iPhone and change the custom transitions/photo lengths, everything plays fine on the iPhone 4 as expected. However, now that you can stream to the Apple TV2 using AirPlay, there is a bug in the 4.2.1 software. If you start your Photos slideshow on your iPhone, then press the airplay icon (top right of the screen), it streams your slideshow to Apple TV2. Great news! However, the issue is that the pushed slideshow only shows photos using the dissolve transition with 2 second intervals between photos, regardless of your user defined slideshow options. As soon as you disable the pushed AirPlay slideshow and go back to the slideshow on your iPhone using the Photos app, it plays fine using your custom settings...

    Maybe we will see a fix with the iOS 4.3 software coming soon? I hope Apple gets it right this time.
  • Patrick Faltico Level 1 Level 1 (10 points)
    To Zoeythedog, curious what model of iPhone (3gs or 4) you have? And do you know if it's the older bootrom 3gs or newer? Did you get the iPhone in 1st half of 2009 or before?

    I see that many people with this problem, including me, have latest software updates but keep seeing the photo airplay bug. I'm wondering if it's somehow hardware related.

    Fyi, I have older bootrom iPhone 3gs. Thanks for sharing.
  • ChuckHo Level 1 Level 1 (0 points)
    The tip suggested by bob83148 worked for me. I set the iPhone to *Airplane Mode*, then turned WiFi back on. It's working great now! I hope Apple has a fix for this in OS version 4.3 that's coming out soon.
  • John Knowles Level 2 Level 2 (335 points)
    BUMP.

    Just updated to the latest software (v4.3 on iPhone/iPad, 4.2 on ATV2) and so far photos over Airplay IS working normally from an iPhone 3GS.

    Et tu?
  • lennydas Level 1 Level 1 (10 points)
    I am having trouble streaming photos from iphone 3gs with new 4.3 software. I do not get an option for airplay with my new ATV (updated software). The music and videos stream from phone, just not photos. Anyone have a suggestion?
  • rsrhcp Level 1 Level 1 (0 points)

    The ATV would get stuck on the first photo, or else get a few photos into a slideshow before crapping out.

    Sounds similar to my situation.  When I try to run the Slideshow feature on the Photos app on my iPad/iTouch, ATV2 shoots off a few images real quick, then goes back to the ATV screen like nothing happened.

     

    Did you end up finding a solution to this? Check out more here:

    https://discussions.apple.com/thread/3250875?tstart=0

     

     

     

    Also, you mentioned a 3-4 second lag.  I figured out that my physical proximity to my router (hooking up the iPad and ATV2 via WiFi) made a HUGE difference. I'm talking 4 second to .5 second lag.  Maybe that could help too!

Previous 1 2 Next