Previous 1 2 Next 22 Replies Latest reply: Jul 14, 2011 1:36 PM by drumorgan Go to original post
  • dontbestupid Level 1 (15 points)
    Actually, I just discovered another sequence that seems to work: Select one of the calendars under the group "xxxx@me.com" then select 'Calendar' and 'Change Location' on the menu bar. Leave the the publishing server as mobileme and check the box 'Publish Changes Automatically' then click 'Publish'.
    The progress bar froze at the end and I had to do a 'force quit' but changes to the calendar are publishing automatically as before the 4.0 update.

    Let's see if it keeps working.
  • MacApple2 Level 1 (0 points)
    This works. Thanks for that.
  • dwmoore Level 1 (10 points)
    Don't use the "sharing" url provided by the new iCal. Use the old "publish" url provided my previous iCal versions. For instance, here's the url for my professional calendar:

    http://ical.mac.com/dwmoore/Donald%20W.%20Moore%20CG

    The "dwmoore" is the mobileme userid. The "Donald%20W.%20Moore%20CG" is the calendar name.

    But also pay attention to advice from other posters about sharing the calendar and selecting "Change Location" from the calendar contextual menu. You need to do that too.
  • Perry Lehman Level 1 (15 points)
    Problem solved. This fix you suggested worked perfectly. A little kludgy but it works.
  • kdtanker Level 1 (0 points)
    Hi everyone. Here is my work around which may be similar to what others are doing. Before the upgrade I published my calendar as a group because I have one calendar for home, one for work, etc. So I used to have all of my calendars in a group and it was published (not shared). Now what I've done is created a group under "On My Mac." I've exported each calendar under my xxxxx@me.com section and imported into my group. I've published the group and it can be viewed on the web just like before. From here on out, I will create 2 of the same event each time, one for my mobileme section and one for my "on my mac" group section. A bit of a pain but at least I can still utilize the publish feature. It terms of my iCal view, I simply keep my group unchecked so I don't have to look at 2 of the same event each day. I hope this helps.

    Message was edited by: kdtanker
  • Bill Rising Level 2 (245 points)
    This indeed seemed to work. How it found the proper server is beyond me, since it could not be specified when telling iCal to use the private server. (Probably a preference from earlier.)

    I still ended up downgrading, because floating events all had their times shifted. Even so, it's good to know that there is a possibility for publishing, because I need it for internal web-based calendars.

    Thanks for the tip.
  • Bill Rising Level 2 (245 points)
    Ok, so I'm a dope. Clicking the 'A private server' dropdown brings up servers.

    Still, the tip looks like a good one
  • drumorgan Level 1 (0 points)

    OK, sometimes I have to read things a few times to get what they say. I have been searching all over google to find the answer to this very issue. And, while there are some kludgy fixes suggested here, I think that Alexander Wolff has it exactly right.

     

    Didn't even realize that they have the calendars either shared with my mobileme account or just stored locally. Perfect solution is to create a local calendar and then you can "publish" exactly as you did before.

Previous 1 2 Next