Previous 1 2 3 Next 42 Replies Latest reply: Mar 28, 2014 8:47 AM by timt3 Go to original post
  • 2yu Level 1 (0 points)

    I had the same problem.  Took computer to Apple Store and made appt at Genius Bar.  I needed 14 Apple updates which we uploaded to computer.  While that was going on he checked on possible solutions to the problem and went to iMovie preference list and removed it (the preference list) theorizing it was corrupt.  We then restarted iMovie and the problem was corrected.  I asked him if he thought it was corrected by the updates or by deleting the iMovie preferences.  He thought it was the latter.  He advises caution when working with the iMovie files for fear of deleting your movies, so at the very least back up your computer files first!

  • Reinko Hallenga Level 1 (20 points)

    I have the same issue in a 1-minute clip with stills and audio only. Unfortunately trashing iMovie preferences has not solved it and when I copy Select All to a new project the images change but are still nog in the order of the thumbnails. My software is up to date so I can't update anything.


    Really annoying!

  • Jolly-Mac Level 1 (0 points)

    Lion 10.7.2, iMovie 11 with latest updates.  Seems something is getting corrupted when adding via iPhoto and the thumbnail is correct but what it shows is not.  Lost a couple hours of work and remembered why I do not use the new iMovie - it *****.  I have had nothing but problems since the transition to the new iMovie look and feel.


    Is there anyway to go back to the old iMove that actually worked in Lion?



  • bennynormal Level 1 (0 points)

    This is a horrific bug. I came to this thread hoping someone had a solution rather than a workaround, but I have a workaround which helps, and i don't believe anyone has mentioned it yet. hopefully it helps someone else who, like me, is scratching their head wondering how a major flaw like this has gone on for so long in one of Apple's flagship software applications.


    the workaround:

    I have this problem whenever I use images that have the same file names as images which have been used previously in other iMovie projects. The workaround, which works for me 9 times out of 10, is to rename each image in the finder to something totally unique and then re-add it to the project. Having a new & unique file name for every image before they are added to the project should make them work correctly. Hope that helps.

  • maybeiknow Level 1 (0 points)

    I have had 2 major issues with imovie:

    1. When Creating a project and dragging the pictures into project the pictures come up differently: This happens only to pictures that I have edited previously in iphoto (Cropped, rotated, enhanced).

    Solution 1: Easiest to Open a new project then drag pictures into new project and it seems to work.

    Solution 2: On right...R-click on picture...choose open in Iphoto...Change the picture to Revert to original...The recrop etc...and close...wait 5 seconds for the picture to come in again on the right...then drag to the project. I decided on Solution #1 because I had over 150 pictures I had edited.


    2. Tried finalizing or sharing to qicktime either error...not enought heap room in heap zone or error in use or parameter list...

    Solution trying as we talk: share, export movie, change resolution to Large if want to burn to DVD. Seems 1080 may be the problem....Also make sure you have turned off Time machine or anything that will interrup  the save since (like Sleep mode) it usually takes hours. (I cannot find where to reduce the resolution to finalize) so I shared it instead and hopefully the DVD will work (it has before).


    Hope his helps someone!

  • Daryl DuLong Level 1 (35 points)

    I'm having the exact same issue, which is very frustrating after spending so long laying out the sequence and transitions.  Photos are not working -- exactly as you described -- but video is rendering correctly.


    I have tried opening up the project package and deleting the thumbnails file from within there, as well as deleting any iMovie cache files in ~/Library/Caches and the iMovie preference files in ~/Library/Preferences, and nothing has worked so far.  I have also tried duplicating the project from within iMovie, and that didn't work either.


    Any other suggestions?

  • 2yu Level 1 (0 points)

    take your MAC to the genius bar. They were able to solve the problem for me per my previous post.

  • bennynormal Level 1 (0 points)

    As I posted above, when I rename the source pictures to 100% original file names and then re-add them to the project, they work everytime. I have a project I update every week with new images, and I have to continuously come up with new and unique file names every single time. Usually I do this by simply adding a string of characters to every name such as "111" and then the following week its "222" and so on. You can drag and drop the re-named version of each image right over each affected thumbnail on the project, one at a time, so that you don't lose the work you did as far as the ordering of the images. Hope that helps.

  • Daryl DuLong Level 1 (35 points)

    Hi @bennynormal,


    I appreciate the quick reply.  Just so I'm clear:


    The photos I'm improting into my iMovie project are already named unique names, such as IMG_9074.jpg, IMG_4465.jpg, etc.  Are you saying that you name them something even more unique, to separate them from the names used when they were imported into my iPhoto library?


    Thanks so much.

  • bennynormal Level 1 (0 points)

    Well I don't import from iPhoto, I drag and drop from a folder in the finder, so our experiences are a little different, and i know it seems like those names would be unique, but maybe try dragging just 1 photo out of iPhoto into a folder, change the name to something completely random, and then drop that onto your project and see if that one and only photo is working suddenly. It works for me almost everytime.

  • 8065 Level 1 (0 points)

    My problem is the same with the latest version. I stated a new project but switched between other projects to import stuff into my new one. Then when I tried to import a pic from iPhoto, the pic I want shows in the project line but can be anything from a black page to the wrong pic show up in the playback. Dead frustrating.

  • bennynormal Level 1 (0 points)

    8065: yeah, this is my exact experience as well, so my work-around/solution will probably work for you.


    Daryl: I should have specifically stated above, the names need to be unique with respect to any and all other images that have ever been added to iMovie projects, not iPhoto. So if you added IMG_9074 to iMovie project A, and then later (could be months later even), you tried to add the same image (or another image with the same name) to project B, the image would be affected by the bug. Change the name and re-add it to project B, all is better, but you can't ever use a file with that name in another iMovie project again. I don't use iPhoto though, so i'm not entirely sure how that plays into it.

  • Daryl DuLong Level 1 (35 points)

    I finally had a moment to sit down and try out your tips. Lo and behold, they worked flawlessly! Thank you so much. Yes, it's a pain to have to do this workaround, but it sure beats the frustration of seeing the same images over and over again after exporting the movie.


    I used the "Reveal in Finder" control-click menu to identify which photo was actually placed there, then option-dragged it to a new folder on the desktop.  I renamed all of the images 1-by-1, and dragged them on top of the existing images in the project.  The dialog menu in iMovie allowed me to choose "Replace", minimizing the headache with the transitions that I had created.


    If you have a few minutes, check out the final product:

  • bennynormal Level 1 (0 points)

    I'm really glad to hear that Daryl, and that's really a great video you put together. Now I want sushi!

  • wadzee Level 1 (0 points)

    Keep having this problem. Apple suck at fixing known issues, this one goes back years... Only affects me if I've fiddled with a picture in iphoto before adding them to my imovie projects. my workaround is to open the Finder window, go to Library, Pictures, iphoto library, Originals and drag and drop your original images directly into your project. This way, you should find it works....


    Alternatively, this also works for me...


    Drag the desired photo from your media window (bottom right of imovie screen) to the computer desktop. This creates a copy of the troubled image. Then drag from desktop directly back into your project.