Previous 1 2 3 Next 42 Replies Latest reply: Mar 28, 2014 8:47 AM by timt3 Go to original post
  • SEREPOWMIA Level 1 Level 1 (0 points)

    I know that some fixes only work for some people but I have had multiple problems with pics and iMovie 11.  My work around will probably only work for those who can add pics to one project but not another.  If you have a corrupted project and can't add stills then start a new project with the same settings and add all the photos you want in your other project.  Keep them atleast 1 second long and in the order you want them in your other project for your own convenience.  Make any adjustments here and export the movie at max quality.  Then import the published Picture movie as an event.  You now have all your pics formatted safely as video.  Next scroll through each pic/2 finger click/select: add still to project.  Each still will add to the bottom of your corrupted project and will use far less memory/heap zone erors than ever before.  Publish and enjoy! 


    Hope it works for you!   

  • zabaksmers17 Level 1 Level 1 (0 points)

    Thenk you bennynormal for the workaround! Tried and it helps. Additional tip: if you have to rename too namy pictures, just use some "mass file renaming" tool, such as R-Name.

  • gwilanne Level 1 Level 1 (0 points)

    I am having the same problem.  I tried the renaming of my pictures but it only worked for 2 pictures. I was able to add 2 but then when I added more it went back to displaying a previous picture.  I have been working on this for the several days and recreated it 3 times now.  I am so frustrated and not sure what I can do.  I can't go to a apple store becasue the closest one is 2 hours away.

  • SEREPOWMIA Level 1 Level 1 (0 points)

    gwilanne- Did you try my method?

  • bennynormal Level 1 Level 1 (0 points)

    I'm glad some people are having good results, sorry if its not working for you. I still have consistently working results here and I have to use my workaround weekly with a continuously updating project. good luck!

  • Nappe1 Level 1 Level 1 (0 points)

    It sesams a LOT of people have this problem and it has been there for a long time.

    Does any one know if Apple have any plans To fix it?

  • dinky2 Level 1 Level 1 (10 points)

    Hi all,


    Just ran into this problem today and managed to work around it with minimal effort. Apparently importing straight from iPhoto does not work (why should it ? They are both Apple..) so what I did was copying the images from iPhoto to e.g. Desktop and import them from there by dragging and dropping. All was fine and even the image that showed up wrong before now looks good. So, forget importing from iPhoto and use the workflow via a folder. Pita, but there you go.

  • cmccarville Level 1 Level 1 (0 points)

    I fixed this for several students by deleting the Preference files...Close iMovie, GO to ~/Library/Preferences/ and .lockfile. Re-open imove and edit the project....Worked for all of them so far and easier then renaming a bunch of pics.

  • bgriffis Level 1 Level 1 (0 points)

    I can't believe this issue has been around for years!  I'm a recent Mac convert and was playing around with iMovie for the first time tonight.  Everything was going great until suddenly I could no longer properly add photos!  I tried deleting ~/Library/Preferences/ but it didn't make any difference for me. 


    Apple, please fix this issue!  I don't want to make a bunch of copies elsewhere as a workaround.  I already have over 100GB of photos so I don't want to duplicate things!  What a disappointment.

  • WDC92 Level 1 Level 1 (0 points)

    I found that importing the image into iPhoto, then editing the photo in iPhoto, then dragging from iPhoto to iMovie timeline seems to fix.

  • sabatica Level 2 Level 2 (210 points)



    Sounds like you have two issues.


    First rebuild your iPhoto thumbnail database. Check apple support on how to do this. Easy.


    Second problem delete your iMovie thumbnails forcing them to be recreated for all existing iMovie events.  You can find these thumbnail folders in you ~/movies/iMovie related folders.


    Thirdly relaunch iMovie and your projects should now work. Ta.

  • sngwtr Level 1 Level 1 (0 points)

    I have been trying to figure this out for hours and was dealing with the same issue.

    If you come up with a unique name for the picture and save either to your thumbs or desktop, something totally new and THEN drag it, it should take care of the problem. Worked for me!

  • timt3 Level 1 Level 1 (0 points)

    bennynormal solved my problem, Thanks.

Previous 1 2 3 Next