5 Replies Latest reply: Aug 5, 2012 5:45 PM by ibarnett
jljonathan Level 1 Level 1 (0 points)
My MacPro 2009 2.93 won't sleep anymore. Worked great with no problems until a couple of days ago. Menu command or keyboard shortcut won't make it sleep. Actually, once and a while it does, but if you try again it doesn't. And, if you do get it to sleep that one time, it won't wake from hitting the keyboard (space bar) I spent time with Apple support today and no luck. Now they want me to erase and install the system. Anyone have any ideas? Oh, no bluetooth device here.
Jonathan

Mac Pro 2.93mhz, Mac OS X (10.6.5)
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    This is for a Mac that won't sleep.

    Here is Apple's KB article HT1776 with their tips.

    Mine follow;

    USB devices and hubs often cause Macs to not sleep or wake quickly from sleep (notably HP printers and scanners, HP all in ones, and Cannon scanners). Disconnect all USB except for keyboard and mouse and try. If it sleeps, add one back at a time testing after each one to find the culprit.

    If you've set your Mac to receive faxes, it may not be able to sleep. It might also have a damaged preferences file.
    If you use your Mac for faxing, open System Preferences. click Print & Fax, click the Faxing tab, and uncheck the Receive Faxes On This Computer box.

    If that doesn't work or you've never faxed on your Mac, go to Finder/Hard Drive /Library/Preferences/SystemConfiguration and delete the com.apple.PowerManagement.plist and com..apple.AutoWake.plist files (if your Mac asks, type your admin. password).
    If the latter file isn't present in the folder, go to user name(probably your name)/Library/Preferences, delete the com.apple.systemuiserver.plist file, and reboot your Mac.

    USER TIPS……..

    Check in System Preferences > Energy Saver is "Wake for network access" checked? If so, uncheck it.

    One user reported, " I couldn't make my macbook pro to go to sleep because I had my wireless headphone receiver still plugged in. I unplugged it and then it went to sleep."

    Also, if you have an External Western Digital (WD) hard drive and have installed
    WDDMService and WDSmartWareD on your Mac, it may not sleep. Fix is to un-install those....you don't need them to use the drive.

    "I have had this problem with my IMac G5. It is surprisingly irritating. LaCie's Silverkeeper backup software was the cause. By default it gave itself permission to wake up the computer to check if a backup was needed. Do you have this or a similar program installed which has scheduled activities including wake-up permissions as an option?"

    One provided this link, xlr8yourmac.com, to a member, which addresses failure of deep sleep with some users that updated and added new FireWire and USB card.

    Also, here is Apple KB article TA2469 about PCI cards and sleep.

    After few days of messing around I found out that I had desktop background (wallpaper) set to change every 1 minute.
    After unchecking "Change picture..." in system preferences (under Desktop/Screen saver), my powerbook went to sleep all by itself.

    "I have a Canon printer(shared) and my imac would not sleep. I opened up printer/fax in system prefs and noticed it said the printer was in use when it was off. Opened up the printer queue and noticed about 7 pending documents. Deleted them all and now it sleeps.
    Check the printer queue!"

    One user has had success, after trying all these tips, using an App. called PleaseSleep. I've never used it though.

    Good Luck!  DALE
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    More, some repeated......

    A number of sleep-related issues can appear after incremental Mac OSX updates, including the inability to properly go to sleep, problems waking from sleep, and having your display go to sleep without your Mac going to sleep. The most common culprit is Bluetooth. Try these tips to fix your sleep problems.
    WAKE UP
    In System Preferences>Bluetooth, uncheck Allow Bluetooth Devices To Wake This Computer. If you are using a Bluetooth mouse and keyboard, you'll have to wake your Mac by pressing the power button.
    FILE CORRUPTION
    Your Bluetooth preference file may be corrupt-you'll need to delete it. Turn Bluetooth off, then go to the /Users/user name/Library/Preferences folder. Look for a file called com.apple.Bluetooth.plist and trash it.The OS will create a new preference file when you enable Bluetooth again.
    ENERGY SAVER
    If you have issues with a Mac or display that goes to sleep at inappropriate times, you may have a problem with Energy Saver. Delete the following .plist files and restart:
    -/Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist
    -/Users/username/Library/Preferences/com.apple.systemuiserver.plist--
    (username is your name or System Administrators name)
    -/Library/Preferences/SystemConfiguration/com.apple.AutoWake.plist
    A restart is very important after deleting these plists. After a reboot your Mac will then generate new ones.
    Some, in these forums, have had luck fixing sleep issues downloading the Combo update from this site (yours may be corrupt), not Software Update, disconnect all firewire + USB devices except keyboard + mouse, Repair Permissions, re-install update, Repair Permissions again + try.

    Here's the 10.6.5 Combo update.

     

    DALE

     

  • Mark Delgrosso Level 1 Level 1 (5 points)
    Mine goes to sleep if I close iTunes. You could try that.
  • murray98 Level 1 Level 1 (0 points)
    Just want to say I had the same problem and trashing Bluetooth preferences did the trick. Thanks!
  • ibarnett Level 1 Level 1 (0 points)

    Hi, after finding the same problem, finally fixed mine.

    I had a UPS monitor plugged into my Mac Pro's USB port, removing it fixed the problem, sleeps well now.