5 Replies Latest reply: Aug 15, 2014 8:58 PM by rmcvicker
NAParish Level 1 Level 1 (0 points)
Ever since I upgraded to iTunes 10.x, my iTunes library keeps getting corrupted, about every 2nd or 3rd time I start the program. I keep having to rebuild the file, import the playlists, the music, the apps, podcast subscriptions, etc., and then it'll crash again -- with an error message saying that the file didn't seem to be a valid libary file.

I've tried it both with and without deleting the .xml file and starting all over, and had the same problem.

Any ideas on what is going on? It's really frustrating! I keep having to completely re-sync my iPhone and iPod, among other problems.

(BTW -- I've posed the same question as part of a thread somebody else created at http://discussions.apple.com/message.jspa?messageID=12706561 , but nobody has responded to that thread)

Message was edited by: NAParish

Windows XP
  • b noir Level 9 Level 9 (72,020 points)
    By any chance do you have an optimisation utility like UniBlue's SpeedUpMyPC installed on that PC? Every now and then, scans and tweaks by those sorts of utilities can cause these sorts of problems.
  • NAParish Level 1 Level 1 (0 points)
    Nope. I don't have anything like that.
  • n13l5 Level 1 Level 1 (5 points)
    check if your itunes library files somehow got set to read-only, or if XP somehow keeps locking the files. iTunes will call a locked database "corrupt".

    A sign for the possibility of an erroneous "corrupt" database would be if it tries to repair and pretty much instantly generates another error, saying it can't repair it for some reason or another.

    First, I'd run a low level disk check (maybe SpinRite) defrag the drive.
    Then I'd download the (free) really useful Systernals Suite from Microsoft, and start monitoring file access before starting up iTunes.

    If any errors accessing the .itl file show up, that should hopefully point you to the culprit.

    This may seem laborious, but its not so bad, and given that you pretty much need iTunes running to be able to use your pods, phones etc, it seems worth the effort.

    A simpler way to test where the issue lies / get it running, would be to create a new Windows user account and install iTunes on that. Copy the itunes library files over to the "My Music" folder of the NEW windows user account and see if iTunes stops calling the library corrupt. If it does, then you know there's something wrong in your other windows user account. Either some setting is wrong, or a piece of software installed that interferes with iTunes, or else, the user account got corrupted. In the last case, you should just copy over all your documents to your newly created user account and once you're sure you got everything, delete/disable the old user account.
  • NAParish Level 1 Level 1 (0 points)
    Thx, nt315. I only just now realized that you'd responded to my question -- mainly because iTunes had been working fine, and I had assumed that the newest version solved my problem, until it crashed again a few minutes ago. In response to your suggestions:

    The library files aren't set as read-only, and I don't think they're locked -- and iTunes doesn't generate the error you sugest.

    I haven't run a diskcheck yet. The Sysinternals Suite is very powerful -- but I am not sure what I'm looking for. Were you thinking of the Process Monitor?
  • rmcvicker Level 1 Level 1 (0 points)

    I've had the same issue on my iMac ever since updating to Mavericks. Before I saw all these posts I was inclined to blame the OS upgrade but since it is happening on Windows and Macs it has to be an iTunes bug. I'm not running any system scanning or virus protection programs like many of you are so it isn't an issue of another program corrupting the databases. I've spent over an hour on the phone with Apple tech support and they were never able to find a solution to keep it from happening. All they suggested was re-installing the OS on a completely wiped drive.