1 Reply Latest reply: Dec 16, 2010 10:18 AM by r_dizzle
r_dizzle Level 1 Level 1 (5 points)
Hi everyone,

I have frequent problems with beachballing when using itunes in the latest OS X. This has plagued me since I converted to iTunes/Mac for 2 years.

Anyway, I have done every possible solution on the web and these forums, and the only thing left is for me to turn OFF Genius.

I have seen a couple posts saying this is done within the itunes Store or the STORE menu in the title bar, but I can't do this.

"turn off genius" is greyed out in the menu and there is nowhere (that I can tell), in the itunes store environment to do this.

if any of you can help me with detailed instructions, that would be a big help

Thanks!

24" iMac 3.06 GHz Core 2 Duo, 4GB RAM, Mac OS X (10.6.4), iPhone4 32GB, iPad 32GB 3G, MobileMe
  • r_dizzle Level 1 Level 1 (5 points)
    Wow, I guess I didn't try every option, restarted and clicked on genius in the left bar, and the TURN IT OFF item was now available in the STORE menu

    ignore...

    just one of those days:)
    happy holidays