10 Replies Latest reply: Jun 22, 2013 8:50 AM by wintersgrass
xaruqui Level 1 Level 1 (0 points)
Hi! I don't know If I have to write this post in this category, well, let's try it. I bought a Riello UPS, downloaded lastest soft from official website (10.5) and Installed it, but doesn't recognize my UPS. Software doesn't run in background (I checked it in System Monitor).

I connect it with USB directly to my iMac, I tried 2 different cables, but nothing happens. When I start manually UPSView it can't find the UPS.

I surfed the web looking for some info, but I found nothing. A workmate bought the same UPS, he's running 10.6 and neither worked.

There aren't Riello Forums and support is only for resellers... I don't know what to do!! Any idea of whats happening??

iMac24" & MacMini & MBP 13'3 & iPhone 4, Mac OS X (10.6.1)
  • Kappy Level 10 Level 10 (255,870 points)
    Either contact the manufacturer's or vendor's tech support. Their software is apparently not compatible. Consider returning it and buying an APC device instead.
  • Pondini Level 8 Level 8 (38,720 points)
    See what the maker's instructions say.

    You may not need their software at all -- OSX has UPS support built in, at least for those UPS systems that behave normally.

    Try uninstalling it -- some UPS software (APC's for example), actually prevents OSX from handling a power failure properly (on Leopard or later).

    See [Using a U.P.S. System with a Mac|http://web.me.com/pondini/AppleTips/UPS.html].

    It may not matter, but what version of OSX are you running? This is the Leopard forum, and you say you've downloaded software for Leopard, but your signature says you're running Snow Leopard.
  • xaruqui Level 1 Level 1 (0 points)
    Pondini, That's awesome! BUT, Leopard doesn't support this UPS...

    About the OS, I'm sorry about that. I'm running 10.5 in my iMac, 10.6 in my MBP (that's why).

    Well, I read Pondini's link and I decided to uninstall UPS software from install package, the first window opening that package was:

    +The UPSMON software package is a client-/server-application for networks and local workstations and which is used for monitoring UPS. The server-module of the UPSMON Software is the Upsagent, which communicates via USB or via TCP/IP network cable with the UPS. After start of the Upsagent it collects as a background program the messages send from the UPS. The Upsagent interprets received messages and makes them available to the client-module, the Upsview program. The transport of the data to the Upsview can be done via TCP/IP or via shared memory on local computer.+
    +If the Upsagent detects voltage variations or a powerloss it can execute different command scripts, which for example may shutdown the server or send warnings to the connected users. These scripts which are a part of the UPSMON can be adjusted to your demands.+
    +When a change in the alarm-status takes place, there is a corresponding file (i.e.+
    +shell script/command file) that will be executed when activating or deactivating+
    +alarms. When a alarm status remains too long, the user can customize the system+
    +to shutdown.+
    +The customer can also shutdown the UPS to save autonomy time, which allows the system to gracefully shutdown itself in case of a repeating alarm situation.+

    So, after reading this I understand less than before. It seems that USB is supported!! I wish you could buy Riello stuff, so this forums would be plenty of posts like mine!
  • Pondini Level 8 Level 8 (38,720 points)
    xaruqui wrote:
    Pondini, That's awesome! BUT, Leopard doesn't support this UPS...


    How do you know that?

    You can tell if OSX recognizes the UPS, via +System Profiler.+ Click the Apple logo at the left of your menubar, select +About This Mac,+ then +More Info.+

    Click USB in the sidebar, and look in the center to see if your UPS is listed. If it is, and the software that came with it isn't working, uninstall it, and Restart your Mac. OSX may work with it.

    So, after reading this I understand less than before. It seems that USB is supported!!


    Yes, a USB link is supported, but that doesn't say the software will work with Leopard.
  • xaruqui Level 1 Level 1 (0 points)
    Actually, I already tried this before opening the thread and it doesn't appear anywhere. This software is supported by Leopard as well, you can check it in their site:

    http://www.riello-ups.com/?en/support/downloads.p3

    I also installed this software in my MBP (10.6 version) with no success. I always have bad experiences on Java platform...
  • Pondini Level 8 Level 8 (38,720 points)
    xaruqui wrote:
    Actually, I already tried this before opening the thread and it doesn't appear anywhere.


    Then there must be a problem with the UPS, the USB cable, or the port on your Mac.

    Try different USB cables, ports, and combinations of the two (a plug that works fine in one port may not quite make contact in another).

    If it's still unrecognized, exchange or return it.
  • xaruqui Level 1 Level 1 (0 points)
    I tried two different cables and a couple of different ports as well, what I didn't try is a combination of both.

    Definitively, I'll contact my vendor. For sure it's heavy enough to break some bones if well throwed.

    Thanks a lot.
  • Pondini Level 8 Level 8 (38,720 points)
    xaruqui wrote:
    . . .
    For sure it's heavy enough to break some bones if well throwed.


    Probably not the best approach

    Thanks a lot.


    You're quite welcome. Keep us posted.
  • PeterLboro Level 1 Level 1 (10 points)
    I had similar problems with a Riello iPlug 800VA and UPSMON 5.1.0 for Mac OS X 10.6. I installed the software but it couldn't see the UPS from my iMac using a USB port that had worked fine with a previous APC UPS.

    I got it working in the end by uninstalling/deleting my previous attempts and reinstalling whilst logged into an admin account. My "mistake" was installing the software initially in my standard account and then trying to reinstall over this in my admin account. Even though it was reported as a successful installation on both occasions, clearly it wasn't as it didn't work!

    A significant stupidity of the UPSMON software is the need to input a "PRTK code" during installation. There is no warning about this and the suggestion of where to find this code on the UPS and/or its box is WRONG. It is NOT on the UPS nor its box and it is not any of the 3 numbers that can be found on both! Nor is it anywhere obvious on the Riello web site. Only if you jump to the Mac pages in the 83 page manual (a separate download to the software), will you find what is needed, i.e the PRTK code "GPSER11201RU" (for the Riello iPlug series)! Who the heck scrolls through a separately downloaded manual before running a standard Mac installer to find a critical install code you're not warned about?!

    When installed UPSMON provides 3 programs: "Ups Wizard", "Upsetup" and "Upsview". However, NONE of these can be used in a standard account, only in an admin account. In fact if you "Show Package Contents" for any of these, then change the permissions for the Contents folder (and its contents) from "No Access" to "Read Only", you can use these from a standard account. Upsview is particularly important as it is the only way of seeing the status of your UPS since the Riello and UPSMON do not provide any support for the Energy Saver panel (unlike APC).

    I now have Upsview working from my standard account and I can check that the UPS is functioning correctly. However, if I want to change any of the UPS parameters, I have to run "Ups Wizard" or the very opaque "Upsetup" and then, by unspecified means, restart the UPS agent, i.e. do a system restart!

    So it works, but the process is FAR WORSE than it should be and compares poorly with APC's Mac support. I just hope the Riello UPS proves to be as good or better than the APC UPS I've just replaced!

    Regards

    Peter
  • wintersgrass Level 1 Level 1 (0 points)

    Thanks for this. Had the same problems trying to get this working on OSX 10.8. This worked perfectly. Software needs to be installed as root but nowhere does the manual mention this.

     

    Thanks,

    Rob