11 Replies Latest reply: Dec 29, 2010 1:20 PM by Robert Paris
Robert Paris Level 1 Level 1 (145 points)
I have a WiFi-3G iPad. I am running iOS 4.2.1... As of yet, I have never turned on the 3G. As an example of the time setting problem I am having, I start out and go into General settings and then "Date & Time". I first set the "Set Automatically" button to OFF. I am hearing that the WiFi only iPads don't have this button. But maybe someone else can confirm that... I then set the "Time Zone" to say Cupertino (I am in Northern Ca). Or San Francisco... I've tried both... I then go into "Set Date & Time" and I set the time manually to whatever the current time might be... Say, for example, it's 6:00 PM... I set it there.. The time goes to that value... So far so good... Then, here comes the problem, I set the "Set Automatically" button to ON... The time instantly resets to 8:02 PM... Yep, two hours and two minutes off (later)... Always... Two hours and two minutes fast...

Is this a bug?? a known bug??? If so, does anyone know if Apple is aware of this or not??? Any idea of how to fix it??? Thoughts???

thanks... bob...

Two 17 inch MacBook Pros and a FW800 G4 dual 1.25 Ghz, Mac OS X (10.6.5)
  • Carolyn Samit Level 10 Level 10 (100,205 points)
    Hi Robert,

    I set the "Set Automatically" button to ON..


    I am able to set mine behind or ahead of Cupertino time (which I use most of the time) but I don't see the "Set Automatically" button to ON" you are referring to ????













    Carolyn
  • David M Brewer Level 6 Level 6 (9,300 points)
    I think the 3G model has set auto for setting the time.
  • Carolyn Samit Level 10 Level 10 (100,205 points)
    I see it now. Thanks David.

    I bet you know this one. If you set to Automatic, wouldn't that reset to default time ?? So maybe cellular picks up the time automatically... I hadn't thought of this before.






  • Robert Paris Level 1 Level 1 (145 points)
    I don't know what you mean by "default time"????

    Recall that I said it was two hours and two minutes off... There are probably more clues in the "two minute" part... That says that something is telling the iPad the WRONG time... It's not just a matter of being a couple of time zones off... In addition, something is feeding it the WRONG time... And if the time is coming from cell towers, I wonder if it matters that I don't have my 3G coverage turned on and never have had it turned on...

    Again, does anyone know if this is a known bug??? Known to Apple??? thanks... bob...
  • David M Brewer Level 6 Level 6 (9,300 points)
    I believe the set audio get's it time info from the cell towers that surrounds your location. So I it take it that if you move from time zone to time zone the iPads time should reflex that time zone change automatically.
  • Carolyn Samit Level 10 Level 10 (100,205 points)
    Hi Robert,

    By default I meant it would revert to the current time no matter what you set it for.

    You can provide feedback to Apple here.






  • Carolyn Samit Level 10 Level 10 (100,205 points)
  • FroggyG Level 1 Level 1 (0 points)
    I have nearly an identical problem on my ipad; except that when I turn on "Set Automatically", the clock jumps ahead 3 minutes from the "correct time" that I set manually. In my case, it's not a fatal flaw, but certainly an annoying bug that should be fixed.
    I reported the problem as a bug to Apple as suggested by another poster.
  • David M Brewer Level 6 Level 6 (9,300 points)
    The Emeral Time app will tell how much your clock on the iPad is off.
    http://itunes.apple.com/us/app/emerald-time/id290384375?mt=8
  • rc137 Level 1 Level 1 (0 points)
    Mine works just fine. I tried resetting time zone to Cupertino, USA and then set time both couple hours ahead and then couple hours in the past. Then turn "Set Automatically" back on and both times it reverted to the correct time.

    Since you don't have a 3G connection (since you didn't sign-up or turn it on), is your WiFi turned on and are/were at a location that has WiFi and your iPad is "connected"? I bet it's not connected to anything and thinks you are in a different time zone. If your iPad had a 3G or WiFi connection, it should get all the time info.

    If that is not the problem, try turning your iPad off and then back on or reinstall the OS. If that doesn't work, call Apple/Apple Store.
  • Robert Paris Level 1 Level 1 (145 points)
    I just looked at mine again... I am running on my home WiFi as I almost always do... But my guess is that the iPad is NOT set up to search for time servers when running as WiFi... I say that because folks who have WiFi only iPads don't even have a "set automatically" button for time... So when I am running on WiFi and with the "set automatically" button set to OFF I don't think I have any choice but to set time manually... Contrast that with my macbook pro that is ALSO running on my WiFi network but it DOES have a preference that allows one to set time automatically using your WiFi connection through to Apple time servers in various locations...

    When I just now looked at my iPad today after having set time manually say about a week ago and with "set automatically" still set to OFF, the iPad was reporting 1:05 PM while my time synced macbookpro was reporting 1:04 PM... So over a week my iPad was off a part of a minute (so far so good)... Then, I set the "set automatically" switch to ON and the time instantly moved forward to 3:07 PM, in other words mine still has the same problem... When I click that switch to ON, my iPad ALWAYS moves forward an errant 2 hours and 2 minutes... It's just broken, pure and simple...

    By the way, I had a different but apparently cellular related problem with my iPad last week... See that posted here,

    http://discussions.apple.com/message.jspa?messageID=12807110#12807110

    The solution to that problem was discovered by other users to be to toggle the Cellular Data switch from OFF (where mine always sits) to ON and then after a few seconds right back to OFF... I tried that and sure enough, that FIXED that issue!!!??? So the cellular end of the iPad appears to have a few bugs and I am confident my issue with setting time automatically apparently using cell tower information is yet another bug...

    I, too, sent feedback to Apple a week or so ago as I'm confident this is some sort of a bug...

    Any other feedback??? thanks... bob...