10 Replies Latest reply: May 11, 2011 8:59 AM by TanqueVerde
Norm Shea Level 1 Level 1 (75 points)
I have been using Davis Weather's WeatherLink 5.0.4 software to access my weather station for years. Back in November, I began having a problem where the software would crash every time I tried booting it. I upgraded to 5.1.0 which solved the booting but caused another problem.

Here is the post I sent to Davis support,
+"I went to download my data recently and WeatherLink would not launch. I’m using version 5.0.4 on a Vantage PRO wired console. I get an Mac OS system error saying the software did not launch, do I want to Ignore, Report or Relaunch. I did an update to 5.1.0 hoping that would solve the problem. WeatherLink does begin to launch now but a software error message has begun to appear. It says, “java.lang.UnsatisfiedLinkError: /Applications/Mac OSX WeatherLink/libjspMacOSX.jnilib: no suitable image found. Did find: / Applications/Mac OSX WeatherLink/libjspMacOS.jnilib: no matching architecture in universal wrapper” with an OK button. When I click OK, the software shuts down."+

Their suggested fix is below:
+"Let's try opening the application in 32 bit.+
+> Try setting the weatherlink.app to run in 32 bit mode. To do so:+
+> Open the Macintosh Hard drive folder. Open the Applications folder. Select the MAC OSX Weatherlink folder.+
+> Click on the weatherlink.app. Go to the top of the screen and select+
+> File & Get Info. See if there is a check in the box for: Open in 32-bit mode.+
+> Launch the weatherlink application and see if it opens successfully."+

That didn't help.

The last successful launching of the software was in September when I downloaded the data from the weather station. So, I've gone back into Time Capsule and replaced the WeatherLink folder in Applications from a late August copy. I'm now back to the crashing on launch. Below is the crash report:

Process: JavaApplicationStub [422]
Path: /Applications/Mac OSX WeatherLink/WeatherLink.app/Contents/MacOS/WeatherLink
Identifier: JavaApplicationStub
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [149]

Interval Since Last Report: 406783 sec
Crashes Since Last Report: 13
Per-App Interval Since Last Report: 0 sec
Per-App Crashes Since Last Report: 12

Date/Time: 2010-12-19 15:00:29.169 -0500
OS Version: Mac OS X 10.5.8 (9L30)
Report Version: 6
Anonymous UUID: C755B105-0FD2-4ED0-ADBA-EAC2F67311CB

Exception Codes: KERNPROTECTIONFAILURE at 0x0000000000000000
Crashed Thread: 0

Thread 0 Crashed:
0 com.apple.CoreFoundation 0x97d81b5b CFDictionaryGetValue + 43
1 ...ple.JavaApplicationLauncher 0x00012b95 ChooseJVMForVersionAndProperties + 107
2 ...ple.JavaApplicationLauncher 0x00015020 startAppFromPropertiesList + 226
3 ...ple.JavaApplicationLauncher 0x0001589d MRJApplicationMainArgs + 69
4 JavaApplicationStub 0x00001db8 0x1000 + 3512
5 JavaApplicationStub 0x00001cac 0x1000 + 3244
6 JavaApplicationStub 0x00001bd9 0x1000 + 3033

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0xa09444ec ebx: 0x97d81b3e ecx: 0xbfffec44 edx: 0x00000010
edi: 0x001138c0 esi: 0x00000000 ebp: 0xbfffec68 esp: 0xbfffec50
ss: 0x0000001f efl: 0x00010283 eip: 0x97d81b5b cs: 0x00000017
ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
cr2: 0x00000000

Binary Images:
0x1000 - 0x1fff JavaApplicationStub ??? (???) <eabed525027f4c87682a5c9988efa62f> /System/Library/Frameworks/JavaVM.framework/Resources/MacOS/JavaApplicationStub
0x12000 - 0x1bffd com.apple.JavaApplicationLauncher 12.7.0 (12.7.0) <c62bd7dc84e3017c9d6f174481e1e8ea> /System/Library/PrivateFrameworks/JavaApplicationLauncher.framework/Versions/A/ JavaApplicationLauncher
0x24000 - 0x2cffe com.apple.JavaVM 12.7.0 (12.7.0) <d9cf554378c7cafa431ea651c476fb80> /System/Library/Frameworks/JavaVM.framework/Versions/A/JavaVM
0x8fe00000 - 0x8fe2db43 dyld 97.1 (???) <458eed38a009e5658a79579e7bc26603> /usr/lib/dyld
0x90003000 - 0x90090ff7 com.apple.framework.IOKit 1.5.2 (???) <7a3cc24f78f93931731203854ae0d891> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x900e3000 - 0x90140ffb libstdc++.6.dylib ??? (???) <04b812dcec670daa8b7d2852ab14be60> /usr/lib/libstdc++.6.dylib
0x90146000 - 0x90146ffa com.apple.CoreServices 32 (32) <2fcc8f3bd5bbfc000b476cad8e6a3dd2> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x90988000 - 0x909a7ffa libJPEG.dylib ??? (???) <d23f3f3b9d168bf32f89449f83fa07f7> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ImageIO.framework/Versions/A/Resources/libJPEG.dylib
0x90ad0000 - 0x90e8efea libLAPACK.dylib ??? (???) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libLAPACK.dylib
0x90fa4000 - 0x90fedfef com.apple.Metadata 10.5.8 (398.26) <e4d268ea45379200f03cdc7c8bedae6f> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadat a.framework/Versions/A/Metadata
0x90fee000 - 0x91019fe7 libauto.dylib ??? (???) <42d8422dc23a18071869fdf7b5d8fab5> /usr/lib/libauto.dylib
0x9101a000 - 0x9101aff8 com.apple.ApplicationServices 34 (34) <8f910fa65f01d401ad8d04cc933cf887> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services
0x910df000 - 0x910e3fff libGIF.dylib ??? (???) <36f7b0255a81d97c7b360c3b11b4e462> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ImageIO.framework/Versions/A/Resources/libGIF.dylib
0x910ec000 - 0x910f0fff libmathCommon.A.dylib ??? (???) /usr/lib/system/libmathCommon.A.dylib
0x910f1000 - 0x910f9fff com.apple.DiskArbitration 2.2.1 (2.2.1) <75b0c8d8940a8a27816961dddcac8e0f> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x9125e000 - 0x9166efef libBLAS.dylib ??? (???) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libBLAS.dylib
0x9166f000 - 0x91685fff com.apple.DictionaryServices 1.0.0 (1.0.0) <ad0aa0252e3323d182e17f50defe56fc> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Diction aryServices.framework/Versions/A/DictionaryServices
0x917f8000 - 0x918b3fe3 com.apple.CoreServices.OSServices 228.1 (228.1) <76fdc146b4d9937f9c5cbaa1512e0023> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Versions/A/OSServices
0x918b5000 - 0x91980fef com.apple.ColorSync 4.5.3 (4.5.3) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ColorSync.framework/Versions/A/ColorSync
0x91981000 - 0x91983ff5 libRadiance.dylib ??? (???) <276f13ab6429e05b093a8dda251e3b53> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ImageIO.framework/Versions/A/Resources/libRadiance.dylib
0x919dd000 - 0x91a8dfff edu.mit.Kerberos 6.0.14 (6.0.14) <673f107cdae80c084774a27bc7bc46c1> /System/Library/Frameworks/Kerberos.framework/Versions/A/Kerberos
0x91a8e000 - 0x91b15ff7 libsqlite3.0.dylib ??? (???) <3334ea5af7a911637413334154bb4100> /usr/lib/libsqlite3.0.dylib
0x91b16000 - 0x91b34fff libresolv.9.dylib ??? (???) <a8018c42930596593ddf27f7c20fe7af> /usr/lib/libresolv.9.dylib
0x91b35000 - 0x91c7dff7 com.apple.ImageIO.framework 2.0.7 (2.0.7) <acf821a3c418fdc86ef02b654366f5f6> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ImageIO.framework/Versions/A/ImageIO
0x91cc0000 - 0x91cd0fff com.apple.speech.synthesis.framework 3.7.1 (3.7.1) <06d8fc0307314f8ffc16f206ad3dbf44> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ SpeechSynthesis.framework/Versions/A/SpeechSynthesis
0x91d20000 - 0x91dadff7 com.apple.LaunchServices 292 (292) <a41286c7c1eb20ffd5cc796f791070f0> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchS ervices.framework/Versions/A/LaunchServices
0x91dc1000 - 0x91efaff7 libicucore.A.dylib ??? (???) <f2819243b278259b9a622ea111ea5fd6> /usr/lib/libicucore.A.dylib
0x91fd1000 - 0x922abff3 com.apple.CoreServices.CarbonCore 786.16 (786.16) <60b518e4ad02b91826240199a6311286> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonC ore.framework/Versions/A/CarbonCore
0x922f3000 - 0x9232afff com.apple.SystemConfiguration 1.9.2 (1.9.2) <8b26ebf26a009a098484f1ed01ec499c> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration
0x92355000 - 0x92384fe3 com.apple.AE 402.3 (402.3) <b13bfda0ad9314922ee37c0d018d7de9> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.fram ework/Versions/A/AE
0x92385000 - 0x92601fe7 com.apple.Foundation 6.5.9 (677.26) <c68b3cff7864959becfc7fd1a384f925> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x92696000 - 0x9273dfeb com.apple.QD 3.11.57 (???) <35f058678972d42b88ebdf652df79956> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ QD.framework/Versions/A/QD
0x92b5b000 - 0x92b84fff libcups.2.dylib ??? (???) <2b0ab6b9fa1957ee940835d0cfd42894> /usr/lib/libcups.2.dylib
0x92be2000 - 0x92bf0ffd libz.1.dylib ??? (???) <5ddd8539ae2ebfd8e7cc1c57525385c7> /usr/lib/libz.1.dylib
0x92bf1000 - 0x92d58ff3 libSystem.B.dylib ??? (???) <c8f52e158bf540cc000146ca8a705958> /usr/lib/libSystem.B.dylib
0x92d59000 - 0x92d69ffc com.apple.LangAnalysis 1.6.5 (1.6.5) <d057feb38163121ffd871c564c692804> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ LangAnalysis.framework/Versions/A/LangAnalysis
0x9366c000 - 0x936ffff3 com.apple.ApplicationServices.ATS 3.8 (???) <e61b0945da6ab368348a927f7428ad67> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ATS.framework/Versions/A/ATS
0x9383b000 - 0x938e2fec com.apple.CFNetwork 438.16 (438.16) <dbf00ca36a09edfae60ec44f9d7a9ef9> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwo rk.framework/Versions/A/CFNetwork
0x94462000 - 0x9447dff3 libPng.dylib ??? (???) <c0791798fb92acc136c250a373449359> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ImageIO.framework/Versions/A/Resources/libPng.dylib
0x9447e000 - 0x944fbfef libvMisc.dylib ??? (???) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libvMisc.dylib
0x948b6000 - 0x9497dff2 com.apple.vImage 3.0 (3.0) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.fr amework/Versions/A/vImage
0x95910000 - 0x9598fff5 com.apple.SearchKit 1.2.2 (1.2.2) <3b5f3ab6a363a4d8a2bbbf74213ab0e5> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchK it.framework/Versions/A/SearchKit
0x95b20000 - 0x95b27fe9 libgcc_s.1.dylib ??? (???) <f53c808e87d1184c0f9df63aef53ce0b> /usr/lib/libgcc_s.1.dylib
0x95b65000 - 0x95bdfff8 com.apple.print.framework.PrintCore 5.5.4 (245.6) <03d0585059c20cb0bde5e000438c49e1> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ PrintCore.framework/Versions/A/PrintCore
0x95be0000 - 0x95db1ff3 com.apple.security 5.0.6 (37592) <0b25e1e4cc34431630f01edb3fdf54d1> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x95db2000 - 0x96452fef com.apple.CoreGraphics 1.409.7 (???) <7b65edcce394f39b6a1954d5e30bc34c> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreGraphics.framework/Versions/A/CoreGraphics
0x964c2000 - 0x964e6fff libxslt.1.dylib ??? (???) <0a9778d6368ae668826f446878deb99b> /usr/lib/libxslt.1.dylib
0x96607000 - 0x96661ff7 com.apple.CoreText 2.0.5 (???) <5483518a613464d043455ac661a9dcbe> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreText.framework/Versions/A/CoreText
0x96a2a000 - 0x96b0afff libobjc.A.dylib ??? (???) <7b92613fdf804fd9a0a3733a0674c30b> /usr/lib/libobjc.A.dylib
0x96b0b000 - 0x96b4afef libTIFF.dylib ??? (???) <a5991d757f0c17a9bb8b1bcb14ab9ec0> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ImageIO.framework/Versions/A/Resources/libTIFF.dylib
0x96bb2000 - 0x96bdffeb libvDSP.dylib ??? (???) <b232c018ddd040ec4e2c2af632dd497f> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libvDSP.dylib
0x96be0000 - 0x96cc1ff7 libxml2.2.dylib ??? (???) <b3bc0b280c36aa17ac477b4da56cd038> /usr/lib/libxml2.2.dylib
0x96cc2000 - 0x96d74ffb libcrypto.0.9.7.dylib ??? (???) <d02f7e5b8a68813bb7a77f5edb34ff9d> /usr/lib/libcrypto.0.9.7.dylib
0x9772c000 - 0x9772cffd com.apple.Accelerate.vecLib 3.4.2 (vecLib 3.4.2) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/vecLib
0x97764000 - 0x9776bffe libbsm.dylib ??? (???) <d25c63378a5029648ffd4b4669be31bf> /usr/lib/libbsm.dylib
0x97ce6000 - 0x97d37ff7 com.apple.HIServices 1.7.1 (???) <ba7fd0ede540a0da08db027f87efbd60> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ HIServices.framework/Versions/A/HIServices
0x97d38000 - 0x97d38ffd com.apple.Accelerate 1.4.2 (Accelerate 1.4.2) /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
0x97d3c000 - 0x97e6ffe7 com.apple.CoreFoundation 6.5.7 (476.19) <a332c8f45529ee26d2e9c36d0c723bad> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0xfffe8000 - 0xfffebfff libobjc.A.dylib ??? (???) /usr/lib/libobjc.A.dylib
0xffff0000 - 0xffff1780 libSystem.B.dylib ??? (???) /usr/lib/libSystem.B.dylib

Does anybody have any ideas? I've been monkeying around for over a month now and, if I can't access the weather station soon, data will start getting overwritten. I'd appreciate any insights anyone might have.


MacPro 3 GHz Dual-Core / MacBook 13-inch Aluminum (Late 2008), Mac OS X (10.5.8)
  • Ralph Johns (UK) Level 9 Level 9 (70,115 points)

    I do not have a direct answer.

    However you do not say which of the two macs you list in your Specs that app is running on.

    You also list 10.5.8
    I thought the 32/64 bit switch only applied to Snow Leopard (10.6.x)
    I could be corrected on this as I only have a MacBook Pro version one which is not Core Duo and cannot do this (Even if I had a Leopard boot handy)

    This bit:-

    ... It says, “java.lang.UnsatisfiedLinkError: /Applications/Mac OSX WeatherLink/libjspMacOSX.jnilib: no suitable image found.

    Did find: / Applications/Mac OSX WeatherLink/libjspMacOS.jnilib: ...

    would normally mean that the launch process had not found one item but had found something that was close. (most often caused by an update installing something either in a different place or changing something about the item)

    Yours appear to have exactly the same name for the file in question.
    You can normally View these if you Right Click the Apps and use Show Package Contents then navigate to the folder the item is in.
    However in this case there is no Contents folder listed in that path.

    It seems it wants to invoke Java.

    At this point I would ask if you have Updated Java since September ?
    On my 10.5.8 Computer I seem to have one listed in Software Update's List on the 21/10/2010 (Oct 23rd British Date Format on my computer).
    (I looked in System Preferences > Software Update > Installed Updates tab)

    Hopefully this my provide you with some clues or enough to post back with more info.

    9:40 PM Sunday; December 19, 2010
  • Norm Shea Level 1 Level 1 (75 points)

    Sorry, it is the MacPro 3GHz Dual-Core and I am still on 10.5.8. I'm wondering now if it has something to do with the drivers for the Keyspan Serial-to-USB converter (USA-28X B). I've noticed previously that if the weather station is not connected, the software is erratic. I saw another post about this. I'm following that track but if you have any other suggestions, I'm happy to entertain them. Thanks for the input.

  • Ralph Johns (UK) Level 9 Level 9 (70,115 points)

    Don't be sorry. You seem to have explained the issue very well and it can be distracting working at one computer and describing the steps to others when they are not there.

    AS the Java update I mentioned seems to be well before the November period you mention it may not be that.

    I am not familiar with the adapter you speak of (Or anything vaguely similar).
    Is it possible to check this on the other computer ?
    Does the Tower have ports back and front for USB ? My G4 Tower does not but these often connect to different USB Controllers inside the Mac when they do.

    However a Search for the Adapter did turn up this (Says it works if not actually Supported)

    I think at this stage either the Drivers or the viability of the cable/Adapter is worth investigating.

    11:03 PM Sunday; December 19, 2010

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • TanqueVerde Level 1 Level 1 (0 points)
    Thanks to you all for your efforts. This problem began for me on 10/28/10 when I updated Mac OS to 10.6.5. Repeated calls to Davis suggest that they have little capacity to troubleshoot the difficulty (yes, with Java) but are honest and sympathetic about our situation. "Curtis" at support (510) 732-7814 is trying to gather more information from users to inform their research. He got me back to the stage of being able to open Weatherlink for Mac v 5.10 but now I cannot add the proper USB drivers. I regret I cannot tell you how we got there but he may be of some help to you. Please do post further clues here, as will I.
  • Norm Shea Level 1 Level 1 (75 points)
    Back to WeatherLink 5.01! Since it had been so long since I'd been able to access my Vantage PRO (September), I was worried I was going to start overwriting my data. I have a G3 Wallstreet laptop that is running Mac OS 10.2.8. I installed my original version of WeatherLink, 5.01, and the Keyspan Serial-to-USB drivers and I've gained access again. I'd lost about 20 days of data but I'm able to download now. Not an ideal solution but it's an interim fix.

    I tried all sorts of stuff prior to that with reinstalling the Keyspan drivers, going back to previous backups of the WLink and Mac OSX WeatherLink folders, upgrading to the new version of WeatherLink, etc., all to no avail. I too have been emailing back and forth with Curtis Lawton at Davis Instruments. He has been responsive but the suggestions have definitely not solved the problem and seemed like more of a stalling technique than anything else. I'm on a weather observer listserv (not related to any particular instrumentation) and the after having monitored it for a number of years, this seems like a recurring theme with Davis; they make reliable instruments but their software and their software support seem to be lacking, especially for Macs.

    Good luck to all those struggling with it.

  • Ralph Johns (UK) Level 9 Level 9 (70,115 points)
    Glad to hear you have made some progress.

    Lets hope Curtis has sudden inspiration over the Holidays.

    Father Christmas

    6:51 PM Saturday; December 25, 2010

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • TanqueVerde Level 1 Level 1 (0 points)
    Curtis from Davis recently emailed me a fix using a Windows PC for this problem, as below. I had to re-run 'Silicon Labs USB Driver Installer.mpkg' on the Mac again after doing the actions below. That seemed to be the final fix. I'm back up with Weatherlink running off the Mac... after losing two months of data.... Good luck all.

    If the driver software will not load try loading the driver software again from the Install CD and if you still do not get the SLAB_USB to UART option then unplug from the MAC (USB cable) & go to a Windows PC & load the weather link software. Once the software is loaded plug in the USB cable. Create a new station and then do the station configuration & the communications port & select serial & auto detect. Is the station located? Yes then which comm. Port is defined, comm. 11? If no then run the USB to Serial Converter exe from: C:\weatherlink\Support\Utilities\CP210X USB to Serial Converter.exe. When complete then you can check again as serial within communications port and auto detect. Or unplug the cable from the PC (USB cable) and now plug it back into the MAC. Go to setup, communications config and what is defined under ports? If you see the SLAB_USB to UART than select test. Is station found? Yes. Then the third icon will get you the Bulletin information and then close the bulletin and then download the station data (2nd icon) and you are in business.
  • Ralph Johns (UK) Level 9 Level 9 (70,115 points)
    Glad to hear you have made progress on this.

    Thanks for posting the new info.

    8:30 PM Sunday; February 20, 2011
  • Norm Shea Level 1 Level 1 (75 points)
    Just an FYI, I never could get things resolved and ended up using a dedicated Windows machine for my weather station. Seems like a more utilitarian solution because it can run unencumbered by anything else going on with my Mac desktop (and my desktop doesn't have to be on all the time either!). There wasn't actually a ability to upload Weather Underground info with the Mac either; it's not currently supported. Here's the link to my station if you want to check out the weather in SC.


    And here's a link to our station at work.


  • TanqueVerde Level 1 Level 1 (0 points)

    The problem has arisen again:  Vantage Pro connect to a Mac 'loses' the USB configuration that was brought to it via a Weatherlink install on a PC.   Curtis at Davis has the fix, cited at


    Suggest you contact him directly for the detailed document that you will need when you log into the silabs site.