Previous 1 2 3 4 Next 50 Replies Latest reply: Apr 27, 2015 3:02 AM by Computerix2 Go to original post
  • apsapsa Level 1 (0 points)

    Worked perfectly.  Thanks so much!  One of those weird oversights from Apple that leaves me scratching my head.

  • ehander Level 1 (0 points)

    Thank you ever so very much for this wonderful shortcut that even mere mortals like me can use!

  • ehander Level 1 (0 points)

    Spoke too soon....not getting either the Terminal command line or the name swap method to work. Phooey!


    What I'd really like is to change these sounds using my ringtones files.......hmmmm anyone from Apple listening??? 



  • LambertL Level 1 (0 points)

    Dear ehander,

 's been years since I had this problem...I wanted to change from "Basso" to "Submarine", which I liked much better. I was able to do it, but I don't remember much about it, however, here are my notes: one of these two methods apparently worked, I wish I could tell you which one it was: (this was all stuff I took from the thread at the time)



    quit iCal

    > app/utilities/terminal app

    type in: defaults write 'Default alarm sound' 'Submarine'

    check syntax

    press enter/return


    Check (open) iCal, alarms should now use that sound...



    Launch Terminal (Applications > Utilities) and run the following command:


    plutil -convert xm/1~/Library/Preferences/


    Now launch TextEdit and open the "" file from ~/Library/Preferences in your home folder.

    just look for the <dict> tag towards the top. Create a new line right below it and paste these two lines:


    >key>Default alarm sound</key>



    the second line refers to "Blank.aiff" - the silent audio file I created. Replace it with the name of whatever sound effect you're using, whether it is a pre-existing Mac OS X system sound or your own custom file. Make sure it's just the name, though, not the file extention or path.


    Save the .plist file in TextEdit and restart iCal. When you create a new event, your chosen alarm sound should be selected there instead of the standard "Basso"."


    I remember that I was nervous doing this stuff (be sure and check the syntax before you enter/save etc.), but

    that it worked, and I've not had a problem since - must have been a year or two ago.


    Best of luck, let me know it worked for you. - I haven't read through all the replies, hope I'm not just repeating something you've already tried. What I can tell you, is that one of these two ways works. I'm running 10.6.8 (Snow Leopard) so I hope that doesn't make any difference. Cheers, L

  • LambertL Level 1 (0 points)

    um, reading your last entry again, it looks like you've tried both of these ways. Can't think why it wouldn't work for you...all I can suggest is to try again...

  • MikesFruit Level 1 (0 points)

    [The terminal has a defaults command that allows to to do this without messing around your preference files with a text editor (to my mind a sure recipe for disaster if you don't know what you are doing).


    • Quit iCal.
    • Open the terminal (Applications/Utilities/
    • Copy the line below (changing the word Tink to the name of the sound you want) into the Terminal window and press return

    defaults write 'Default alarm sound' 'Tink'

    • Open iCal, new default alarms should now use that sound.


    Best wishes

    John M]



    BEST RESPONSE IN THIS STRING!  Thank you for making things in plain english and easy to figure out, for those of us who aren't tech geeks!  Thanks John!



  • LambertL Level 1 (0 points)

    Right, clearly this is the difinitive answer that works, and would think the thread could be closed at this point. Thanks again, Mike, for the answer to this question. L

  • cube60 Level 1 (0 points)

    NO!! Don;t close it out just yet!!


    I tried the defaults script in Ternimal for Marimba and it would not work.  It used to under Mountain Lion.

  • alexbarthur Level 1 (0 points)



    I've tried both methods, using the strings in BBEdit, and using the terminal commands, but to no avail. I learned that from using the terminal commands, I was able to actually create the string mentioned in the comments about BBEditor before even opening it- once I opened the plist file in BBEditor, the file 'Hero' was already inserted as into the string.


    I am wondering how my defaults could still be making that same noise as before. Please let me know.




  • LambertL Level 1 (0 points)

    can't think why it would be...possibly because of using a different version of the os, or not saving the changes? in the terminal code, restarting? - it's over my head. Maybe it's time to spend 10/20 bucks for one of those online guys who only gets paid if he solves the issue. Sorry I can't be of more help. Cheers, best, L

  • kalina1 Level 1 (0 points)

    Thanks so much!  After trying everything else, these steps worked for me!

  • highestwater Level 1 (0 points)



    Can anyone help me work out what's gone wrong here?


    In OSX 10.9 Mavericks, "iCal" is now called "Calendar". However, I have assumed that preferences are still kept in because there are lots of other settings that I recognise in that file and there is no file called


    Therefore I set about following the helpful instructions in this thread:


    • I closed Calendar
    • Using the termial script (defaults write 'Default alarm sound' 'Tink'), I changed the preferences.
    • I checked that the the file had been amended using BBEdit and yes it has: The entry reads

               <key>Default alarm sound</key>


    • I've closed down and rebooted


    So far so good!


    However, Calendar is still using Basso as the default sound.


    So can anyone suggest what is causing Calendar not to change the default sound.



  • NoBo Mac Level 1 (25 points)

    Been trying to find a solution as well.


    Unfortunately, it looks like a Calendar issue/bug.


    Did the "defaults write..." thing. Value is in-place (did a "defaults read..."), value also in iCal.plist (XCode). Yet, create an event and the actual event data file has a line: ATTACH;VALUE=URI:Basso


    (event(s) are at ~/Library/Calendar/UUI.caldav/UUID2.calendar/Events/UUID3.ics)


    Closest I can get, was to put my custom aiff file in ~/Library/Sounds. Shows up in Calendar alert tones list. Create custom alerts and specify my sound for alerts. Downside, event created on an iOS device will default to Basso, so, have to go into each iOS created event and redo alerts. Ug!


    Guess can do the renaming/moving of the basso aiff file, but, loathe to be tweeking "system level" stuff.

  • NoBo Mac Level 1 (25 points)

    Add another data point: in the configuration I described above, an event created on an iOS device comes over with no tone defined, and when triggered, just brought up the notification window without a tone.


    So, really FUBAR on the OS X side of things re: alerts.


    BTW: this is Mavericks 10.9.2 and iOS 7.0.6 data flow.

  • kalina1 Level 1 (0 points)

    Per Matt Bianco  4-7-2013 in this thread.  I followed his instructions listed below and worked perfectly.  It says
    "Basso" but I hear "Ping" as the default.




    The procedure below worked very easily and flawlessly for me.   The Terminal commands procedure was not working for me.


    0.5) Turn off Calendar


    1) Go to the folder with the sounds are located (HD>Systems>Library>Sounds).  I simply searchd for the file name using Spotlight (magnifying glass in your upper right corner)


    Basso File Name Change.png

    2) Command-C (or File>Copy) the sound you prefer as your default.  I chose "Ping" as my favorite

    3) Paste the file you just copied with Command-V (or File>Paste Item)

    4) When it pastes it assigns a new name to the copied file

    5) Rename "Basso".  As you see above, I changed it to "Basso Original"

    6) Rename the copied file to "Basso"

    Ping to Bass File Name Change.png


    7) Turn Calendar on


    The menu still shows "Basso", but the sound you hear is the file you chose to copy, in my case "Ping"



    You can add other files to your Sounds folder.  And, as long as you name any of them Basso, that new sound will become your default.  Or you can keep the original file names and select them manually.


    As much as I was tempted to install C'Mon Y'All, Wow or  Aooga which you can download from here (link) on my wife's computer, she chose the Doorbell