Previous 1 2 3 4 Next 54 Replies Latest reply: Dec 29, 2015 7:02 AM by ja.12.7887 Go to original post
  • aboveandunder Level 1 (20 points)

    Thanks kalina1, you solved the problem.

     

    Under Mavericks the old trick doesn't work anymore. Calendar resaves the "com.apple.iCal.plist" file everytime it is used and erases the line "Default alarm sound...". It looks like that's why the default sound always reverts to "Basso".

  • sylvic Level 1 (0 points)

    Meidas, if you try HunterS suggestion it will work. You need to tick the box ical preferences 'Add a default alarm to all new events and invitations'. THEN you go and change the script in com.apple.ical.plist as per John Maisey's suggestion on page 1 of this discussion. Hope that helps

     

    alternately, you can open the com.apple.ical.plist

     

    Go to lines 5 and 6

    <key>Add default alarms</key>

              <false/>

     

    Change FALSE to TRUE

    <key>Add default alarms</key>

              <true/>

     

    Then go down to lines 25 & 26

    <key>Default alarm sound</key>

              <string>Basso</string>

     

    And change Basso to GLASS or whatever default sound you want

     

    <key>Default alarm sound</key>

              <string>Glass</string>

     

     

    Cheers

    Syl

  • GrantusM Level 1 (0 points)

    Kalina1,
    Thank you so much for this amazingly simple idea.   I don't know why I didn't think to do this before but you thought around the problem and that's worked out wonderfully.

     

    I've been trying to fix this for weeks and none of the remedies mentioned above worked in Mavericks.

     

    Well done, and thanks again!

  • annabelle Level 2 (460 points)

    I just discovered that iCal or Calendar  uses the first (alphabetical order) sound it finds in your sound folder

    The default is Bass because this is the first one

    but if you add any other one that starts with the letter A, iCal will use that one

    I added the sound Agogo and now all my alerts use Agogo

    You need to copy the sound you want to be used in your  User Sounds folder, no need to change the System Sound folder

    or add an A in front of the name of your favorite one

  • Computerix2 Level 1 (0 points)

    Hi,

     

    here is a solution that is working for me in 10.9.5 (thanks to Wakko from http://iszene.com/thread-165772-post-1927711.html#pid1927711)

     

    1. (Make TimeMachine backup)
    2. Quit calendars
    3. Go to ~/Library/Calendars. Here, for each calendar there is a folder with its UUID (i. e. 9C36543C-8BA1-4264-8E3F-C1BB9FB207BE.calendar). To find out what calendar it is referring to open info.plist within it. Chose the calendar's folder you want to change the alarm sound for. It should also be containging the folder /LocalDefaultAlarms with the two files EventAllDayAlarms.icsalarm and EventTimedAlarms.icsalarm. If it does not open calendars and create a test event in that calendar. Go to 2.
    4. Open EventAllDayAlarms.icsalarm and EventTimedAlarms.icsalarm. Find the line ATTACH;VALUE=URI:basso and change basso to the sound you like. I had to place the sound file in /System/Library/Sounds.
    5. (By the way: If you want to change the default hour for alerts for all day events, change TRIGGER:-PT15H accordingly. PT stands for pacific time, -PT15H means 9 AM (15 hours before beginning of the day).)
    6. Reboot

     

    EventAllDayAlarms.icsalarm and EventTimedAlarms.icsalarm are re-created and reset to basso each time calendar prefs are saved. So, in order to prevent overwriting your manual settings accidentally, set them to read only.

     

    Good luck!

     

    Florian

  • Computerix2 Level 1 (0 points)

    I forgot:

     

    4a. Delete

    ~/Library/Calendars/Calendar Cache

    ~/Library/Calendar Cache-shm and

    ~/Library/Calendar Cache-wal

  • English Bulldogs Rule Level 1 (0 points)

    Excellent workaround, kalina!.  The one step you omitted, which might have been obvious to most, was RE-STARTING the computer in order for the changes to take effect.  I couldn't figure out why following your guidance in re-assigning the sound assigned to "Basso" did nothing when I re-opened iCal. All's well that ends well, though, so thank you.

  • English Bulldogs Rule Level 1 (0 points)

    To change sounds in iCal:

     

    1. Close iCal
    2. Go to Macintosh>HD>System>Library>Sounds
    3. Select the new preferred sound (I chose "Glass"), make a copy of that file, and paste it into the Sounds folder.  The system will alter the name to indicate it's a copy.
    4. Rename the "Basso" file to something else (I chose "Basso-original").
    5. Rename the copied file of your preferred sound to “Basso.” 
    6. Restart your computer.  That should do it.


    This is a workaround, since I could find no way to change the system to look something other than Basso for the iCal default alert sound.  This method allows for updating your alert sound anytime you want, just be renaming the copied file of your new preference "Basso."

  • English Bulldogs Rule Level 1 (0 points)

    After trying for an hour to figure this out, which included a 20 minute call to Apple support, I read the perfect workaround on this string.  I copied and posted it (with one critical extra step) as a reply to Don H.  Good luck!

  • ja.12.7887 Level 1 (0 points)

    Hey Don, 

     

    In El Capitan, I noted that the sounds were stored in system library, not user library; by default, the user library.sounds folder is empty.

     

    However, simply by copying the desired sound (eg. Glass) from the system.library.sounds folder to the user.library.sounds folder, then renaming it so that the first letter is a(n empty) space, it bumps up " Glass" to the top of the list, in the default position (Calendar sorts the sounds (somewhat) alphabetically (as others in the thread noted in part)... it wasn't sufficient to simply rename to "alert Glass" for example).  You may need to close+restart Calendar to see the new addition.

     

    This doesn't yet solve the second question of how to change to default alert to "message with sound", from simply "message", so it would be good to see what answers can be identified for that in El Capitan.

Previous 1 2 3 4 Next