Previous 1 2 Next 15 Replies Latest reply: Jun 28, 2013 9:02 AM by ddelcourt
Elimo Level 1 Level 1 (0 points)
Hi

I have a FTP server on a nas (ProFTPD 1.3.3c Server, Netgear ReadyNAS Duo).
No problems with it until now.
Some FTP clients can not list the folder contents? Strange, do you have a clue?
I think that this problem originates after updating AE to 7.5.2.

Both port 21 and the passive port range are forwarded to the nas.

MacBook Pro 15" (5.3), Mac OS X (10.6.1)
  • Do Right Daddy Level 1 Level 1 (0 points)
    I have the same FTP server configuration, ReadyNAS Duo and AE as Elimo. I too updated from 7.4.2 to 7.5.2. Then all of my FTP clients started reporting passive connection errors and time outs. Here is a proFTPd log snippet where the problem occurs:

    Passive data transfer failed, possibly due to network issues
    Check your PassivePorts and MasqueradeAddress settings,
    and any router, NAT, and firewall rules in the network path.
    FTP no transfer timeout, disconnected
    FTP session closed.

    To fix this issue I simply downgraded back to 7.4.2.

    Are any of the Apple AE engineers looking at this NAT issue?
  • Elimo Level 1 Level 1 (0 points)
    I solved it.

    Apple Airport Extreme does not understand the "Masquerade as" field in the FTP settings in ReadyNAS control panel named Frontview.

    *The "Masquerade as" field must be left BLANK in order to work with Apples hardware.*

    In earlier versions of ReadyNAS firmware (RAIDiator) you could have something written there and Airport Extreme would not care, but after the latest RAIDiator update the field must be left blank.

    Message was edited by: Elimo

    Message was edited by: Elimo
  • Do Right Daddy Level 1 Level 1 (0 points)
    That's great. Now how do I force the "Masquerade As" to spaces and make the blanks stick in Frontview? Every time I blank the FTP setting out, apply the setting, and refresh, Frontview simply re-populates the Masquerade As field with the NAS id. I know I could delete the line from the proftpd.conf file but this is VERY annoying.
  • Elimo Level 1 Level 1 (0 points)
    I am sad to say that it no longer works.

    Right now I don't know why it worked for a while or why it does not work anymore.

    It was not the right method. There must be som bugs in ProFTPd.

    sorry

    I've tried no-ip.com instead of dyndns.org - so far no positive resluts.

    http://www.readynas.com/forum/viewtopic.php?f=23&t=48843

    Message was edited by: Elimo

    Message was edited by: Elimo
  • Elimo Level 1 Level 1 (0 points)
    problem repeared, method did not work
  • Elimo Level 1 Level 1 (0 points)
    Now it works again!

    My method was almost there.

    Masquerade As field should be NAS id (if blank, Frontview will fill it in).

    In AirPort Extreme you MUST make the server the default host (the port mappings are not enough).
  • Elimo Level 1 Level 1 (0 points)
    This is a risky method, with default host.

    It's better to edit the conf file of the readynas
    AllowForeignAddress on

    http://www.readynas.com/forum/viewtopic.php?f=23&t=49034
  • coreyas Level 1 Level 1 (0 points)
    It is most certainly a problem with the 7.5.2 firmware. I had the same problem with PureFTPd on my iMac--I could connect with no problems inside of the network, but not outside--and downgrading to firmware 7.5.1 has fixed my problems. Hopefully this will save someone else time it just cost me.
  • Do Right Daddy Level 1 Level 1 (0 points)
    Any resolution updates on this issue? I am currently sitting on 7.4.2 with a constantly blinking amber light wanting me to upgrade to 7.5.2.

    If I upgrade to 7.5.1 will the blinking light and FTP server issue go away? If so, that will be some progress!
  • paulerob100 Level 1 Level 1 (0 points)
    This is still an ongoing issue - apple are you listening? If so holla back!

    Just bought an aebs to replace a fried linksys router. Figured I would try the sexier look - but seems good looks and brains rarely go together in technology either!

    In my situation I am trying to port map 21 to a Windows Server - all other ports are working just fine to this server (HTTP, RDP, SQL) - but FTP is probably the most important one and is currently failing. Local IP/port 21 request works just fine.

    How do I downgrade to 7.4.x to see if that works for me? All help is appreciated.
  • rblon Level 1 Level 1 (0 points)
    coreyas (or someone else), do you know the status of this problem? I am also using pure ftpd: unencrypted sessions work fine from outside, but encrypted sessions only work from the internal network (see my post: http://discussions.apple.com/thread.jspa?threadID=2815168&tstart=0)
  • diddyho Level 1 Level 1 (0 points)

    I have verified this too.  I have a synology 209 and when I try to FTP and use a non standard external port (such as 4116) to internal port 21, it won't connect.  When I change the port the FTP is listening to on the NAS to 4116...so external 4116 to internal 4116 it works just fine.  Pretty lame, but I guess this bug will need to be fixed before I can get it working as expected.

     

    This is my first experience with a pretty severe apple bug.  I hope they fix it soon.

  • tom259 Level 1 Level 1 (0 points)

    I can verify this issue as well.  7.5.2 firmware seems to be the cause, from what I understand of it.

     

    I've got around the problem for now by using a USB drive and sharing that over WAN instead.

     

    Not ideal - surely Apple can fix this one.  Its definitely a bug!  I can set similar port forwarding/virtual server/firewall configs on pretty much any other router out there.  No issues.

     

    I'm running PPPoE on the AEBS and using a dedicated modem off of a copper line.  I wonder if maybe that's the problem, the fact I'm running the AEBS with PPPoE?  I might try changing to ethernet and having my modem do PPPoA instead and see if that makes a difference.  At this stage I can't really be bothered though - I got everyone used to going to the USB disk now.

     

    Is anyone here running their AEBS in ethernet mode got this issue with FTP?

     

    Has anyone out there got an FTP server working through an AEBS with 7.5.2 at all for that matter?

     

    Plenty of threads out there on this issue, so I'm reasonably sure I'm not being thick-skulled on this one....

     

    Anyone out there?

  • frodeco Level 1 Level 1 (0 points)

    i have the same problem with ftp access from outside. i have a linux based web server for developing websites and realy needed ftp access from outside. after a few times searching, downgrading the firmware of my airport extreme still no success. now i desided to use port 22 over ssh so that i can use SFTP in stead of FTP and everything works fine.

     

    I thought maybe a good tip for others who have this problem.

Previous 1 2 Next