2 Replies Latest reply: Jan 4, 2011 4:59 AM by ragob66
ragob66 Level 1 Level 1 (10 points)
Hi there,

we migrated the 10.5.8 Server of one of our customers to 10.6.5 on a new machine.

Unfortunately we have to problems now that make us crazy. One is related to ichat and is posted here.

The iChat Server doesn't start, there is no Start-button in Server Admin and all configuration options are greyed out.

Seems totally as though this fix should help: http://support.apple.com/kb/TS3178

But it doesn't.

Some more research leads us to this command:

use sudo /usr/libexec/ichatserverinittool -i


That says that the following files already exists and that therefor the process is exiting.

/private/var/run/jabberd
/private/var/jabberd/sqlite/jabberd2.db
/private/var/spool/conference.xserve.ourdomain.de


We renamed these files to *.old and tried it again. After that the initialization went fine but the iChat problems persist.

Now you can find the following problems in the log.

Can not create /var/run/jabberd Permission denied

(It is already there with permission jabber:jabber / 755). Changes are undone after a reboot.

servermgr_jabber[W]: detailed service status not available until network configuration completed


Finally (and this seems to be the point for me)

authenticated as conference.Xserve.local


This is not the correct domain, of course!

But when starting

sudo changeip -checkhostname I get


Primary address = IP-Address of Ethernet1

Current HostName = xserve.ourdomain.de
DNS HostName = xserve.ourdomain.de

The names match. There is nothing to change.
dirserv:success = "success"


Any suggestions how to solve this would be greatly appreciated!

Thanks a lot!

Bets wishes from Germany!

Volker

MacBook Pro (3,1) Intel Core 2 Duo 2,2GHz, Mac OS X (10.5.8), 4GB Ram, 500GB HDD
  • Tim Harris Level 4 Level 4 (1,460 points)
    This is not a unique problem - not sure if that is good or bad news.

    I'm not sure why this happens - that's not good news for me.

    I would like to see the file /Library/Logs/Migration/jabbermigrator.log which is created when the config is updated. You should also file this as a bug and send that same file to Apple. Do you have access to
    ichat, if so contact me on bumfodder at mac.com


    Tim
  • ragob66 Level 1 Level 1 (10 points)
    Hi Tim,

    thanks for your answer.

    The problem is solved for us now. We needed just another restart. After rebooting the domain was correct, too. Nevertheless we mentioned that this behaviour (all is greyed out) comes back when no network connection is available. So it seems worth a try to check the network connection if this problem occurs.

    Thanks a lot!

    Best wishes

    Volker