Previous 1 2 Next 23 Replies Latest reply: Jul 16, 2011 6:01 AM by psorensen Go to original post
  • brandonbowersox Level 1 (0 points)
    I agree. After installing the new Xcode 4 I got this error every time.

    Solved by re-downloading iTunes (http://www.apple.com/itunes/download/) and re-installing.

    I did need to re-enable contacts syncing.

    (This was on Mac 10.6.6 iTunes 10.2.1 with an iPhone 4 and the version of Xcode 4 downloaded from the Developer Center, not the $4.99 purchase on App Store.)
  • weshsu Level 1 (0 points)
    David,

    Thank you SO much. This, too, solved my problems. My situation was rather unique. A SuperDuper! backup decided to fill up my boot SSD. Of course, I didn't understand what filled it up until after I deleted Xcode 4, since I knew that would instantly free up 9+GB. Once I found the culprit, I installed the latest Xcode 4 only to be greeted with the error message. I then deleted it and copied /Developer from a recent backup. I still got the same error message.

    Following these steps fixed my problems.
  • Willem4Ever Level 1 (0 points)
    Same issue after installing xcode ... pulled my hairs out last nite and decided to call it the day, found your solution this morning and problem was resolved ...
  • zyber17 Level 1 (35 points)
    I was getting the same error. Just followed your instructions and they worked like a charm. Thanks!
  • Vinko Level 3 (955 points)
    I too had this problem and problem backing up my iOS devices, after I upgraded them to iOS 4.3.1 while also installed the latest iOS development tools.

    David's suggestion resolved my problems. Thank you.
  • jefesín Level 1 (0 points)
    Thanks Mark Levitt1.

    I encountered the same issues after installing xcode4. That 'streamlined' reinstallation worked without any rebooting or messing around manually deleting stuff.

    Back in business.
  • BigAl617 Level 1 (0 points)
    Thank you David! This worked for me. I updated to Xcode 4 under Mac OS X 10.6.7 today and started receiving the error messages. I followed your recommendations and everything is now copacetic.
  • nomby Level 1 (0 points)
    This is the KEY problem to the upgrade to IOS 4.3.1 if you purchase Xcode 4..you get all the back up and other issues hassles..thanks for solving the problem Mr Brady it is greatly appreciated.
  • psorensen Level 1 (0 points)

    I too had the "iTunes was unable to load provider data from Sync Services. Reconnect or try again later." problem with my devices today. Couldn't sync nor update.

     

    In iTunes all my backups wasn't showing under devices, yet they were all fine showing in the folder system under /Library/Application Support/MobileSync/Backup/.

     

    A couple of days ago I updated Xcode to IOS 4.3.1, I wonder if this was the problem too?


    My solution was to download iTunes again and install it, without uninstalling the one that was already installed.

    I then restarted the computer, and all my backups were again showing under devices in iTunes and I could again sync and update.

Previous 1 2 Next