1 Reply Latest reply: Dec 25, 2010 10:28 AM by Jolly Giant
Chris SD Level 1 (0 points)
Merry Christmas...

My IMac G4 is running Safari and is updated with latest 10.4.11, new G4 ITouch wants latest ITunes 10.1.1. My issue is the error message when I try to load this latest version of ITunes. Here's the message, *"Couldn't open "Install iTunes.pkg". This package type requires Mac OS X 10.5."*

Is this due to my desktop running Safari? How to I get around this to be able to use the IPOD Touch?


IMAC, PowerPC G4, Mac OS X (10.4.11)