0 Replies Latest reply: Dec 25, 2010 11:39 AM by fbprod
fbprod Level 1 Level 1 (0 points)
After upgrading both my old and my wife's new iphone 4s to the latest software my wife's iphone could not longer read her sim card. Here is what we've done so far to try to fix the problem... all to no avail.

1 We took her card out and repositioned it.
2 We reset her network settings
3 We put her sim card into my iphone and it worked there so we know her sim card works
4 We put my sim card into her iphone and it worked there so we know her iphone works
5 We then turned off her iphone, let it sit for two minutes then put her sim card back into her iphone and once again it said "No SIM card installed" when the phone started and the words "No SIM" remains in the upper right hand corner of the screen.
6. When we attach the iphone to her Macbook to try reinstalling the software we get the message "There is no SIM card installed in the iPhone you are trying to activate. Please disconnect and insert a SIM card in the iPhone"

Any suggestions?

iphone 4, iOS 4