1 Reply Latest reply: Dec 26, 2010 1:47 PM by TeenTitan
aapl.crox Level 1 Level 1 (0 points)
I'm trying to get an mac mini running snow leopard server to join a windows domain here. The windows domain server is running Windows server 2008.



When I go to "Accounts" in my System Preferences, and lick on "Join", I get this error: "Unable to add server. Node name wasn't found. (2000)"


In my console messages I find this:

10-04-06 11:42:25 AM System Preferences[1452] -[ODCAddServerSheetController handleOtherActionError: gotError: Error Domain=com.apple.OpenDirectory Code=2000 UserInfo=0x2004f2f80 "Custom call 82 to Active Directory failed.", Node name wasn't found.



I specified a FQDN for the domain server, so I am totally confused as to why it would list "domain = com.apple...." in that error.


I've tried firing up the Directory Utility and trying to join a domain via the Active Directory option there. Again I fill in the FQDN, and the proper administrator/password acount info. Now I get a different error:


"Invalid Domain

An invalid Domain and Forest combination was specified. You should enter a fully qualified DNS name for the domain and forest (e.g., ads.company.com)."



If anyone has any pointers or suggestions this would be appreciated.
  • TeenTitan Level 4 Level 4 (2,410 points)
    I would use directory utility instead of system preferences. It gives you better control over bind, search path, extra.

    Have you set the timer server to the AD? time is really important in bindings.

    I would also verify the FQDN. Every AD i've seen has the FQDN messed up; mostly because the AD isn't picky about it. http://support.apple.com/kb/ht3394 explains how to verify the AD FQDN.
    have you tried binding to the AD by ip address instead of FQDN? If so dose it bind?