13 Replies Latest reply: Oct 11, 2015 7:47 AM by Get Rich
Hazza42 Level 1 (0 points)
I'm currently experiencing a bug where iTunes automatically chooses my Apple TV as my speakers and screen (over AirPlay) instead of my computer. So whenever I play a movie/TV show, I have to manually choose 'Computer' from the dropdown box to get it to show on my iMac and stop it from playing on my Apple TV downstairs. What's worse is that it resets to my Apple TV after every video, meaning I have to reselect my speakers every time I pick a new track. I've tried reinstalling, restarting and updating (both Apple TV and iTunes), I can't think of any other way to stop it short of turning off 'Look for remote speakers connected with AirPlay' in preferences and losing a great feature...

Needless to say, the whole thing is extremely irritating!
I was wondering if anyone else is experiencing this, or if I'm missing something in settings?

Heres a video I took of the bug in action: http://www.youtube.com/watch?v=zZc04w7Akew

Thanks in advance!

2010 27" iMac, Mac OS X (10.6.5), 3 GHz, 4GB RAM, 1TB HD
  • Hazza42 Level 1 (0 points)
    Argh!
    No sooner had I posted this, I found a fix!

    To any and all still experiencing this issue, just click on the little AirPlay symbol in the bottom right of the iTunes window and click on 'Multiple Speakers'; then check your AirPlay speaker that iTunes is automatically using, and then uncheck it! Simple.

    Now it should work perfectly!
  • H Scott Level 1 (10 points)
    Thanks for taking the time to post the solution to your own problem -- that's exactly the issue that brought me here today, and what you specified worked for me as well. Thanks!
  • H Scott Level 1 (10 points)
    Ugh... unfortunately, iTunes keeps reverting to sending audio and video on the Apple TV. If, for example, my wife is watching Netflix via the Apple TV, and I start a movie in iTunes on our iMac, she gets bumped out of her program.

    I must be missing something... some way to make the settings stick; otherwise it seems more people would be running into the same problem, but I don't see people making such complaints.

    Any ideas?
  • Racm1 Level 1 (0 points)
    Same here, this one has me stumped. Have reset, restarted, renegotiated all connections.
    My computers grab the apple TV instead of playing locally regardless of settings. One can "force" playback locally one item at a time but it will goof up whatever is happening on the Apple TV (small black puck version). Bug is new since the last round of updates. Level one apple cust service insist it isn't happening and that I am imagining it. Did not have the time and energy to escalate the call - why do they have to make it so hard to report a problem??
    Our workaround for now is to turn off airport on the computer that is trying to watch something locally.
  • David Lee10 Level 1 (5 points)
    I am having a similar problem with airplay but it is on my iphone.
    I have a sony xplod car stereo receiver which can take bluetooth calls as well as stream music from the iphone4. I recently purchased a jawbone bluetooth headset but everytime i answer a call and then hang up the iphone defaults to the iphone speakers and not the sony speakers. I have to go into the airplay window on my iphone every time after a call to reselect the sony xplod speakers. This is just irritating. Has anyone hear of a fix?
  • Toyworks11 Level 1 (10 points)

    OK, this is just my crappy luck. I have the same problem with itunes playing my movies automatically to my AppleTV. I went to the drop down box thing with my AppleTV on it, but there is no box to uncheck, just my 2 ATVs and Computer.

  • jenericloches Level 1 (0 points)

    Same problem here.   Must be a programming error.  Apple?  You there?  knock-knock....

  • danmoose Level 1 (0 points)

    I have the same problem on a MacBook.

    I have MacBook Pro and two Mac Minin, one iMac and another MacBook and everthing is fine ther.

    I have Deleted iTune preferences file, run Onyx, DiskWarrior, reset Parameters deleted Finder Preferences file, cleared Cache on user and System, repaired Permissions I have compared settings in iTune to another computer and all settings are the same.

     

    After all this no solution,

    Now I am trying installing latest MacOs 10.7 combo update I hope that will fix it.

  • danmoose Level 1 (0 points)

    Found a solution

    Installing Mac Os 10.7 combo update does not help

     

    The solution I found is a lame one

    You need to open Air play in lower right hand corner and chose Apple TV and close the window, the you need to open it again and select Computer and close

     

    That did it for me... 

  • therealdeffi Level 1 (0 points)

    danmoose is right!

     

    1.You have to click the Airplay-Icon, chose Apple Tv (Airplay-Icon now is blue)

    2. You click the Airplay-Icon again and choose your PC/Mac

     

    Now its working correct - when your starting a Film, it will be shown at your pc and not at AppleTV

     

     

    By

  • otoy02 Level 1 (0 points)

    I can't find the airplay symbol on the iTunes window. Can you please be a little more specific. I'm using Macbook Pro

  • hubcityallday Level 1 (0 points)

    worked. thanks.

  • Get Rich Level 1 (0 points)

    My computer shower Computer checked as default, but ITunes was defaulting to my Apple TV and preventing my movie from playing.  This solution worked for me. 

    1. When nothing is playing, click the airplay and set Apple TV to default, then close the Airplay drop down.
    2. Open the Airplay dropdown again, and set the default back to computer.
    3. Try playing your movie again.

    That finally cleared it up for me.