Previous 1 2 3 Next 40 Replies Latest reply: Apr 7, 2013 4:33 PM by blee4
daniel4632 Level 1 Level 1

Suddenly my VPN connection to my iMac stopped working. Using iVPN and L2TP. After some tests and thinking I thought the problem must have to do with firmware update of my AirPort Extreme to 7.5.2. I don't remember what version I ran before the update. I guess 7.5.1 since I always do update if there are any. Anyway. One last desperate thing I did was to downgrade the firmware via AirPort Utility to 7.4.2. 7.4.2 is the 2nd latest version available in AirPort Utility. Now the iVPN connects again. I couldn't see anything in the logs in my AE when running 7.5.2 pointing to port forwarding issues.

-- Daniel

MacBook1,1, iPhone 4, iMac9,1, Mac OS X (10.6.1)
Solved by Changren Yong on Nov 10, 2011 9:38 PM Solved

Updating to 7.6 finally fixed the VPN issue!

  • Douggo Level 4 Level 4
    With what little I've seen, the 7.5.2 firmware seems to invoke troubles with port-forwarding or changes the ports that are open de facto, re: this post dealing with netboot issues with the new firmware.

    I just did the upgrade on my home AEBS, and it was the first one that had come up - jumped from 7.4.2 to 7.5.2

  • Martin De Bernardo Level 1 Level 1
    I can confirm that the Firmware update 7.5.2 brakes the VPN for L2TP. I was not able to access my OS X 10.6.5 server anymore after the update. Rolling the Firmware back to the previous version fixed the issue.

    How do I get ride of the yellow light telling me that there is a firmware update? I want to see the green light since I would not notice if there are any other issues. I just lost my internal drive in the TimeCapsule and if I had not seen the yellow light I would not have noticed that the drive was failing.

  • MrHoffman Level 6 Level 6
    There's a setting in AirPort Utility to clear the fault LED. IIRC, AirPort Utility > select device > Manual Setup > Airport > Summary > Click on the Yellow indicator. I don't have one throwing a fault right now to confirm this.
  • Changren Yong Level 1 Level 1
    I have the same issue too. After updating my Airport Extreme router to 7.5.2, iVPN quit working when i attempted VPN to my server from outside my home network. The interesting thing to note is i was able to VPN to my server from within my own network. When i removed the port forwarding VPN settings in the Airport Extreme, trying to VPN to the same server from the same network failed. So AE is definitely doing some port-forwarding, it's just not doing it correctly when connected from outside my network.
  • Terry Fundak Level 2 Level 2
    Add me to the list of people where the Airport Firmware update broken something about port forwarding for VPN connections...... Hey Apple ! not good!
  • Richard May Level 1 Level 1

    I will also confirm that the 7.5.2 firmware upgrade is the culprit.

    I went as far as rebuilding the server from scratch, 10.6-10.6.6.

    The vpn would work intermittently, then quit altogether. As one of the other posters discovered, local vpn connection would work.

    Remote vpn would fail. Since my extreme is behind a uverse router, I was looking there first.

    After changing to 7.4.2, all works fine. Updated back to 7.5.2, immediate failure, Return to 7.4.2, all working again.
  • Terry Fundak Level 2 Level 2
    Hi Richard,

    I also was jumping thru loops looking for why VPNs stopped working...... It took me more than two weeks to realize it was the ABS firmware update because of time delay between applying the update and when VPN problems were reported to me.... I also was in the process of rebuilding a full server when it became clear that it was not the server itself that was the issue. Portscanning to the ABS was giving no indication that the VPN related ports were open on another ABS that also had a firmware update..... Then the light went off..... After finding this thread I downgraded the ABS and VPN was back.....

    I then went and downgraded 4 other base station and that fixed VPN on those also ( 4 different networks.... ) So, 100% confirmed! What is Apple doing in their testing? or has anyone got'n the new firmware to work with VPN ports forwarded?
  • Level 1 Level 1
    Discovered other problem with this FW.
    Got a time capsule connecting to internet and using wide channels to hook up a airport express (extending the network). Had bad downloads of apple updates (corrupted DMGs etc..) on both the imac which is wired connected to the express) as well as from the MBP connecting via Wifi.
    Downgraded both to 7.4.2 and problems are gone.
    I now really get upset that both devices turned yellow as I didn't upgrade to the latest version !!!! (which clearly has problems)
  • Douggo Level 4 Level 4
    I just finally had the chance to check VPN connections through my AEBS, and lo !! - L2TP and PPTP work on my unit, and I confirmed that it is running the 7.5.2 firmware. So this is not a completely universal problem with the firmware. Might be more specific to certain model runs? Dunno..

  • emanuelme Level 1 Level 1
    Was working for me... stopped. not sure why. when i connect directly to the modem, it always connects (pptp and l2tp) but through the router on 7.5.2 it doesnt. on 7.4.2 it seems to work although some probs still linger... ideas?
  • mountainbike2001 Level 1 Level 1
    I can complicate this issue folks.. I have an Airport Extreme running 7.5.2. Using my old work DELL pc, I was able to connect via the Nortel VPN on that machine NP. NOW, Ive just upgraded to a MBP and CANNOT connect to my corp VPN via the Airport Extreme!!!!!!!!!!!!!!!!!!!!!!!!!

  • emanuelme Level 1 Level 1
    I connected an old airport base station as the primary router and vpn worked (pptp connection). When I connect directly to the modem, it works as well. So it MUST be a problem with the router and perhaps with the mac hardware. I have tested windows but only on the mac and it seems to have the same problems. I downgraded the firmware to 5.4.2 but I still have the issues... Ideas?

  • ajk99 Level 1 Level 1
    Where can I find the 7.4.2 download? All links seem to end up here, rather than with an actual download.
  • Douggo Level 4 Level 4
    You can download the 7.4.2 firmware here.

Previous 1 2 3 Next