Previous 1 2 3 Next 40 Replies Latest reply: Apr 7, 2013 4:33 PM by blee4 Go to original post
  • GSOY Level 1 Level 1 (15 points)
    Although I didn't have problems with my VPN setup besides a sometimes slow connection, I experienced a severe drop in WiFi transfer rates when updating my AEBS to 7.5.2.

    Cf. these threads:
    http://discussions.apple.com/thread.jspa?threadID=2688269
    http://discussions.apple.com/thread.jspa?threadID=2690381&tstart=0

    After reverting back to 7.4.2, everything is back to normal.

    It seems that the bugs in 7.5.2 do not apply to the newest AEBS Dual-Band models, as some users report no problems with the latest firmware. However, people like me who bought an AEBS back in 2009 (Model A1301) experience various issues. I don't know if it's something hardware-related, but I guess the engineers at Apple did not test the update thoroughly on older base stations.
  • Scott Reynolds1 Level 1 Level 1 (10 points)
    Unfortunately, both download links in that article send you back to HT1218. Still looking for the 7.4.2 firmware...
  • Terry Fundak Level 2 Level 2 (150 points)
    Prior Version of Firmware are typically stored in your base station.

    In Airport Utility, Select your base station. Select "Manual Setup". In the Summary tab - click on the word "Version". You should see various versions of firmware. Select the one you'd like.

    If this work.....then it's EZ. If it doesn't then...... one needs more help I guess.....good luck.

    Terry
  • Scott Reynolds1 Level 1 Level 1 (10 points)
    Only version 7.5.2 was listed. However, I found a copy of the older firmware on my work laptop. As soon as I copied the 7.4.2.basebinary file to my home machine, a whole list of other versions appeared like magic, just as you suggested.
  • emanuelme Level 1 Level 1 (0 points)
    Reverting to 7.4.2 didnt help my vpn errors... Any ideas???
  • Terry Fundak Level 2 Level 2 (150 points)
    Really need more information. I found my issue to be that upon port scan of the External interface / WAN interface / Public interface from the internet ..... that the VPN ports through forwarded were not visible - meaning that the software upgrade that hidden or closed the ports. Other ports were fine. I attempt to delete and add the ports back in , but that changed nothing.

    Only downgrading to 7.4.2 on three of my seperate gateway Airport Base Station cleared the issue.
  • Douggo Level 4 Level 4 (2,740 points)
    From the KB article the download page takes you to:
    AirPort Utility keeps an archive of all Wi-Fi Base Station firmware updates you install, and stores them in the location below.

    Mac OS X: ~/Library/Application Support/Apple/AirPort/Firmware
    Windows: ~/AppData/Local/Apple/AirPort/Firmware


    Sure enough, the 7.4.2 firmware was stored there.

    -Doug
  • emanuelme Level 1 Level 1 (0 points)
    Downgrading to 7.4.2 doesnt seem to help. VPN on my macbook works intermittently with a reset to default settings. When I set the AEBS to bridge mode, I can connect pptp fine but I limit the amount of computers I use to just one.... How can I get pptp to work on AEBS?

    Also, when it does work distributing a range of ip addresses, it is slow? Please help me
  • mr.pixel Level 1 Level 1 (0 points)
    Hi all,

    I recently experimented with settings on Base Station, after resetting to original settings, connectivity to private network was lost. I could no longer access the internet from laptop.

    Please excuse old setup, but it was working fine until then with 7.5.2.

    Tried to revert to 7.5.1, but no go. Don't have a copy of 7.4.2 (any idea where I can get it?)

    I'm an amateur; I assumed that settings in bootptab would lead me to a solution, but couldn't even find that.

    Any help appreciated.
  • mr.pixel Level 1 Level 1 (0 points)
    Just noticed that the only service not available from LAN is dns. The Airport Extreme Base is on the LAN. All external services working fine.

    Thanks for any help.
  • siamless Level 1 Level 1 (0 points)

    I can confirm that the 7.5.2 firmware version is not working correctly when trying to connect a iPhone or iPad. After downgrading both, my Extreme and Express (n) station to 7.4.2 I could connect again to my network. Unfortunately it seems that the avarage speed is lower now...

  • Knownone Level 1 Level 1 (0 points)

    It is possible to get L2TP VPN working with the 7.5.2 firmware on AEBS and Time Capsules, but the default config for L2TP VPN is broken in 7.5.2. I got it working by going Advanced -> Port Mapping on my AEBS and then changing(adding) the L2TP settings to include port 1701 open on TCP as well as UDP so the setting as follows seem to work:

     

    Public UDP Port(s): 500, 1701, 4500

    Public TCP Port(s): 1701

    Private UDP Port(s): 500, 1701, 4500

    Private TCP Port(s): 1701

     

    Setting the above Port Mapping rule and then restarting the AEBS or Time Capsule followed by restarting the VPN Service on Snow Leopard Server seems to solve the problem (at least it did for me). It works both inside and outside the firewall on my setup.

  • jeffmr Level 1 Level 1 (35 points)

    It doesn't work for me.  I have all those ports open and have restarted.  Where can I find the 7.4.2 firmware? its not in the airport folder and versions of the firmware for older tcs don't work.

  • ibosie Level 4 Level 4 (1,115 points)

    Link to Airport 7.4.2 firmware:

    http://support.apple.com/kb/DL849

     

    I don't know that it's possible to install older firmware on newer devices though.

     

    This post explains the problem in more detail:

    https://discussions.apple.com/thread/2357772

     

    Back-to-my-Mac (including any MobileMe members saved in Airport Utility > Advanced) uses the same VPN ports and firmware 7.5 seems to bind with this service when there are Macs on the network - whether or not those Macs have BTMM enabled the preparation is assumed. Sometimes resetting or restarting the base station provides a brief window to connect until the bind is re-established and locked down. When I looked at this issue some time ago, I discovered 7.4 firmware is able to increment on the ports until it finds one available which means both BTMM and VPN can coexist. However on Mac OSX Server it is sometimes required to stop and restart the VPN Service for this to happen. The VPN issue is known to Apple but has not been addressed in 16 months but it will be interesting to see what happens in the next generation of Base Station and the iCloud service - hopefully the ability to VPN using Apple DHCP routers will be restored.

  • iamzood Level 1 Level 1 (0 points)

    I have an answer, but it has taken a long time to figure it out.

     

    I have a Mac Pro, running behind an Airport Extreme 811N router.  I ran OSX Server 10.6x and after I did the upgrade to 7.5.x firmware on my airport the L2PT service died going thru my router.  I simply switched to the PPTP VPN because it appeared to work fine.  Then I upgraded (or downgraded) to 10.7x Server.  When I did that they got rid of PPTP as an option, and my L2PT connections still did not work.  I went looking online for answers, and found alot of references to the 7.5.x firmware.  I ran a test to see if I could connect to the VPN internal to the LAN - thereby bypassing the router as an issue.  It worked flawlessly.  It definately had something to do with the way 7.5.x handles a packet.

     

    After several trial/error sessions, I figured out that it was the DCHP service on the Airport Extreme that was causing the problem.  For whatever reason if you have DCHP assign the IP address to your VPN server, it will never work.  I took the server out of the DCHP pool, and gave it a static IP.  Once I did that and correctly configured the interface on my server (be sure to setup the DNS correctly if you use static IP) I was able to get the VPN to work flawlessly.  Was even able to turn the Back to my Mac feature back on.

     

    Don't know if this helps, but I have personally logged 3 days on this problem over the last 2 months.  I am pleased it is resolved.